My fingerprint reader is not detected

I have asus vivobook x509ja laptop in which i recently install fedora 34, but i am unable to access my fingerprint reader. Please Help!

Hi, look at this post:

lsusb command is not detecting my sensor.

Post here output of lsusb and lspci.

Text was better than screen-shot, just use Ctrl+E with selected text to apply formatting of console output.

Check whether fingerprint reader is enabled in BIOS.
Maybe it’s integrated with touchpad? Run cat /proc/bus/input/devices |grep -i name

N: Name="Lid Switch"
N: Name="Power Button"
N: Name="Power Button"
N: Name="AT Translated Set 2 keyboard"
N: Name="ELAN1200:00 04F3:3087 Mouse"
N: Name="ELAN1200:00 04F3:3087 Touchpad"
N: Name="Video Bus"
N: Name="Video Bus"
N: Name="PC Speaker"
N: Name="Asus WMI hotkeys"
N: Name="HDA Intel PCH Headphone"
N: Name="HDA Intel PCH HDMI/DP,pcm=3"
N: Name="HDA Intel PCH HDMI/DP,pcm=7"
N: Name="HDA Intel PCH HDMI/DP,pcm=8"
N: Name="HDA Intel PCH HDMI/DP,pcm=9"
N: Name="HDA Intel PCH HDMI/DP,pcm=10"
N: Name="HDA Intel PCH HDMI/DP,pcm=11"
N: Name="HDA Intel PCH HDMI/DP,pcm=12"
N: Name="USB2.0 VGA UVC WebCam: USB2.0 V"

The bios does not mention fingerprint sensor distinctly.

It’s probably Elantech device connected through SPI instead of USB. A driver is being worked on, you can contact the developer and help by testing it:

@vatsal, the driver has been merged and released, have you tried libfprint 1.92?

There’s a F35 version that you could use for testing purposes: