Fedora Silverblue Installation Issues on my Laptop

Hi. Sorry If this is the wrong place to ask, but I am trying to install fedora silverblue on my laptop (new to linux) with the following specs

ASUS ROG Strix GM15_IM

  • AMD Ryzen 4800H
  • Nvidia GEFORCE RTX 3060 Laptop
  • 64GB 3200MHZ ddr4 RAM
  • 1tb NVME ssd

The Problem I had was when installing Silverblue, the display manager wouldn’t start. I figured it was a driver issue. So I installed it in the text-based installer. After installing, I rebooted, the grub menu showed, and when I select Fedora Silverblue, it will begin booting, showing the usual CLI output, and ends with “BTRFS info (device nvme01p3): Autoenabling async discard”. I left it to sit out, but after 1.5 hours, it still wasn’t booting. I tried a different installation media, still to no avail. (Pop!_OS worked, so i’m not sure if it’s a hardware issue.) Thanks for any help!

UPDATE:
Now it boots to a TTY shell. Thanks, @computersavvy now I just need to get drivers configured, which i’ve done on fedora workstation before

UPDATE 2:
I reinstalled with a different install media and set the “nomodeset” boot paramater on the installation media and everything works now. Thanks for the help

I suspect the issue is the nvidia GPU. If you can see the grub menu during boot then press e to edit the command line and add nomodeset into the line that begins with linux

If that allows you to complete booting then install the nvidia drivers from rpmfusion. The instructions here tell how to do that, but are written for fedora using dnf. The fact that you are using silverblue means the commands are different, though the repo is the same.

Thanks! Now it just boots into a TTY shell. What do I do next?

There are ostree/Silverblue instructions available on that same page, too - Howto/NVIDIA - RPM Fusion

sudo rpm-ostree install akmod-nvidia xorg-x11-drv-nvidia
sudo rpm-ostree install akmod-nvidia xorg-x11-drv-nvidia-cuda #optional if using nvidia-smi or cuda
sudo rpm-ostree kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init