Fedora SIlverblue 38 Brother DCP-1610W not working


i tried to setup my printer by following the instructions on the brother website, (here are the instructions if needed)
Screenshot from 2023-12-04 13-41-35

When i try to do this i get this output on the terminal

And when i try to print the pages comes out blank, also the printer uses all the paper sheets.
here’s a printer settings screenshot

Should i install these drivers on a toolbox/distrobox then?
Thanks for any suggestion

Is there a reason you’re trying to use the RPMs from Brother?

Fedora has built-in support for most printers and scanners these days (for the past couple years), including Brother ones. You shouldn’t have to install any third party RPMs for support. (And, as you’ve seen, the RPMs aren’t really useful anyway, especially on Silverblue, as the packages do odd things.)

For reference: I have a Brother MFC-L2750DW.

Here’s what it looks like when I go to GNOME Settings, in the Printers area:

(Printer is autodetected and it uses the “driverless” support.)

When I open up Document Scanner (aka: “Simple-Scan”), it searches the network for a few seconds…

Then finds the printer+scanner combo:

This is how it’s been in Silverblue for several releases. I didn’t have to do anything special, aside from installing “Document Scanner”, which is available in Fedora and also on Flathub.

This is in Fedora 39 Silverblue, but it was just like this in the previous few versions of Fedora as well.

You are using commands that are based on the regular fedora spins that use dnf for package management. It seems you are using an ostree based variant (silverblue) so those commands do not work correctly and must be modified to work with rpm-ostree.

Thanks for answering, i tried what you said but it seems that my printer is an older model so it doesn’t work without the drivers.

Thanks for answering, do you know any guide for executing those commands on silverblue.

So most printers in the past decade support driverless printing. It seems that yours was made right before the transition from drivers to driverless support. :slightly_frowning_face:

If you’re trying to use RPMs, then you’d need to do rpm-ostree install *rpm (assuming those are the only RPM files in the directory). Silverblue doesn’t support dnf, except in toolboxes (which are not the host system). But you need printer drivers on the system, not in a toolbox.

However, years ago, this method did not work with various printer drivers, as they sometimes try to put files in /opt/ which doesn’t work as expected in Fedora, especially Silverblue (which, at least at the time, did not support that). But since then, there has been work to support a subset of RPMs that place things like drivers in /opt/. I believe this was with relocatable RPMs? Anyway, it might work now, and you should definitely try it.

So, in summary: rpm-ostree install *rpm (or the RPM file names), then hope it works, and reboot. Then it might work? But it also might not. You might need to search for your printer if it’s not auto-detected.

After installing those RPMs, if it’s successful, and if it’s not autodetected, then adding would look something like this, in GNOME, in the printer part of system settings:

If it doesn’t have the right driver but it does see your printer, then you’d change it like this:

selecting printer details
(Select printer details from the printer’s menu, if the printer is in your list. You’d first have to “unlock” the page with your password.)

clicking on the "select from database..." button

On the details page, you’d click “select from database…”

Screenshot from 2023-12-08 12-53-55

And you’d see a dialog with printer drivers. This one doesn’t have your printer shown, but if installing the RPM with rpm-ostree install (and the RPM files) was successful, after a reboot, then you should see your printer on the list.

(Note: If your printer is detected and set up properly by default after installing the RPMs and rebooting, then you wouldn’t even have to do the above steps.)

Sorry I can’t help any further.

If this doesn’t work, then you might need to use Fedora Workstation instead, if you want your printer to work. Or install an OS in a VM and print from that. Neither are ideal (reinstalling or using a VM for printing). Hopefully the rpm-ostree install method with RPMs will work for you.

Also: Please come back to the forum to share with us if this was successful or even if it was not. Thanks! Best of luck!

I tried what I suggested within a VM.

With these files, downloaded from Brother:


I ran this in the terminal:

cd Downloads
rpm-ostree install *rpm

It successfully added these to Fedora 39. (I realize now I tried this in Fedora 39. It most likely works exactly the same in Fedora 38.)

After a reboot, I was able to confirm that the driver was installed and shows up in GNOME Settings, in the printer section:

Screenshot from 2023-12-08 13-31-54

As I don’t have your exact printer, I can’t test that it prints. But it appears everything should work!

When your printer is properly configured, it’d look something like this:

Pay attention to the model specifically; it should state “DCP-1610W for CUPS” and the status should hopefully be “Ready” too. (The name of your printer will be different; I changed it here in this screenshot.)

The specific printer drivers that I’ve downloaded are the ones in purple here:



I’ve linked the individual ones here, on the list directly above. I hope that makes it even a little easier. :wink:

You specifically do not want the the “driver install tool” or anything that’s 32-bit. And you probably don’t need or want “scan-key-tool”.

(I can’t test the scanner installation at all. Hopefully that works too. It does install the package. I think you don’t need anything else. If you do, then possibly the “setting file”? But it hopefully works with just the driver.)

Download those three files, feed them to rpm-ostree install from the command line (as mentioned above), reboot, and you should be good. If you are using *rpm instead of the specific file names, make sure you don’t have other RPM files in your “Downloads” folder, else it might not work as expected. And also make sure you run the command from within your Downloads folder (as mentioned above, with the cd Downloads command).

Good luck! It looks like this will very likely work for you! :+1:

1 Like

I don’t know what to say man, thank you very much you’ve been very helpful, unfortunately it seems that either i’ve done something wrong or it doesn’t work for my model, so i made a mint virt manager vm for printing, but i’m gonna try this again in case i want to reinstall the system. Again thanks man you’re the best

I had the same issue as the OP with my Brother DCP-1610WE printer.
Following the steps described by @garrett, I was able to print successfully. However, after installing the Flatpak versions of KDE Skanlite and GNOME Document Scanner, I encountered issues with the scanner. For those reading this discussion in the future, I was able to resolve the issue by installing KDE Skanlite through package overlaying. The scanner was then detected without any problems.

OK, I’ve tried to configure this device on a second computer with Fedora Kinote, but this time I’m having problems.
I think I’ve done it exactly the same way as before, but it’s not working. I mean, the printer does not work, but the scanner does, which is even stranger.
I connect the printer to the laptop with a cable. I’ve installed the following packages from this webpage:

  • brscan4-0.4.11-1.x86_64.rpm
  • dcp1610wcupswrapper-3.0.1-1.i386.rpm
  • dcp1610wlpr-3.0.1-1.i386.rpm

I also switched to the rpm version of Okular to make sure this wasn’t the problem. Unfortunately not. Printing a test page from the printer settings does not work either.

Do you have any idea what can be a problem?

rpm-ostree status:

● fedora:fedora/39/x86_64/kinoite
                  Version: 39.20240111.0 (2024-01-11T00:40:17Z)
               BaseCommit: dbceb2811c61829bd2750192bfefc1945ffd2e5db4671b3aa30670bd2b373ca6
             GPGSignature: Valid signature by E8F23996F23218640CB44CBE75CF5AC418B8E74C
      RemovedBasePackages: gnome-keyring gnome-keyring-pam 42.1-5.fc39
          LayeredPackages: gstreamer1-plugin-openh264 mozilla-openh264 okular skanpage
            LocalPackages: brscan4-0.4.11-1.x86_64 dcp1610wcupswrapper-3.0.1-1.i386

Operating System: Fedora Linux 39
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.111.0
Qt Version: 5.15.11
Kernel Version: 6.6.9-200.fc39.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Manufacturer: LENOVO
Product Name: 20L8S0SA00
System Version: ThinkPad T480s