Brother scanner drivers issues

Hi, I have correctly installed the drivers for printer/driver Brother DCP-J315W on F36 following the instructions on Brother’s website. Everything seems to be correctly set up but when I launch simple-scan it does not detect the scanner. I tried downloading the vuescan trial from flathub and it correctly recognise the scanner and scans without a problem (except for the fact that I don’t want to use this piece of software and I don’t intend to pay for it).
Could you help me with this issue? Anyone who had had similar issues?

Have you tried using ‘sane’ for scanning?

Hi Jeff, thanks for your reply! I actually found a solution online. I had sees in a bug report that to correctly work I needed to install libnsl but it didn’t work for me. In a forum I saw that it also requires libusb to work even on network. With both libraries the scanner works perfectly!

1 Like

Would you please post in detail the steps you used to solve the problem then mark the solution so others can find the answer.


Here is the way I managed to make the scanner work. In my case I needed DCP-J315W but I saw this solution worked for other Brother devices too.
Some suggest to delete the printer configuration if there is already one for the device you are attempting to install. I run the process on two machines with Fedora 36 installed and tried both leaving and deleting printer settings and worked well with both. I did however reinstall the drivers as per the following instructions.

  1. Install libnsl

sudo dnf install libnsl

Some suggest a reboot after this step, others don’t. I rebooted

  1. Install libusb. This is required even if the scanner is reached via network

sudo dnf install libusb

  1. Download the official Driver Install Tools for your Brother printer/scanner from Brother’s website and follow the install instructions provided in the drivers download page (extract package, get su privilege, run bash script, and provide ip adress).




I just created account to say : THANK YOU! I would never find a solution for that. These 2 packages were needed, and nowhere this is mentioned. Big THANK YOU again!
(Just installed Fedora for the first time, :smiley: , now, I’m enjoying it even more!)