Fedora silverblue 34 grub2 error

error when booting fedora silverblue

error: …/…/grub-core/kern/disk.c:258: no such partition

grub rescue>

Is this a new installation?

Or this error came up suddenly? Any notable changes before this happen?

Yes, the error came after Frist booting this system, the graphic card crashed suddenly and it said the no shutdown binaries were created.
A total desaster, the hard disk became inaccessible.

Much Thanks for your help !

I installed serveral programs with the gnome software application and forgot to first install the nvidia driver for GT 630.

Thanks for your response.

I will try, but I doubt that the installation DVD will recognise the hard disk. I’ll report to you.

1 Like

I am sorry that I misread your posts. So please ignore my previous reply.

So your SilverBlue booted OK for the First Boot. And the issue only happen after you install some software using Software.

I am not familiar with how to reinstall the grub bootloader under SilverBlue. (I tried to search for this topic a few times, but failed to find solutions.)

Thus I will reinstall in this situation.

I am sorry the installer does not recognise the hard disk any more.

So sorry, this is a very difficult problem, to me it happened for the first time.

You are right, it is so hard to get information about the fedora silverblue os.

The problem is recognition.
Reinstalling the Bootloader with arch linux installer no problem.
But if the hard disk cannot be addressed any more e.g. /dev/sd… then most programs fail to do their work.

What so you mean by not recognized?

You cannot name the device, Windows fails to troubleshoot it, assigns a GID, but not Linux no dev or UUID can identify the SSD Intenso 128 GB hard disk.

Flipping back and forth with windows only causes confusion.

I would assume the ssd is functional, then look in bios to see how it is configured.

Without knowing more I can only guess, but the disk must not be configured as raid, but instead use AHCI. Also, if the system uses RST (intel Rapid Storage Technology) then that should be disabled as well.
It seems from reading the posts here that those settings fix most of the “not recognized” problems related to the drives.

If windows was installed using the raid config then it is also likely that you will have to do a repair to windows after switching the bios config for the drive.

Thanks for this possible solutions. I will try to enter the bios and change this settings you mentioned.
It’s true, windows and unix aren’t friends.

Is not as RAID configured. Bios does not list this hard disk. Only if the SSD is disconnected the bios lists the option to boot from USB. But when I connect the hard disk with the PC it is only possible to boot from the CD/DVD drive.

Then you need to dig deeper into the bios, and try using the boot menu from bios. What you are describing seems to be the default boot order and not the boot menu.

When I use gparted on a fedora 29 live usb system and connect the hard disk it doesn’t show up, even when I refresh the program. Only the usb live stick is displayed.

I entered the boot menu. There the SSD hard disk was not listed.

In this situation, I will:

  • note down the important System Firmware settings. Then do a default reset.

  • If system still not listing the drive in Frimware - reconnect the drive power and signal cable. Change to another SATA port if needed.

If Firmware cannot detect the drive, the hope for any Operation System to use it is very slim.

Many thanks for your advice.

Best wishes

1 Like

Do you know a possibility to flash this drive ? I tried to connect with this disk by serveral bios menus, but non of them could detect the SSD, but one of the bios menus as a flash tool entry.

Have a nice evening