Fedora does not boot after trying to install silverblue on an SD card with the same machine

I installed Fedora Silverblue on an SD card from a live installation media. However, after that, Fedora 36 fails to boot. It boots into Ubuntu, which is one of my tri-boots. Even when I try to select it from the BIOS, it does not work. The Fedora partition has been renamed to fedora-localhost-live. I have tried many times to boot Fedora manually, but the most I got was loading Fedora’s grub. How do I try to fix this? Am I better off just copying my files and reinstalling?

Please post the output of lsblk and sudo fdisk -l as Preformatted text using the </> button above when entering your post.

Fedora and silverblue likely use the same /boot/efi/EFI/fedora and /boot/grub2 directories so it seems probable that silverblue changed the boot config in the bios as well as possibly overwriting the fedora grub.

Have you tried using the bios boot menu and selecting the fedora install from there?

Yes, I have. It goes black for a fraction of a second, apparently trying to boot, then comes back to the menu. There’s also an opensuse option from my attempts to install it on that same SD card before. It does not exist on my computer and also has an identical result so I guess they’re both pointing to nonexistent drives.

I deleted the loop devices

pythonian23@pythonian23-thinkpad ~> lsblk
nvme0n1     259:0    0 476.9G  0 disk 
├─nvme0n1p1 259:1    0   260M  0 part /boot/efi
├─nvme0n1p2 259:2    0    16M  0 part 
├─nvme0n1p3 259:3    0  93.8G  0 part 
├─nvme0n1p4 259:4    0     2G  0 part 
├─nvme0n1p5 259:5    0   125G  0 part /
├─nvme0n1p6 259:6    0  1000M  0 part 
├─nvme0n1p7 259:7    0     1G  0 part 
└─nvme0n1p8 259:8    0 253.9G  0 part
pythonian23@pythonian23-thinkpad ~> sudo fdisk -l
[sudo] password for pythonian23:
Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: SAMSUNG MZVL2512HCJQ-00BL7              
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 49FC2277-6EF8-4FB0-A5EA-F2E3CC9D6EB5

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1      2048     534527    532480   260M EFI System
/dev/nvme0n1p2    534528     567295     32768    16M Microsoft reserved
/dev/nvme0n1p3    567296  197175295 196608000  93.8G Microsoft basic data
/dev/nvme0n1p4 731828224  736022527   4194304     2G Linux swap
/dev/nvme0n1p5 736022528  998166527 262144000   125G Linux filesystem
/dev/nvme0n1p6 998166528 1000214527   2048000  1000M Windows recovery environment
/dev/nvme0n1p7 197175296  199272447   2097152     1G Linux filesystem
/dev/nvme0n1p8 199272448  731828223 532555776 253.9G Linux filesystem

Partition table entries are not in disk order.