Fedora not working properly


When i boot in fedora it sometimes just doesn’t work. Cant open settings, wifi/Bluetooth doesn’t work, the option even disappears sometimes , wifi error NetworkManger not running.
Cant even poweroff or reboot the system so im just stuck there, so i have to power off by holding the power button , and if im lucky it works on the next boot.
I’ve seen this problem on dualboot as well as single complete fedora.


Not yet known.

Related Issues


None yet.

Moving to Ask Fedora

Please provide some information on the hardware you are using. Make / Model, if it’s DIY provide the parts. Also :

  1. Are you currently using the system in a Dual boot configuration?
  2. Have you tried any commands to see system information? reviewed logs?
  3. Does your system hang immediately after logging in? Can you access a terminal?

While your question is vague and hard to reproduce, it’s possible to be hardware related.

The word dualboot struck me and I need to ask:

When you say that you also experience this on pure Fedora with no dualboot, does it mean that you can see it on different devices? Or is it just the same computer all the time?

I was once experiencing the same, sometimes the networking card would not work. I realized that it only worked when the computer was switched off completely when leaving Windows. Restarting and booting Fedora would leave the card in some kind of weird state when it would only work in Windows, but not in Linux.

I would start with this and see if that could not be the case of your troubles.

It is the same computer

1.im currently using it as single fedora


3.no it does not hang immediately, i can access the terminal but not always , it sometimes just keeps on loading and never opens

Was this ever working?
What was the last change that you made to the system before it broke?
Was that a dnf update?

I wonder if you have a problem with selinux?

You could try changing selinux from enforcing to permissive in /etc/sysconfig/selinux and see if your system starts working after a reboot.

With me it is a bit different:
I use the KDE spin and sometimes after typing my password to log in it takes a very long time before the splash screen arrives, after which the wallpaper comes up. I know then that I have to reboot or else the system wil freeze after, well maybe 30 seconds.
When that happens the only thing which still works is using the power-off button for 5 seconds.
The next time I log in the splash screen arrives almost immediately and I get to see the wallpaper and things are just fine.

Start a new topic Jan. Do not hijack this topic.

1 Like

I installed fedora and then i ran sudo dnf upgrade and then it started glitching like this

Did the update complete successfully?
You could try selinux relabelling.

touch /.autorelabel
1 Like

The errors reported show a bunch of different problems. So it is difficult to tell what went wrong. It looks like some files could have been damaged during the update or by a failing disk?

1 Like

This is more likely to be hardware problem than a Fedora bug. What is the history of this system (e.g., brand new purchase, previously working system, used system purchased from a thrift store, etc.)? Some vendors have Hardware Test images.

Start with checks for memory and disk issues:

  • install the Fedora memtest86+ package (adds memtest86+ the list of bootable systems)

  • use Gnome Disks “SMART Data & Self Tests” from a Fedora Live Installer USB to check the “health” of your system disk: