Wifi sometimes not working on boot

In the last week I’ve noticed three times where I boot up my computer, it take longer than usual, and then my wifi simple isn’t working. I’ve been using this computer without any issues since I got it in November of last year. Earlier in the day it may have worked, I shut it off, and then when I boot it up later the wifi stops working. Even after 2-4 restarts and me trying different things it won’t work. At this point when I’ve noticed the problem, I just turn my computer off, leave it alone for several hours, and then try again later. Usually the wifi will work again without any issues.

The only things I’ve tried for troubleshooting are to update my PC when updates are available, hoping I pick up any fixes from people who may have reported this earlier. I was going to try live booting to see if my wifi card worked at all, but that time the wifi magically came back so I didn’t go that far.

For now I’m back (writing from the computer in question), but I’d like to see if there is a fix that’s not just rebooting and waiting.


OS: Fedora Linux 37 (Workstation Edition) x86_64
Host: ROG Strix G513QY_G513QY 1.0
Kernel: 6.1.13-200.fc37.x86_64
Uptime: 2 hours, 36 mins
Packages: 1989 (rpm), 39 (flatpak)
Shell: bash 5.2.15
Resolution: 1920x1080
DE: GNOME 43.3
WM: Mutter
WM Theme: Adwaita
Theme: Adwaita-dark [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: gnome-terminal
CPU: AMD Ryzen 9 5900HX with Radeon Graphics (16
GPU: AMD ATI Radeon Vega Series / Radeon Vega Mo
GPU: AMD ATI Radeon RX 6700/6700 XT/6750 XT / 68
Memory: 4214MiB / 15392MiB

Hi - what symptoms do you see that let you know it’s not working? For example, does it…

  • Connect to your router, but you can’t access the internet?
  • Try but fail to connect to the router
  • Not even show up as an installed device at all?
  • (or something else?)
1 Like

I don’t see any details of your wifi hardware. Problems with wifi at boot are sometimes due to different firmware/configuration loaded by another OS or possibly wake-on-lan or PXE network booting (in UEFI). Are you using dual boot?

The wifi icon in the top right (using Gnome) is either not there or showing greyed out with three dots over it. When the icon isn’t there at all, I don’t know if it’s doing anything and I can’t see any available networks to connect to. When the greyed out icon is there, it looks like it does see my home network, but it tries and fails to connect. In both cases I can’t get online.

Nope, just Fedora 37.

Is there a command I can use to bring that up? I see lspci recommended online but don’t know if I should just dump the whole thing in here.

You can limit the details of lspci by

  1. Run lspci -nn and look at the output. You should see a line something like this for the wifi controller.
04:00.0 Network controller [0280]: Qualcomm Atheros AR93xx Wireless Network Adapter [168c:0030] (rev 01)

Then run lspci -v -nn -d ID where you replace ‘ID’ with the 8 character portion inside the [] you get from the previous command, and post that output only so we can see the details. On my line shown above I would use the command as lspci -v -nn -d 168c:0030.

1 Like

Ok, here’s what I got.

05:00.0 Network controller [0280]: MEDIATEK Corp. MT7921 802.11ax PCI Express Wireless Network Adapter [14c3:7961]
	Subsystem: AzureWave Device [1a3b:4680]
	Flags: bus master, fast devsel, latency 0, IRQ 80, IOMMU group 14
	Memory at fc30300000 (64-bit, prefetchable) [size=1M]
	Memory at fc30400000 (64-bit, prefetchable) [size=16K]
	Memory at fc30404000 (64-bit, prefetchable) [size=4K]
	Capabilities: <access denied>
	Kernel driver in use: mt7921e
	Kernel modules: mt7921e

It looks like that particular wireless card has been problematic for quite a few other folks as well:


A possible solution, based on this other comment, might be checking to make sure that linux-firmware is installed correctly, as that is apparently the package that includes files required for the MediaTek driver that supports that card:


Hope this helps,


I’ll mark this as solved until I give it a shot. Looks more involved than I’m used so I’ll need to psych myself up to tackle this! Thank you!

Honestly, I feel the same way about a lot of things posted here (I’m afraid to type half the things into the terminal that I do), so if I can take a shot at how I’d interpret the info in those links so maybe you can feel more comfortable? I know problems like that really can be grating to try to just live with, so it’d be great to know if it really does work in your case!

  • Open a terminal
  • Run the command dnf info linux-firmware
    *This command does the following: dnf is the Fedora package manager, the command info tells it to list info about a package, and linux-firmware is the package

Now, the next step I’d take would depend on what you see in the first couple lines of that output:

  • If, at the top, after the line about Last metadata expiration… it says “Installed Packages” and then the info for linux-firmware, then that package is already installed - and it might be worth a try to use sudo dnf reinstall linux-firmware to see if that helps?

  • If, on the other hand, it says “Available Packages”, then you might be in the boat some folks in those other threads were, where linux-firmware just isn’t installed at all. At that point, then sudo dnf install linux-firmware might help.

Someone who knows more can definitely correct me here, but I think in either of those cases a reboot would be needed to see if it really did help (not the least because the issue you have gets triggered sometimes by booting up!)

1 Like

“Proper preparation prevents piss-poor performance.”

To feel confident tackling issues with (command-line) linux find good resources and start with some simple practice exercises.

I used to work in a lab that developed specialized software. The manuals for the first Unix system I used (Wicat) included papers by Dennis Ritchie which provided the thinking behind the shell.

We ran workshops to teach the underlying theory along with practical sessions using the software. Initially the software ran on IRIX64, then was ported to linux. We setup systems with the software in a computer lab before the workshop began. We found that many workshop participants had problems getting the software running in their home labs, so added introduction to linux in the first couple afternoon practical sessions. These introduced shell concepts and filesystems, with emphasis on learning to use man pages and online resources, in particular: Linux Command for exercises and (since we used Ubuntu) Debian User Manuals.

Fedora has Getting Started Guide. There was a System Administrator’s Guide, now being replaced with shorter topic-specific documents.

Many Debian/Ubuntu and Arch documents also apply to Fedora. Package management and SElinux do need Fedora/RedHat-specific documentation.

1 Like

I did have it installed, so I tried reinstalling and rebooting. So far so good, but I’ll set this post now as the solution and follow up if it seems like I’m good for a while. Thank you!

1 Like