Wifi problem first boot

hi,
i have recurring problem with wifi not loading at first boot.
i use to have this problem since Fedora 35.
i use now Fedora release 40 (Forty).
i have dual boot with windows 11 and Fedora.
the problem is:
at first boot when the computer turned on and i start fedora the wifi card not present.
i restart the computer again and it’s ok.

the card is: Network controller: Intel Corporation Alder Lake-P PCH CNVi WiFi (rev 01).
the computer is Laptop ASUS tuf F15.
i use to have the same problem with other computer and cards.

i want to send you data when this is happen, could you please give me the commands so when its happen i will upload the data?

or if this is known issue that resolved give me the solution.

10q
Liran

Added f40 and removed f35

There are iwl packages where you can check if they are installed:

sudo dnf list \*iwl*

In BIOS/UEFI settings, do you have Fast Boot enabled? Disable it if so. Also from Windows, Fast Start ideally should be disabled too (it does some fake hibernate thing for Shutdown).

It sounds like something (firmware, power state, etc) is being locked by Windows, and Linux doesn’t like it on the 1st boot. Whatever is locked gets reset on the 2nd Linux boot.

1 Like

Can we rule out something specific to your wifi environment? Does the problem occur with multiple wifi locations? Has your wifi network changed during the time the problem has been occuring?

hi, yes they installed.

Installed Packages
iwlegacy-firmware.noarch 20240513-1.fc40 @updates
iwlwifi-dvm-firmware.noarch 20240513-1.fc40 @updates
iwlwifi-mvm-firmware.noarch 20240513-1.fc40 @updates

yes, it happen to me with several computers and also different wifi cards.

fast boot disabled

You need to show us details of the wifi startup using journalctl in a terminal. Here, on my old iMac:

% journalctl --no-hostname -b  -g wifi |cat
Jun 17 11:00:34 NetworkManager[1290]: <info>  [1718632834.8486] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity-fedora.conf, 22-wifi-mac-addr.conf, 90-broadcom-wl.conf)
Jun 17 11:00:34 NetworkManager[1290]: <info>  [1718632834.8649] Loaded device plugin: NMWifiFactory (/usr/lib64/NetworkManager/1.46.0-2.fc40/libnm-device-plugin-wifi.so)
Jun 17 11:02:57 NetworkManager[1290]: <info>  [1718632977.2606] device (wlp3s0): Activation: (wifi) access point 'Infinity' has security, but secrets are required.
Jun 17 11:02:57 NetworkManager[1290]: <info>  [1718632977.2630] device (wlp3s0): Activation: (wifi) connection 'Infinity' has security, and secrets exist.  No new secrets needed.
Jun 17 11:02:57 NetworkManager[1290]: <info>  [1718632977.7604] device (wlp3s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "Infinity"
Jun 17 11:03:47 NetworkManager[1290]: <info>  [1718633027.5329] device (wlp3s0): Activation: (wifi) access point 'Infinity' has security, but secrets are required.
Jun 17 11:03:47 NetworkManager[1290]: <info>  [1718633027.5345] device (wlp3s0): Activation: (wifi) connection 'Infinity' has security, and secrets exist.  No new secrets needed.
Jun 17 11:03:53 NetworkManager[1290]: <info>  [1718633033.1454] device (wlp3s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "Infinity"

A newer system has more details:

%  journalctl --no-hostname -b  -g wifi |cat
Jun 18 11:54:01 kernel: Intel(R) Wireless WiFi driver for Linux
Jun 18 11:54:01 kernel: iwlwifi 0000:00:14.3: enabling device (0100 -> 0102)
Jun 18 11:54:01 kernel: iwlwifi 0000:00:14.3: Detected crf-id 0x2816, cnv-id 0x1000100 wfpm id 0x80000000
Jun 18 11:54:01 kernel: iwlwifi 0000:00:14.3: PCI dev a370/4030, rev=0x312, rfid=0x105110
Jun 18 11:54:01 kernel: iwlwifi 0000:00:14.3: WRT: Overriding region id 0
[...]
Jun 18 11:54:01 kernel: iwlwifi 0000:00:14.3: WRT: Overriding region id 28
Jun 18 11:54:01 kernel: iwlwifi 0000:00:14.3: loaded firmware version 46.7e3e4b69.0 9000-pu-b0-jf-b0-46.ucode op_mode iwlmvm
Jun 18 11:54:01 kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Wireless-AC 9560 160MHz, REV=0x312
Jun 18 11:54:01 kernel: iwlwifi 0000:00:14.3: base HW address: 04:ed:33:d9:16:d3, OTP minor version: 0x4
Jun 18 11:54:01 kernel: iwlwifi 0000:00:14.3 wlo1: renamed from wlan0
Jun 18 11:54:02 NetworkManager[1147]: <info>  [1718722442.2863] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity-fedora.conf, 22-wifi-mac-addr.conf)
Jun 18 11:54:02 NetworkManager[1147]: <info>  [1718722442.2939] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:14.3/ieee80211/phy0/rfkill1) (driver iwlwifi)
Jun 18 11:54:02 NetworkManager[1147]: <info>  [1718722442.2997] Loaded device plugin: NMWifiFactory (/usr/lib64/NetworkManager/1.46.0-2.fc40/libnm-device-plugin-wifi.so)
Jun 18 11:54:02 kernel: iwlwifi 0000:00:14.3: Registered PHC clock: iwlwifi-PTP, with index: 0
Jun 18 11:54:06 NetworkManager[1147]: <info>  [1718722446.2380] device (wlo1): Activation: (wifi) access point 'Infinity' has security, but secrets are required.
Jun 18 11:54:06 NetworkManager[1147]: <info>  [1718722446.2390] device (wlo1): Activation: (wifi) connection 'Infinity' has security, and secrets exist.  No new secrets needed.
Jun 18 11:54:06 NetworkManager[1147]: <info>  [1718722446.4107] device (wlo1): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "Infinity"

Read man journalctl for an explanation of the options. I added | cat to get pre-formatted text with lines wrapped.

You can use the -b <N> option to compare a boot where wifi works with one where it fails.

Jul 06 16:37:55 kernel: Intel(R) Wireless WiFi driver for Linux
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: Detected crf-id 0x1300504, cnv-id 0x80400 wfpm id 0x80000030
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: PCI dev 51f0/0074, rev=0x370, rfid=0x10a100
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version: 0.0.2.42
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: loaded firmware version 89.e9cec78e.0 so-a0-hr-b0-89.ucode op_mode iwlmvm
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x370
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: WRT: Invalid buffer destination
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: WFPM_UMAC_PD_NOTIFICATION: 0x20
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: WFPM_LMAC2_PD_NOTIFICATION: 0x1f
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: WFPM_AUTH_KEY_0: 0x90
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: CNVI_SCU_SEQ_DATA_DW9: 0x10
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: Detected RF HR B5, rfid=0x10a100
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: RFIm is deactivated, reason = 5
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3: base HW address: 84:7b:57:26:f2:e6
Jul 06 16:37:55 kernel: iwlwifi 0000:00:14.3 wlo1: renamed from wlan0
Jul 06 16:38:03 NetworkManager[2190]: <info>  [1720273083.8602] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity-fedora.conf, 22-wifi-mac-addr.conf)
Jul 06 16:38:03 NetworkManager[2190]: <info>  [1720273083.8658] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:14.3/ieee80211/phy0/rfkill1) (driver iwlwifi)
Jul 06 16:38:03 NetworkManager[2190]: <info>  [1720273083.8706] Loaded device plugin: NMWifiFactory (/usr/lib64/NetworkManager/1.46.0-2.fc40/libnm-device-plugin-wifi.so)
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: WRT: Invalid buffer destination
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: WFPM_UMAC_PD_NOTIFICATION: 0x20
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: WFPM_LMAC2_PD_NOTIFICATION: 0x1f
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: WFPM_AUTH_KEY_0: 0x90
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: CNVI_SCU_SEQ_DATA_DW9: 0x10
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: RFIm is deactivated, reason = 5
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: Registered PHC clock: iwlwifi-PTP, with index: 1
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: WRT: Invalid buffer destination
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: WFPM_UMAC_PD_NOTIFICATION: 0x20
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: WFPM_LMAC2_PD_NOTIFICATION: 0x1f
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: WFPM_AUTH_KEY_0: 0x90
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: CNVI_SCU_SEQ_DATA_DW9: 0x10
Jul 06 16:38:04 kernel: iwlwifi 0000:00:14.3: RFIm is deactivated, reason = 5
Jul 06 16:38:04 systemd[1]: Starting wifi-power-management-off.service - Disable power management for wlan0...
Jul 06 16:38:04 systemd[1]: wifi-power-management-off.service: Main process exited, code=exited, status=203/EXEC
Jul 06 16:38:04 systemd[1]: wifi-power-management-off.service: Failed with result 'exit-code'.
Jul 06 16:38:04 systemd[1]: Failed to start wifi-power-management-off.service - Disable power management for wlan0.
Jul 06 16:38:04 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=wifi-power-management-off comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Jul 06 16:38:08 NetworkManager[2190]: <info>  [1720273088.0406] device (wlo1): Activation: (wifi) access point 'Daniel_5G' has security, but secrets are required.
Jul 06 16:38:08 NetworkManager[2190]: <info>  [1720273088.0412] device (wlo1): Activation: (wifi) connection 'Daniel_5G' has security, and secrets exist.  No new secrets needed.
Jul 06 16:38:08 NetworkManager[2190]: <info>  [1720273088.2120] device (wlo1): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "Daniel_5G"
Jul 06 16:45:47 sudo[28570]:    liran : TTY=pts/0 ; PWD=/home/liran ; USER=root ; COMMAND=/usr/bin/journalctl --no-hostname -b -g wifi

this is the output…

Others are seeing this and have reported it on Intel forums, but wifi may work despite the message. Your journalctl output ends with:

This looks like wifi is working. If you are still having a problem it may be with the wifi router configuration.

hi, this is the outpt when it works, i recently update to latest version and the problem did not return.
we can close this post… if it will return i will post the log output.

thank you all for your help and input.

To to summarize, a recent update fixed your issue?