Wifi not working (dual-boot Windows 10 Pro + Fedora 37)

Description of my PC: custom made Gigabyte X570 Aorus Pro. Memory 32 GiB, AMD Ryzen 9 3900X, NV168 graphics, 1 TB disc.

Dual boot with half Fedora and half Windows 10 Pro 64-bit (500GB each).

GNOME Version: 43.2

Problem with WIFI adapter that is always working perfectly fine when booting with Windows. I changed from Ubuntu to Fedora, thinking that the problem was the OS and after trying lots of commands, even installing again my wifi adapter card driver which was already recognized in Terminal (Intel Wi-Fi 6 AX200). But realize that this step of downloading the driver was not necessary. Wifi was appearing again in settings after restarting and accessing Windows first, then restarting and going back to Fedora again, suddenly everything worked, so the driver is not the issue here. Linux is unable to recognize it for some weird reason and this is directly related to shutting down or restarting the PC.

I have fast boot in BIOS disabled.

I saw lots of forums with the same issue and nobody seems to provide a real solution of why this is happening. Where is the root problem. Is it the DNS? is this some IP issue? what is going on when rebooting the system and why it needs to be rebooted so it is fixed on its own?

It is obvious that Linux has some issues recognizing WIFI when you shot down the computer and you turn on again. But nobody is touching this part. Everyone just throws their 100000 commands expecting that some of them work, but it’s not working.

And the advice of getting a new WIFI card because of this? excuse me? why I should waste money and buy another WIFI card when this is a clear Linux problem.

The person who actually knows why this is happening and comes with a real solution, I swear we’ll be friends forever, cuz I’m already weeks trying to solve this same issue and it’s insane.

Thank you for reading.

Please post the output of lspci -nnv so we can see exactly what wifi card and chipset are involved. We need the details to be able to assist.

Manufacturers often use the same card model with different chipsets and what works for me may not work for you with the exact same card model (because of different chipsets involved).


I’m afraid I don’t know the specific answer and I’ll refrain from guessing, but I did want to address this:

And the advice of getting a new WIFI card because of this? excuse me? why I should waste money and buy another WIFI card when this is a clear Linux problem.

Linux in general, and Fedora Linux in specific, are put together by volunteers. A lot of times, support for specific hardware is provided by heroic, passionate people who, on their own time, decipher how the hardware works and create drivers for it. But, it’s impossible to provide complete coverage of all hardware in this way.

Ideally, hardware vendors would work directly to make sure their device works with Linux. Many do, in fact — including Intel. But, it’s not always perfect, and unfortunately they don’t really provide direct end-user support. If you bought a pre-built computer sold with Fedora Linux pre-installed, that vendor could take your problem to Intel to get help. But the rest of us… unless it’s a specific known situation, sometimes all we can do is give suggestions for things to try based on what we do know.

I know that this isn’t the same as a great corporate customer-support experience. But that’s because you’re not a customer. By running a system with Linux, you’re part of the Linux community. By running a system with Fedora Linux, you’re part of the Fedora community.

Please be patient with us as we try to help you figure this out. I hope we can be friends even if we can’t get you a solution instantly.

1 Like

Actually, I can’t help myself… I’m going to offer one guess. This Ask Ubuntu post describes a similar problem, and notes that they discovered they need to turn Fast Boot off both in the BIOS and in Windows. You’ve noted that you’ve turned it off in the BIOS — can you double-check that it’s also off in Windows?

That post also links to this Linux kernel bug report which suggests that these network cards actually have persistent memory where the driver can save state, which at least leads to a plausible reason Windows fast boot might interfere — it could leave values there that confuse the Linux driver. On non-fast boot/shutdown, it might clear these — but could leave them in place to save time in fast mode.

So, I think it’s worth trying… even though I can’t promise success.

Of course we can be friends even without the solution obtained. My description was just my way of saying from the level of frustration that I find myself at sometimes. Of course I understand that Linux and Fedora is open source and it works thanks to the community sweat and tears. My expressions are sometimes direct because I am a direct and honest person. But yes, with Windows everything is easier and it frustrates me that everything is built around Windows and its corporatism. I have built this PC myself piece by piece. I understand that now the only thing left for me is to contact Intel, since they have sent me the WIFI card.

Thanks for your honest answer.

1 Like

Actually this is the first time I’m reading about disabling fast-startup in Windows after disabling fast boot or secure boot in BIOS.

In windows control panel>power settings this was active so I just unchecked fast-startup.

Hopefully this will be the one. I’ll post again in 2 days after testing this and let you know if this worked.

Thanks again! Appreciated! :blush:

1 Like

Thanks Matt.
I remember seeing something about the fast boot in windows in the past, but since I never use it and very seldom even boot windows it had slipped my mind.

I hope this is the final answer for the OP. :+1:

1 Like