Fedora Kinoite gives error as soon as live iso loads

As soon as the iso finishes loading after the grub screen, I get this error. Even more strange is that I only get a two second window to check the error before the system automatically reboots and throws me back to the grub screen. Just before the error pops up all I see is a white screen with the cursor, there’s no install button or anything of the sort.

Stuff I’ve already tried:
-I was already using Fedora Media Writer to do all this.
-Tried redoing the process through Media Writer, same result.
-Tried using Fedora 38 version (was using 39 before on my first attempt), same result.
-Tried using Fedora Silverblue, same result.
-Tried using Fedora KDE Spin, just to see if the problem was with all Fedora iso or just Atomic ones. The KDE spin ended up loading up fine.
-Tried plugging in the same usb in a old laptop I had lying around, which somehow worked perfectly with no errors.
No idea why this happened, the only real difference (that I can think of) between that laptop and my main system is that my current one comes with an NVIDIA card along with an integrated card, while the old one only has a single Intel card. Not sure if that’s even relevant here or not.

Are you installing on an existing system?

This is likely Dual boot / Better support in Anaconda for existing EFI setup · Issue #284 · fedora-silverblue/issue-tracker · GitHub

You need to clean the previous EFI partitions before installing Kinoite. Dual boot is more involved.