Fedora kinoite 40 install always fail when installing bootloader

'm trying to install and always fail when trying to install bootloader. I already found some threads about it for many different versions from 28 and after, but seems that there is not solution. I did it many times with custom partitoning. First tried to use the existing EFI partition, then with pre-created a new EFI partition. Also tried to do this from the installer and create the partitions for efi and root there. Always the installation fails at the same point with error that cannot write bootloader configuration, and then if I press the button to continue the installation, then I get an os-tree critical erro and installation fails. Also fails in a stage than no bin folder has created, so I cannot even chroot to try do something there.
I also tried to install(for testing) in a virtual machine and again installation failed with the same error. I have checksum the iso and is okay.
Is there an option to bypass the bootloader and just install, so to manually add it afterwards via chroot?
Also can I install the normal fedora first and then re-base to kinoite?

Added anaconda, f40, installation, uefi

That is very bad! I have not tested the install. You may try this download site and install the Kinoite 39 ISO.

That worked reliably for me. From there you can upgrade. Best would be to establish wifi from the installer end exit to TTY (Ctrl+Alt+F4 when the login screen shows), so you dont get possible Plasma 5 / Plasma 6 config file issues.

It would be very good if you could file a bug report against anaconda on the Fedora Bugzillla

1 Like

It didn’t work. I get the same error as before “failed to write bootloader configuration” and after I press continue installation then os-tree error 1. I tried again with the already existing EFI partition and with new partition created from the installer. Is there any way to try configure it from chroot? I mounted the partition but there isn’t a “bin” directory in /. There is one in “/mnt/ostree/deploy/fedora/deploy/6de7e542d974b61976632cc666bff3192d1ee6c56dde5cb577eabb07c6f07a1c.0” though.

This is not normal at all. Before trying anything manual please give us a few more details.

  • dual boot or single boot?
  • is the drive empty?
  • do you use standard partitioning or something else?
  • what hardware, what storage device?
  • what type of firmware, is it current, something strange?
  • is the BIOS locked, to you have TPM, is there IOMMU or some other write protection? Did you go into the BIOS and try to turn relevant things off?

This is from an earlier post of mine while doing some testing. @dancaer69 looks to want to install a different bootloader? I went kind of detailed since my install needed to be systemd-boot LVM+XFS encrypted Container.

and from that thread a reply :

@boredsquirrel

  • is dual boot with archlinux and windows on the same disk

  • no the drive isn’t empty

  • I think yes. The disks are GPT and the partitions are ext4

  • The system has ryzen 5600 cpu, asrock steel legend b550m mainboard, 7 disks(1nvme, 2 ssd and 4 hdd)

  • Its UEFI and I haven’t update the firmware, but it was updated to the latest version before the current one(v3.20)

  • I don’t think so, secure boot is disabled, and also I tried to disable a category “Trusting computing” which has there TPM, but It didn’t make any difference.

Also, I wanted to use the EFI partition of the 1st ssd, an ext4 partition from the 2nd ssd and an ext4 partition from an hdd as “/home”, but after the couple installation fails I use only the 2nd ssd for all. I mean that I use 200M for the efi partition and 42G for the root partiton without separate home.
I also tried(the 40 version though) to install on a Virtual Machine but again I had the same errors.

@hamrheadcorvette
I don’t try to install a different bootloader, I didn’t mentioned the “Full disk summary and bootloader” option before I read it here. I tried to don’t install a bootloader once but again I get the 2nd fatal error:

> The command 'ostree admin instutil set-kargs rhgb quiet root=UUID=#diskuuid# rw' exited with the code 1.

Otherwise I get the “failed to write bootloader configuration” error first which promps me to either stop or continue the installaton. When I press continue I get the 2nd above error.

Atomic Variants are not techincally ready for dual booting. There are mixed experiences but it is discouraged.

Now technically you are triple booting, which will have it’s own hurdles. I might be able to help here in a limited capacity.

2 Likes

As I wrote I don’t try to install on the same disk. I just tried first to use the EFI partiton from the other disk, but after some failures I create a new EFI partition on the same disk. So the disk with the windows and archlinux doesn’t used at all. But still fails.
On the link you posted mentioned in a post that use a boot partition also. Do I need to have a separate boot partition for kinoite?

Yep, I understood.

that’s fine, You still need to create all the other ones. I think In my first link when I tried it I needed all of :

/boot  -- 350MB
/boot/efi -- 600MB

so you will still need these partitions.

:party: Good Luck :fedora: Friend :party:

2 Likes

Thanks, seems that boot partition is required for atomic versions. I never used separate boot partition and never had problems with any distro I’ve tried(and I have a lot, included fedora) in the past.

1 Like

There will be some reason for it for sure. Likely the fundamentally different distribution model.

Note that there are also works on bootupd support, likely backported to F40. This will allow to update the bootloader, which is also currently not supported.

Also only grub is supported, no refind or systemd-boot.