Fedora freezes ... for years now

I am a Linux user since kernel 1.0 and I use Debian and Gentoo most of the time. (I want to say: I am not that unexperienced.)

Every time I boot Fedora, no matter what version, it freezes after about 20 minutes, apparently without a reason. It’s usually after installation, but it might also happen during. It might have to do with my graphics card, a GeForce GTX 650 Ti. I experience the behaviour for many years now. Btw. CentOS doesn’t make such trouble.

Now I have a few days of time to spare, and my question is: How can I help Fedora Project by debugging my personal problem? Though experienced, I have not much to do with kernel matters, and I have no idea what I can do if the system is frozen and doesn’t accept keyboard entries anymore.

Please can someone point to me to the right docs?


Hi Yan. Which Fedora version have you installed? If you open a terminal and run dmesg does it show anything when the freeze occurs? After a freeze and rebooting does journalctl --boot=-1 tell you anything? Assuming your problem is gfx related, have you tried installing the nVidia proprietary drivers? HOWTO for Fedora 30, 29: https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/


Probably best to take information from RPMFusion themselves:


@yanestrb welcome to the community! Please do take a minute to go over posts in the #start-here catgories if you’ve not yet had a chance.

1 Like

can you boot Fedora-Live and try to save logs ?
i had same problem with Gnome-Wayland on Nvidia Drivers. but not in installation process.

I suspected the nouveau driver because I know it’s not very stable. Surprisingly, the Fedora kernel is the only one which makes problems on my machine; I know it’s heavily patched. (Currently I run a vanilla kernel without any problems.)

When my system freezes when running Fedora, everything stops with a sudden. I couldn’t find any suspicious log entries. I tried to log in over ssh, but in vain, the system does not answer anymore (timeout on TCP request). Apparently, it doesn’t exactly matter if X11 is running or not, the crash will happen sooner or later.

NVIDIA proprietary drivers on wayland? I didn’t realise it was working yet, I thought it was still in progress for next release or the one after (I read some blog)

Interesting that you say that. I find that nouveau + Wayland is perfectly stable, bug free, etc, while NVIDIA + Xorg freezes for a few seconds occasionally (I see something about nvlock or trying to free a lock. I only checked once) and is prone to some minor graphical glitches or annoyances (the background on gdm’s greeter turns to static after I close my laptop, nautilus’ context menu extends the height of one option below properties)

So, headless, Xorg or wayland, it still happens?

With regards to your kernel, do you use any third-party modules?

Also, Linux distros ship their own firmware (for devices. I’m not referring to anything like UEFI), microcode, etc. If it isn’t fedora’s kernel vs upstream that’s the issue, this could also cause an issue at a low enough level that it could crash your machine.

1 Like

As I said, Fedora doesn’t live that long on my system. 20 minutes, not more. No time to install external drivers. It’s a plain Fedora system, from the disk.

Nouveau driver is …incomplete… …may lead to crashes. Read the docs.

@yanestrb I’m afraid without more information it is hard to pin-point what may be causing the issue, and if we cannot do that, we cannot help work around it or fix it.

So, the feedback is always welcome, but if the idea here is not to diagnose and fix the issue by providing your helpers with the requested information—which requires work on your side too, I’m afraid this topic isn’t going to lead anywhere.