Fedora 31 freezes after login

Hi there!!

I make a fresh install of fedora 31. I have this laptop:

HP Pavilion 14-al007la, i7 6500U, 16 gb of RAM, NVIDIA® GeForce® 940MX, and a SSD of 500 GB

When i install fedora, its completly freeze after login, so i think that it was because of the nvidia driver, so i follow this instructions

its work for a couple of hours, but after that, the system freeze again. I cant login, or if i can log, when i open any application, its freeze.

I dont know what more i can do.

Excuse me for my poor english.


Sorry about that @soldan and welcome to the Fedora Community.

It might surprise you that your graphics card is still messing with your computing experience. Don’t get me wrong. The card may be in great shape. Its just that Nvidia does not collaborate well with open-source projects like Fedora. Your experience is likely the result.

So, let’s rule out Nvidia. Please uninstall the proprietary driver and revert back to Nouveau. Fire up your Fedora after that, and tell us what happens.

Alternatively, you can use the drivers compiled for Fedora at https://rpmfusion.org … At least the engineers at rpmfusion follow the packaging guidelines for Fedora. The Fedora Community does not recommend the use of drivers published directly by Nvidia. If you want to use proprietary Nvidia drivers in Fedora, rpmfusion is your best bet. That route also gives you more oprions for troubleshooting.



How i uninstall de Nvidia driver and how i install the drivers compiled for Fedora ?

The RPMFusion page has all the info you need:



many thanks!

this are the drivers from fedora?


For some unexplainable reasons, that page is timing out here (I.e. I can’t access it). Have you seen this?:

It is also possible that your machine is crashing because you are logging into graphical desktop with Wayland windows manager. Nvidia doesn’t support that. Make sure you set the manager to Xorg before logging in.

Ok, when i try to uninstal de NVIDIA driver with

dnf remove xorg-x11-drv-nvidia*

it doesnt find any with that name

I install the driver with the instructions, when i reboot, this happend

I go to the tty2 and try to startx

Slow down sir,

Which driver were you uninstalling; the one from Nvidia website? If so, you are mixing things up. Which packages have you installed?

Take this gradually.
Boot to level 3 (login prompt) and run some checks without graphics. You can do that by appending ‘3’ at the end of the Grub boot kernel parameter before booting.

Log in via the terminal and check the loaded modules:
sudo lsmod | grep nvidia
sudo dnf list --installed | grep nvidia

Share your outputs

hehehe excuse me…

i install the nvidia driver from website, i follow this guide

ok, im gona try that.


sudo lsmod | grep nvidia dont show anything

I have examined your progress more closely. You have done some things wrongly.
First, you have not confirmed that you successfully uninstalled the driver from Nvidia’s site as per your statement below

… And the following command you executed will NOT remove that driver

To remove the driver from Nvidia site, please follow the instructions on this page carefully. That page should be familiar since you followed their installation guide successfully.

After you have removed the proprietary driver from Nvidia, also remove the one from rpmfusion too. :flushed:Why? You installed the wrong version. Geforce 940MX is not supported by the 340xx driver series. Your graphics card is recent and is supported by the 440xx series. You can confirm that here (look in the ‘SUPPORTED PRODUCTS’ tab). To remove the packages from rpmfusion, do the following:

sudo dnf remove *nvidia*
Make sure that the packages listed for removal are the ones from rpmfusion … let it run (choose Yes)

Now that you have restored your system, do the following:
sudo dnf update
That will update your Fedora and pull the latest kernel

sudo dnf install akmod-nvidia
That will install the correct drivers for you (Remember: you need the rpmfusion repository to do this. Fedora does not ship proprietary drivers)

If you need cuda/nvdec/nvenc support, also run this:
sudo dnf install xorg-x11-drv-nvidia-cuda

Please remember to wait after the RPM transaction ends, until the kmod get built. This can take up to 5 minutes on some systems.
Once the module is built, “modinfo -F version nvidia” should outputs the version of the driver such as 440.64 and not modinfo: ERROR: Module nvidia not found.


Many thanks Twohot

I think that im gonna try a fresh install again, because i tried to uninstall the nvidia driver with ```
nvidia-installer --uninstall and nothing happend. I have four kernels installed, only in one kernel i can go to the ttys, in the others boots, i cant even go to tty, because it crash.

So, i decide to make a fresh install. In this case, i have to follow this guide?

I’d follow the RPMFusion guide, that’s up to date. This post is already a year old.


I agree with @FranciscoD.

That page has all the information you need

1 Like

Undo if-not-true-then-false Fedora 37/36/35/34 NVIDIA Drivers Uninstall Guide - If Not True Then False

Generating, creating “nvidia.conf” files for NVIDIA settings causes system to hang, mine is one. If you created or altered one, rename it.

sudo mv /etc/X11/xorg.conf.d/nvidia.conf{,.BACKUP}

Add nouveau.modeset=0 to /etc/default/grub at the end of the GRUB_CMDLINE_LINUX line.


sudo grub2-mkconfig -o $(sudo find /boot -name grub.cfg)

Upgrade the system and reboot:

sudo dnf distro-sync -y

I think is still best to disable Secure Boot at your machine’s BIOS/UEFI and I guess you should use the Current GeForce/Quadro/Tesla from RPMFusion, since the legacy driver is for 8000,9000,200 and 300 series:

sudo dnf install akmod-nvidia
sudo dnf install vulkan
sudo dnf install nvidia-settings
sudo dnf install xorg-x11-drv-nvidia-cuda xorg-x11-drv-nvidia-cuda-libs #optional for cuda/nvdec/nvenc support
sudo dnf install vdpauinfo libva-vdpau-driver libva-utils # video acceleration for video players

And make sure to wait: “Please remember to wait after the RPM transaction ends, until the kmod get built. This can take up to 5 minutes on some systems.” Check with:

sudo akmods

And reboot

sudo systemctl -i reboot

You can also install GreenWithEnvy (GWE) to monitor the card:

sudo dnf copr enable atim/gwe -y && sudo dnf install gwe -y


thank you all for the help. i tried everything you say, and more. nothing seems to work, same error always.

when i try a fresh install, the dnf update freeze when it finish and its brokes the kernel update.

I even try fedora 32 beta and its works fine for two days, but after restart, same error.

maybe its a hardware problem with linux… in windows its works fine…

maybe i just wait until the quarantine ends in argentina and so i can try with my linuxs friends

1 Like

Also shows:

sudo ls /usr/share/X11/xorg.conf.d/
sudo ls /etc/X11/
sudo ls /etc/X11/xorg.conf.d/

Check the logs:

journalctl | egrep nvidia
journalctl --system | egrep nvidia
journalctl -dmesg | grep nvidia

The Quarantine will be long. In the current global situation it must be to avoid more loss. I don’t know exactly how things are going in Argentina, but here, in Brazil, is bad and may get worse.

Be safe.

Ok, I don’t know much about Nvidia proprietary drivers… but I have search GeForce 940 MX on nvidia support page for Linux 64 bit, found Geforce Driver Results | NVIDIA and realize that this version came out today. An article at Phoronix speaks about it: NVIDIA 440.82 Linux Driver Brings DOOM Eternal Performance Fix, Linux 5.6 Compatibility - Phoronix … don’t know if it can help you.