Fedora causes Thinkpad X1 Carbon Gen 7 to hang on reboot after “Restart and Upgrade”

I recently installed Fedora 30 on my Thinkpad X1 Carbon Gen 7. The installation went fine. On the first boot I went to the software center to check for updates. There were quite a few software and OS updates. I downloaded them and after some time I was prompted to restart and upgrade. Upon doing so the computer rebooted but hung at the Lenovo splash screen. I left it since I thought it was just updating, but after 30 minutes it was still on the Lenovo splash screen. I had to hold the power button to force the laptop to turn off. Then when starting it again the update proceed. But, when the update had finished and I had logged into Fedora there were no wireless networks detected. I rebooted to see if the network would come back, but it was still not detecting any wifi networks. When I log back into Fedora there is an error message that says an unexpected error occurred.

Should I try the latest kernel? Any other ideas of why this is happening?

Here are some photos of the error: Imgur: The magic of the Internet
Laptop specs: Imgur: The magic of the Internet

Hi @rosepeach! Welcome to the community! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so.

  1. Regarding your wireless issue, it’s likely to be this case, please check it:


  1. Regarding updating and hangs.

Not a solution, just a suggestion. I personally find it far more convenient, reliable and informative to do my updates using cli interface. This way the reboot isn’t forced on me – though in many cases reboot is still needed, but I’m free to choose the time for it. But main reason is I see the output if update process, and I immediately see if anything goes wrong (which it did maybe two or three times for the quite a few years I’ve been using Fedora).

To do update from the cli I personally use two commands:

sudo dnf --refresh check-update

This one is optional, it shows you the list of packages that can be updated right now. --refresh switch forces dnf to check with the repositories right at this moment, are there any new updates. Without it metadata refreshed automatically every few hours.

To perform the actual update you run

sudo dnf upgrade

If you haven’t used check-update above, you can add --refresh to this command.

dnf gives you text feedback during downloading and then updating packages, it’s human-readable and very clear. If you see something you don’t like in the output – you can research it right away, not look for it somewhere in the logs after reboot.

1 Like

Same here with a Thinkpad X1 Yoga Gen 4, which I guess shares most of its hardware with your X1C7. The wifi issue is solved if you reboot on the older kernel, but the BOOT_IMAGE crash sticks around and not only at startup, it comes back during the session.

Those are pretty new laptops. I guess we might wait for 1 or 2 more kernel versions for this to be fixed. I heard that Fedora engineers use pretty much the Thinkpad line. hopefully some of them did get one of those new X1 laptops and are working on these issues :grin: