[Fedora 38 (Workstation Edition)] Software Updates do not download completely and successfully

type or paste code here

Hello! For more context - when I hit the “Download” button, the progress bar goes up to halfway, then stops. Power cycling the Lenovo ThinkPad X1 Carbon 6th, removing software I don’t use, etc., does not seem to resolve this issue. This is preventing me from updating my System Updates, Google Chrome (which outdated version malfunctions - does not load pages properly), et al. Thanks for your time and help - Josh

You have not provided enough information for us to understand the problem.

In case others encounter a similar issue it is helpful to provide (as text so it can be found by searches, using the </> icon (or just bracketing text with triple backquotes) your Fedora version, hardware details, and a summary of your mass storage. The commands below should be run in a terminal to generate text output:

  • Fedora version and hardware: run inxi -Fzx

  • Mass storage usage: run df -lTH

You may want to scan journalctl -b for messages related to your issue: problems with filesystems, disk space, or network.

Probably some upgrade conflict, and GNOME Software doesn’t display enough information.

Try upgrading from terminal:

sudo dnf upgrade

If it fails, please provide the full output.

2 Likes

Thanks for your time and help, @gnwiii++ and @jn64++! Justin’s solution resolved the issue. Just for everyone’s information–and hopefully benefit–there are a handful of prompts, so maybe adding both options -a and -y to the command Justin suggested prior will make the process seamless.

Hi,

I’m trying to update from the Softwate app and the updates get stuck for hours and never complete.

I’ve dried both dnf update and dnf upgrade on terminal and i get

Dependencies resolved.
Nothing to do.
Complete!

I’ve tried also dnf update --refresh and same.
Both the software app and updating via terminal were working fine until a couple of days ago.
Tried both on X11 and Wayland
I’m on Fedora 38,

Any advise?

Thank you!

Jose

1 Like

I’m running into this same problem. Any help would be appreciated. Thanks in advance.

Only the Flatpak apps are stuck. dnf update upgrades system apps, resulting in a “nothing to do” message indicating you have the latest release. This problem is related to a common issue Flatpak install/update fails with ‘Need more input’ or ‘Input buffer too small’.

1 Like

Thank you @yuntaz, that seems to be working.

Thanks again!

1 Like