Fedora 37 hanging with reboot after updating to 6.1.7-200.fc37.x86_64

fedora 37 hanging with reboot after updating to 6.1.7-200.fc37.x86_64. I was running 6.1.6-200.fc37.x86_64 prior to the update. I used the software update app instead of sudo dnf update. Anyone else having same problem? One of my drives is running Stratis Storage. Any help appreciated.

I’ve had issues from 6.1.5 onwards.

Please give details about the “hang”.

For kernels 6.1.5 & 6.1.6 there have been issues with a black screen during boot, that seems related to both nvidia and using encryption on the drive. For those reporting the issue the work around seems to be simply enter the password to unlock the drive on the black screen then press enter and the boot seems to continue normally.

The most recent kernel 6.1.7 seems to have fixed that issue.

You said you already updated to 6.1.7 so we need more info on what your ‘hang’ is and what you see when this happens.

This is what appears during the reboot. Whalen I “press any key to continue” nothing happens.

In my case, with kernels 6.1.5, 6.1.6 and 6.1.7 my system gets as far as the prompt for the hard disk password, which I can enter. It then hangs, not getting as far as bringing up the user login box.

This actually sounds like two different issues. Though both appeared after updating to 6.1.7 the initial symptoms appear different.

I would suggest @maverickofsurrey that you start your own thread so it will be simpler for us to focus on one problem in each thread instead of trying to work on two different problems and the confusion that may result.

For both of you.
Is it possible to boot to an older kernel with the existing system to do some trouble shooting?

If that fails, is it possible to boot to a live usb device so we could do some trouble shooting?

Yes, I can shutdown my desktop, reboot to when attached screen appears and boot into 6.1.6 with no problem. Just the 6.1.7 hangs or freezes.

I will create a separate thread. In quick reply, yes I can load a working kernel, and run a terminal command to remove non-working kernels.

Never be afraid to trust an unknown future to a known God.

Corrie Ten Boom

Since you are able to boot to 6.1.6 then I would suggest removing the 6.1.7 kernel and reinstall it to see if there it would now work properly.

  1. Boot the 6.1.6 kernel
  2. sudo dnf remove kernel*6.1.7*
  3. sudo dnf upgrade and verify that it installs the 6.1.7 (or later) kernel.
  4. Wait at least 5 minutes then reboot and see if the 6.1.7 kernel will boot properly.

Hi Jeff, I tried your suggestion but I get the same results, 6.1.7 still hangs with same message so I can only boot 6.1.6.

Since you can use the 6.1.6 kernel, and there is a new 6.1.8 kernel in testing I suggest the following.

  1. edit /etc/dnf/dnf.conf and modify the installonly_limit to allow retaining 4 kernels. Additional kernels are usually not an issue and it does provide a little more room to avoid the system potentially removing a still functioning kernel.
  2. remove the 6.1.7 kernel as done above
  3. install the 6.1.8 kernel from testing with
    sudo dnf upgrade kernel* --enablerepo=updates-testing
    which should pull in the kernel from testing (without unnecessarily upgrading everything else that may be in testing).

You then should be able to try the 6.1.8 kernel and see if it may boot properly where 6.1.7 does not .

For completeness, please also post the output of inxi -Fzxx so we can tell exactly what hardware is in the system. This can be done with the 6.1.6 kernel to allow it to be done quickly.

Jeff, I tried your first solution again before I tried your latest post and system froze again, then I turned off desktop and restarted and 6.1.7 booted OK - I have tried it several times now and 6.1.7 seems to be rebooting OK. I don’t know what was going on. I will save your second solution in case I have future problems with 6.1.7. Thanks for your help! I am up an running again now.

Jeff, for future reference is it best to use sudo dnf update/upgrade in terminal, or best to use GUI Software update? The Software update always wants to reboot after the update or upgrade. Should you always reboot with either one?

My personal preference is to always use the command line and dnf for upgrades. Others use gnome software.
I do not like the automatic offline update so one of the things I do with a new install is disable that.
sudo systemctl disable packagekit-offline-update.service
sudo systemctl mask packagekit-offline-update.service

This prevents the checkbox that appears when doing a restart or shutdown that triggers the offline update.

Some seem to like the automatic updates and others like using the gnome-software tool to do updates.

As far as rebooting every time, no it is not always necessary, but sometimes it is.
Updates to gnome, kernel, drivers, firmware, (and a few others) do need a reboot so things work well.

I have same notebook issue with RTL8723DE wireless card. Affected kernels 6.1.6-200,6.1.7-200,6.1.8-200. After add modprobe.blacklist=rtw88_8723de to kernel parameters machine loaded without problem and after manual module rtw88_8723de load network is working. But in regular boot machine hang after or near after wpa_supplicant service start.

Some more info. When load module rtw88_8723de with active bluetooth system is hang. After switch off bluetooth before load module the system is working well.

I think that issue is in RTL8723DE wireless card driver/firmware for WiFi/Bluetooth.

Good catch and it should be reported as a bug for that driver, bluetooth, and card

Pavel, thank you for the helpful information. I note that you have the same WiFi card as me. What do you do to manually re enable the module once you have logged into your system?

After logging i do sudo modprobe rtw88_8723de. But in current i stay on 6.0.15-300 kernel until fix will be provided because i need wifi and bluetooth at same time.