Lost WIFI after recent update. Intel 9560NGW

When I first installed Fedora 30 Workstation my wifi was fine. I’d also run an update 5 or so times without any issues. Then I updated last night and rebooted and had no wifi, I did the update in a terminal window and there was no issues, all verified, no errors.

These are the packages that updated (using dnf history info):

Transaction ID : 36
Begin time     : Thu 25 Jul 2019 19:52:26 NZST
Begin rpmdb    : 1756:f76dbd71859a34a0e7e05f5bd54e81504eee65dd
End time       : Thu 25 Jul 2019 19:55:22 NZST (176 seconds)
End rpmdb      : 1756:7071de9fc398bb00398f2ab469d5ac329e816670
User           : 
Return-Code    : Success
Releasever     : 30
Command Line   : update -y
Packages Altered:
    Install  kernel-5.1.18-300.fc30.x86_64                        @updates
    Install  kernel-core-5.1.18-300.fc30.x86_64                   @updates
    Install  kernel-modules-5.1.18-300.fc30.x86_64                @updates
    Install  kernel-modules-extra-5.1.18-300.fc30.x86_64          @updates
    Upgrade  autocorr-en-1:                  @updates
    Upgraded autocorr-en-1:                  @@System
    Upgrade  bind-export-libs-32:9.11.8-1.fc30.x86_64             @updates
    Upgraded bind-export-libs-32:9.11.6-5.P1.fc30.x86_64          @@System
    Upgrade  bind-libs-32:9.11.8-1.fc30.x86_64                    @updates
    Upgraded bind-libs-32:9.11.6-5.P1.fc30.x86_64                 @@System
    Upgrade  bind-libs-lite-32:9.11.8-1.fc30.x86_64               @updates
    Upgraded bind-libs-lite-32:9.11.6-5.P1.fc30.x86_64            @@System
    Upgrade  bind-license-32:9.11.8-1.fc30.noarch                 @updates
    Upgraded bind-license-32:9.11.6-5.P1.fc30.noarch              @@System
    Upgrade  bind-utils-32:9.11.8-1.fc30.x86_64                   @updates
    Upgraded bind-utils-32:9.11.6-5.P1.fc30.x86_64                @@System
    Upgrade  curl-7.65.3-1.fc30.x86_64                            @updates
    Upgraded curl-7.64.0-8.fc30.x86_64                            @@System
    Upgrade  dhcp-client-12:4.3.6-35.fc30.x86_64                  @updates
    Upgraded dhcp-client-12:4.3.6-34.fc30.x86_64                  @@System
    Upgrade  dhcp-common-12:4.3.6-35.fc30.noarch                  @updates
    Upgraded dhcp-common-12:4.3.6-34.fc30.noarch                  @@System
    Upgrade  dhcp-libs-12:4.3.6-35.fc30.x86_64                    @updates
    Upgraded dhcp-libs-12:4.3.6-34.fc30.x86_64                    @@System
    Upgrade  evolution-data-server-3.32.4-1.fc30.x86_64           @updates
    Upgraded evolution-data-server-3.32.3-1.fc30.x86_64           @@System
    Upgrade  evolution-data-server-langpacks-3.32.4-1.fc30.noarch @updates
    Upgraded evolution-data-server-langpacks-3.32.3-1.fc30.noarch @@System
    Upgrade  gnupg2-2.2.17-1.fc30.x86_64                          @updates
    Upgraded gnupg2-2.2.16-1.fc30.x86_64                          @@System
    Upgrade  gnupg2-smime-2.2.17-1.fc30.x86_64                    @updates
    Upgraded gnupg2-smime-2.2.16-1.fc30.x86_64                    @@System
    Upgrade  gvfs-1.40.2-1.fc30.x86_64                            @updates
    Upgraded gvfs-1.40.1-2.fc30.x86_64                            @@System
    Upgrade  gvfs-afc-1.40.2-1.fc30.x86_64                        @updates
    Upgraded gvfs-afc-1.40.1-2.fc30.x86_64                        @@System
    Upgrade  gvfs-afp-1.40.2-1.fc30.x86_64                        @updates
    Upgraded gvfs-afp-1.40.1-2.fc30.x86_64                        @@System
    Upgrade  gvfs-archive-1.40.2-1.fc30.x86_64                    @updates
    Upgraded gvfs-archive-1.40.1-2.fc30.x86_64                    @@System
    Upgrade  gvfs-client-1.40.2-1.fc30.x86_64                     @updates
    Upgraded gvfs-client-1.40.1-2.fc30.x86_64                     @@System
    Upgrade  gvfs-fuse-1.40.2-1.fc30.x86_64                       @updates
    Upgraded gvfs-fuse-1.40.1-2.fc30.x86_64                       @@System
    Upgrade  gvfs-goa-1.40.2-1.fc30.x86_64                        @updates
    Upgraded gvfs-goa-1.40.1-2.fc30.x86_64                        @@System
    Upgrade  gvfs-gphoto2-1.40.2-1.fc30.x86_64                    @updates
    Upgraded gvfs-gphoto2-1.40.1-2.fc30.x86_64                    @@System
    Upgrade  gvfs-mtp-1.40.2-1.fc30.x86_64                        @updates
    Upgraded gvfs-mtp-1.40.1-2.fc30.x86_64                        @@System
    Upgrade  gvfs-smb-1.40.2-1.fc30.x86_64                        @updates
    Upgraded gvfs-smb-1.40.1-2.fc30.x86_64                        @@System
    Upgrade  hplip-3.19.6-1.fc30.x86_64                           @updates
    Upgraded hplip-3.18.12-13.fc30.x86_64                         @@System
    Upgrade  hplip-common-3.19.6-1.fc30.x86_64                    @updates
    Upgraded hplip-common-3.18.12-13.fc30.x86_64                  @@System
    Upgrade  hplip-libs-3.19.6-1.fc30.x86_64                      @updates
    Upgraded hplip-libs-3.18.12-13.fc30.x86_64                    @@System
    Upgrade  ipset-7.2-1.fc30.x86_64                              @updates
    Upgraded ipset-6.38-2.fc30.x86_64                             @@System
    Upgrade  ipset-libs-7.2-1.fc30.x86_64                         @updates
    Upgraded ipset-libs-6.38-2.fc30.x86_64                        @@System
    Upgrade  iwl100-firmware-             @updates
    Upgraded iwl100-firmware-             @@System
    Upgrade  iwl1000-firmware-1:          @updates
    Upgraded iwl1000-firmware-1:          @@System
    Upgrade  iwl105-firmware-            @updates
    Upgraded iwl105-firmware-            @@System
    Upgrade  iwl135-firmware-            @updates
    Upgraded iwl135-firmware-            @@System
    Upgrade  iwl2000-firmware-           @updates
    Upgraded iwl2000-firmware-           @@System
    Upgrade  iwl2030-firmware-           @updates
    Upgraded iwl2030-firmware-           @@System
    Upgrade  iwl3160-firmware-1:         @updates
    Upgraded iwl3160-firmware-1:         @@System
    Upgrade  iwl3945-firmware-            @updates
    Upgraded iwl3945-firmware-            @@System
    Upgrade  iwl4965-firmware-          @updates
    Upgraded iwl4965-firmware-          @@System
    Upgrade  iwl5000-firmware-           @updates
    Upgraded iwl5000-firmware-           @@System
    Upgrade  iwl5150-firmware-             @updates
    Upgraded iwl5150-firmware-             @@System
    Upgrade  iwl6000-firmware-            @updates
    Upgraded iwl6000-firmware-            @@System
    Upgrade  iwl6000g2a-firmware-        @updates
    Upgraded iwl6000g2a-firmware-        @@System
    Upgrade  iwl6000g2b-firmware-        @updates
    Upgraded iwl6000g2b-firmware-        @@System
    Upgrade  iwl6050-firmware-            @updates
    Upgraded iwl6050-firmware-            @@System
    Upgrade  iwl7260-firmware-1:         @updates
    Upgraded iwl7260-firmware-1:         @@System
    Upgrade  kernel-headers-5.1.18-300.fc30.x86_64                @updates
    Upgraded kernel-headers-5.1.17-300.fc30.x86_64                @@System
    Upgrade  langtable-0.0.43-3.fc30.noarch                       @updates
    Upgraded langtable-0.0.43-2.fc30.noarch                       @@System
    Upgrade  langtable-data-0.0.43-3.fc30.noarch                  @updates
    Upgraded langtable-data-0.0.43-2.fc30.noarch                  @@System
    Upgrade  less-551-1.fc30.x86_64                               @updates
    Upgraded less-550-1.fc30.x86_64                               @@System
    Upgrade  libblkid-2.33.2-2.fc30.x86_64                        @updates
    Upgraded libblkid-2.33.2-1.fc30.x86_64                        @@System
    Upgrade  libbytesize-2.1-1.fc30.x86_64                        @updates
    Upgraded libbytesize-2.0-1.fc30.x86_64                        @@System
    Upgrade  libcurl-7.65.3-1.fc30.x86_64                         @updates
    Upgraded libcurl-7.64.0-8.fc30.x86_64                         @@System
    Upgrade  libertas-usb8388-firmware-2:20190717-99.fc30.noarch  @updates
    Upgraded libertas-usb8388-firmware-2:20190618-97.fc30.noarch  @@System
    Upgrade  libfdisk-2.33.2-2.fc30.x86_64                        @updates
    Upgraded libfdisk-2.33.2-1.fc30.x86_64                        @@System
    Upgrade  libgdata-0.17.10-1.fc30.x86_64                       @updates
    Upgraded libgdata-0.17.9-4.fc30.x86_64                        @@System
    Upgrade  libmount-2.33.2-2.fc30.x86_64                        @updates
    Upgraded libmount-2.33.2-1.fc30.x86_64                        @@System
    Upgrade  libreoffice-calc-1:             @updates
    Upgraded libreoffice-calc-1:             @@System
    Upgrade  libreoffice-core-1:             @updates
    Upgraded libreoffice-core-1:             @@System
    Upgrade  libreoffice-data-1:             @updates
    Upgraded libreoffice-data-1:             @@System
    Upgrade  libreoffice-draw-1:             @updates
    Upgraded libreoffice-draw-1:             @@System
    Upgrade  libreoffice-emailmerge-1:       @updates
    Upgraded libreoffice-emailmerge-1:       @@System
    Upgrade  libreoffice-filters-1:          @updates
    Upgraded libreoffice-filters-1:          @@System
    Upgrade  libreoffice-graphicfilter-1:    @updates
    Upgraded libreoffice-graphicfilter-1:    @@System
    Upgrade  libreoffice-gtk3-1:             @updates
    Upgraded libreoffice-gtk3-1:             @@System
    Upgrade  libreoffice-help-en-1:          @updates
    Upgraded libreoffice-help-en-1:          @@System
    Upgrade  libreoffice-impress-1:          @updates
    Upgraded libreoffice-impress-1:          @@System
    Upgrade  libreoffice-langpack-en-1:      @updates
    Upgraded libreoffice-langpack-en-1:      @@System
    Upgrade  libreoffice-math-1:             @updates
    Upgraded libreoffice-math-1:             @@System
    Upgrade  libreoffice-opensymbol-fonts-1: @updates
    Upgraded libreoffice-opensymbol-fonts-1: @@System
    Upgrade  libreoffice-pdfimport-1:        @updates
    Upgraded libreoffice-pdfimport-1:        @@System
    Upgrade  libreoffice-pyuno-1:            @updates
    Upgraded libreoffice-pyuno-1:            @@System
    Upgrade  libreoffice-ure-1:              @updates
    Upgraded libreoffice-ure-1:              @@System
    Upgrade  libreoffice-ure-common-1:       @updates
    Upgraded libreoffice-ure-common-1:       @@System
    Upgrade  libreoffice-writer-1:           @updates
    Upgraded libreoffice-writer-1:           @@System
    Upgrade  libreoffice-x11-1:              @updates
    Upgraded libreoffice-x11-1:              @@System
    Upgrade  libreoffice-xsltfilter-1:       @updates
    Upgraded libreoffice-xsltfilter-1:       @@System
    Upgrade  librsvg2-2.45.7-1.fc30.x86_64                        @updates
    Upgraded librsvg2-2.45.6-1.fc30.x86_64                        @@System
    Upgrade  libsane-hpaio-3.19.6-1.fc30.x86_64                   @updates
    Upgraded libsane-hpaio-3.18.12-13.fc30.x86_64                 @@System
    Upgrade  libshaderc-2019.0-1.fc30.x86_64                      @updates
    Upgraded libshaderc-2018.0-2.fc30.x86_64                      @@System
    Upgrade  libsmartcols-2.33.2-2.fc30.x86_64                    @updates
    Upgraded libsmartcols-2.33.2-1.fc30.x86_64                    @@System
    Upgrade  libuuid-2.33.2-2.fc30.x86_64                         @updates
    Upgraded libuuid-2.33.2-1.fc30.x86_64                         @@System
    Upgrade  linux-firmware-20190717-99.fc30.noarch               @updates
    Upgraded linux-firmware-20190618-97.fc30.noarch               @@System
    Upgrade  linux-firmware-whence-20190717-99.fc30.noarch        @updates
    Upgraded linux-firmware-whence-20190618-97.fc30.noarch        @@System
    Upgrade  osinfo-db-20190611-1.fc30.noarch                     @updates
    Upgraded osinfo-db-20190504-1.fc30.noarch                     @@System
    Upgrade  plymouth-0.9.4-7.fc30.x86_64                         @updates
    Upgraded plymouth-0.9.4-6.fc30.x86_64                         @@System
    Upgrade  plymouth-core-libs-0.9.4-7.fc30.x86_64               @updates
    Upgraded plymouth-core-libs-0.9.4-6.fc30.x86_64               @@System
    Upgrade  plymouth-graphics-libs-0.9.4-7.fc30.x86_64           @updates
    Upgraded plymouth-graphics-libs-0.9.4-6.fc30.x86_64           @@System
    Upgrade  plymouth-plugin-label-0.9.4-7.fc30.x86_64            @updates
    Upgraded plymouth-plugin-label-0.9.4-6.fc30.x86_64            @@System
    Upgrade  plymouth-plugin-two-step-0.9.4-7.fc30.x86_64         @updates
    Upgraded plymouth-plugin-two-step-0.9.4-6.fc30.x86_64         @@System
    Upgrade  plymouth-scripts-0.9.4-7.fc30.x86_64                 @updates
    Upgraded plymouth-scripts-0.9.4-6.fc30.x86_64                 @@System
    Upgrade  plymouth-system-theme-0.9.4-7.fc30.x86_64            @updates
    Upgraded plymouth-system-theme-0.9.4-6.fc30.x86_64            @@System
    Upgrade  plymouth-theme-spinner-0.9.4-7.fc30.x86_64           @updates
    Upgraded plymouth-theme-spinner-0.9.4-6.fc30.x86_64           @@System
    Upgrade  python3-bytesize-2.1-1.fc30.x86_64                   @updates
    Upgraded python3-bytesize-2.0-1.fc30.x86_64                   @@System
    Upgrade  python3-langtable-0.0.43-3.fc30.noarch               @updates
    Upgraded python3-langtable-0.0.43-2.fc30.noarch               @@System
    Upgrade  qt5-qtbase-5.12.4-3.fc30.x86_64                      @updates
    Upgraded qt5-qtbase-5.12.4-1.fc30.x86_64                      @@System
    Upgrade  qt5-qtbase-common-5.12.4-3.fc30.noarch               @updates
    Upgraded qt5-qtbase-common-5.12.4-1.fc30.noarch               @@System
    Upgrade  qt5-qtbase-gui-5.12.4-3.fc30.x86_64                  @updates
    Upgraded qt5-qtbase-gui-5.12.4-1.fc30.x86_64                  @@System
    Upgrade  qt5-qtwayland-5.12.4-4.fc30.x86_64                   @updates
    Upgraded qt5-qtwayland-5.12.4-3.fc30.x86_64                   @@System
    Upgrade  selinux-policy-3.14.3-41.fc30.noarch                 @updates
    Upgraded selinux-policy-3.14.3-40.fc30.noarch                 @@System
    Upgrade  selinux-policy-targeted-3.14.3-41.fc30.noarch        @updates
    Upgraded selinux-policy-targeted-3.14.3-40.fc30.noarch        @@System
    Upgrade  system-config-printer-libs-1.5.11-18.fc30.noarch     @updates
    Upgraded system-config-printer-libs-1.5.11-16.fc30.noarch     @@System
    Upgrade  system-config-printer-udev-1.5.11-18.fc30.x86_64     @updates
    Upgraded system-config-printer-udev-1.5.11-16.fc30.x86_64     @@System
    Upgrade  systemd-241-9.gitb67ecf2.fc30.x86_64                 @updates
    Upgraded systemd-241-8.git9ef65cb.fc30.x86_64                 @@System
    Upgrade  systemd-container-241-9.gitb67ecf2.fc30.x86_64       @updates
    Upgraded systemd-container-241-8.git9ef65cb.fc30.x86_64       @@System
    Upgrade  systemd-libs-241-9.gitb67ecf2.fc30.x86_64            @updates
    Upgraded systemd-libs-241-8.git9ef65cb.fc30.x86_64            @@System
    Upgrade  systemd-pam-241-9.gitb67ecf2.fc30.x86_64             @updates
    Upgraded systemd-pam-241-8.git9ef65cb.fc30.x86_64             @@System
    Upgrade  systemd-rpm-macros-241-9.gitb67ecf2.fc30.noarch      @updates
    Upgraded systemd-rpm-macros-241-8.git9ef65cb.fc30.noarch      @@System
    Upgrade  systemd-udev-241-9.gitb67ecf2.fc30.x86_64            @updates
    Upgraded systemd-udev-241-8.git9ef65cb.fc30.x86_64            @@System
    Upgrade  totem-1:3.32.1-1.fc30.x86_64                         @updates
    Upgraded totem-1:3.32.0-1.fc30.x86_64                         @@System
    Upgrade  util-linux-2.33.2-2.fc30.x86_64                      @updates
    Upgraded util-linux-2.33.2-1.fc30.x86_64                      @@System
    Upgrade  util-linux-user-2.33.2-2.fc30.x86_64                 @updates
    Upgraded util-linux-user-2.33.2-1.fc30.x86_64                 @@System
    Upgrade  vamp-plugin-sdk-2.8.0-1.fc30.x86_64                  @updates
    Upgraded vamp-plugin-sdk-2.7.1-2.fc30.x86_64                  @@System
    Upgrade  vim-minimal-2:8.1.1713-1.fc30.x86_64                 @updates
    Upgraded vim-minimal-2:8.1.1661-1.fc30.x86_64                 @@System
    Upgrade  virtualbox-guest-additions-6.0.10-1.fc30.x86_64      @updates
    Upgraded virtualbox-guest-additions-6.0.8-2.fc30.x86_64       @@System
    Upgrade  xen-libs-4.11.2-1.fc30.x86_64                        @updates
    Upgraded xen-libs-4.11.1-6.fc30.x86_64                        @@System
    Upgrade  xen-licenses-4.11.2-1.fc30.x86_64                    @updates
    Upgraded xen-licenses-4.11.1-6.fc30.x86_64                    @@System
    Removed  kernel-5.1.15-300.fc30.x86_64                        @@System
    Removed  kernel-core-5.1.15-300.fc30.x86_64                   @@System
    Removed  kernel-modules-5.1.15-300.fc30.x86_64                @@System
    Removed  kernel-modules-extra-5.1.15-300.fc30.x86_64          @@System

I tried booting to old kernels using grub but the wifi still didn’t work. I’m guessing one of the firmware updates created a problem?

Hello @andrewnet, and welcome! Please do check out #start-here for some information on how to best utilize this site.

Now on to the core issue: based on the version numbers listed and your WiFi chipset you mentioned, I’m going to guess that this commit or this commit is where the issue came from. Could you run dmesg | grep iwlwifi and post the output?

If you really need an immediate workaround, you can undo that transaction.


Thanks for the reply. :smiley:

I’ve been using a wifi USB dongle since my built in wifi stopped working. I unplugged the dongle before running dmesg | grep iwlwifi then plugged it back in to post the results on here. To clarify this output is without the dongle plugged in but it was plugged in seconds earlier.

It was too many characters for this forum so I put it on PasteBin.

I had a similar issue. Filed this, so worth checking if it’s the same:


Depending on your hardware, though, it may be a different firmware package. You’ll have to check the descriptions to see which package are used for your hardware (rpm -qi <package name>).

The immediate workaround is to downgrade the package. That fixes it.


Thanks a lot @FranciscoD that worked. As per the BugZilla workaround instructions. It must be the the same bug.

sudo dnf downgrade -y iwl7260-firmware
sudo rmmod iwlmvm iwlwifi
sudo modprobe iwlwifi

To confirm, upgrading from iwl7260-firmware-1: to iwl7260-firmware-1: stops the Intel 9560NGW wifi module working. (And downgrading back to iwl7260-firmware-1: fixes it.)


Please mark the answer as the solution. I expect a lot of users are going to experience this :frowning:

1 Like

I have a similar issue since F29:
Unhiding SSID partly helps, but the connection drops and fails to establish a lot more often.

If you want to lock the version of the package iwl7260-firmware:

sudo dnf install 'dnf-command(versionlock)'
sudo dnf versionlock add iwl7260-firmware

This is from December? That’s quite a while. I’d bump the bug if I were you.

Bumping this thread, while upstream discussions about how to patch the issue are ongoing.

Thank you @andrewnet and @vgaetera for the workarounds.


I’ll just put this here in case someone else needs it. I’m running Fedora 30.

I had an issue with a recent update which broke my wifi where the wifi kept going on/off constantly. I’ve got a laptop with an Intel 9560 wifi chip. The latest update of the iwlwifi driver broke it.

Basically the fix is to move, delete, or rename the microcode file “iwlwifi-9000-pu-b0-jf-b0-46.ucode” from the /lib/firmware/ folder.

Just for reference, here the Intel linux wifi drivers page. You can download driver microcode files from here if needed.

You should avoid working around your package manager in these ways. Inevitably, you will forget what you did, or some update will overwrite your changes.

In this case, it would be better to downgrade the package: sudo dnf downgrade iwl7260-firmware or if there’s an update in testing, try it out and provide positive karma if it fixes the bug (or negative karma if not).


Was already reported, so I’ve merged your post with the original post. Please search the forum before posting—and if you did, were you unable to find the post?

I’m going to close this thread now. A workaround is known so we currently have a solution. A bug has also been filed and is being looked into. Bumping this thread does not really do much.

Quick update:

An update has been pushed, and seems to work for me. Please test this out. It will be in the repos by tomorrow (20th):


Information on how you can test updates and provide feedback is here:


Please note that you must also update your kernel to 5.2.9, poweroff your system completely and then restart it (a reboot will not be enough).