Fedora boots to a black screen when connected to a samsung 4k TV

Hi everyone,
I have fedora 35 workstation installed and working fine with all updates installed on my PC that is connected to an old VGA monitor using VGA-HDMI adapter. I tried to connect the PC to a samsung 4k TV and fedora stays on black screen after the grub menu. I tried booting all fedora entries in grub but with no vain. I only managed to boot fedora when I entered “nomodeset” in grub boot options.
My PC specs
Aorus B450 elite
Motherboard Ryzen 3400g with Vega 11 graphics
16 GiB Ram.
Sorry for bad English and thanks in advance

SIDE NOTE: The HDMI cable connected to the TV is somewhat Bent before the connector(the part the we plug into the port) but I don’t think it’s the problem as I can see the bios and grub screen. Also Windows 11 does a similar thing as the TV gives no signal on login screen.

Does it work if you plug it in after booting or give you options to configure?

Can you post:
inxi -Gzx

A visibly damaged HDMI cable should be an obvious clue that it may need replaced.

If you have access to a different cable then try replacing the cable to see if it makes a difference. If you have a different monitor available you might try a different monitor on the same cable as well to see if that helps.

You said that is a 4k TV, and some have been noted to not report the proper info back to the PC as well so they may not get properly configured.

1 Like

Thanks for the reply. about the command you posted should i run it while connected to the working monitor or the TV in “nomodeset”?

Hi, just want to make sure if the TV setting already set to the correct source signal. Usually we need to change manually the source signal, for example source from HDMI 1, 2, or 3 or DP 1, 2, or even VGA/PC.


Look like it already set since you able to boot with nomodeset.

While connected.

You should also try plugging in the tv after being logged in.


This is the output of the command while connected to the working monitor.

inxi -Gzx
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile
vendor: Gigabyte driver: amdgpu v: kernel bus-ID: 06:00.0
Display: wayland server: X.Org compositor: gnome-shell driver:
loaded: ati,vesa unloaded: fbdev,modesetting,radeon
resolution: 1360x768~60Hz
OpenGL: renderer: AMD Radeon Vega 11 Graphics (RAVEN DRM 3.44.0
5.16.11-200.fc35.x86_64 LLVM 13.0.0)
v: 4.6 Mesa 21.3.6 direct render: Yes

I bought a new cable and now windows works but fedora still gives black screen even if i connected after reaching login screen (i removed the cable before pressing enter on grub and reconnected when i noticed the hdd light stopped blinking)
Thanks and sorry for being late to reply