Fedora 40 on HP 6570B Laptop -- grub menu, luks passwd for /home, then black screen

Install went fine. I booted three or four times, saw that wayland was working ok on this relatively minimal hardware (upgraded the base laptop with an i7 cpu and 16GB of ram, all tested verified with benchmark and stress test programs) Next I updated the fresh system, allowing it to install or update all the software it requested, which was considerable. Then booted ok, twice. Then installed software with dnf, normal things like geany, thunar, brave-browser and not much else, and booted again, ok.
I had installed the default install of the workstation version of Fedora 40 so I could try different graphical desktops: I read they could be installed and switched easily by doing this. Tried installing KDE, something like sudo dnf group install KDE . I had installed a new battery. I wanted to run it down to a low energy level then charge it fully. It started at 75%. Within a minute the laptop screen went black. Fan stopped. The new battery is apparently no good. It’s going back. I’ll look for a better one.

Running on wall power now, I chose to boot from the SDD. It offers the typical grub menu with the original kernel and a newer one that was installed by the updating. I can pick either kernel, 6.8.5-301 or 6.8.9-300 or the recovery boot option. The first two lead to a graphical LUKS prompt for my /home directory, after inputting password it goes to a black screen with a prompt in the top left corner. There is no response to any keyboard input at this point. I tried editing one of the grub entries replacing rhgb and quiet with nomodeset=0 This allows me to see system messages, gives a request for the LUKS password. After that the system halts at this point and will go no further. I tried to input my password but there appears to be no response to any key input.

[ OK ] Started systemd-ask-password-wall. ... Forward Password Requests to Wall.

Can it be rescued?


]- install +1
]- laptop battery burped
]- now it’s black-screen-w-dead(unresponsive)-prompt after boot & login
]- will she schoon — or is it toe-tag for Fedora 40?
]- how to fix?

How about a “repair install”? Is there such a thing using the live media (USB stick) or possibly with the ISO on my Ventoy stick? Either should be about the same, but how to proceed? I’m guessing that it’s mainly the boot partition, /boot that got damaged. Unsure if there is an option in the installer to repair the boot section? ANYONE?
This should be simple especially as it’s not a dual boot machine: the single SDD is dedicated to one installation…>HELP

Some laptops need a good battery to handle power demand peaks that exceed the capacity of the wall supply, or you may actually have a good battery with a failure elsewhere in the power systems.

Do you have an external monitor? Some reports of laptop black screens say an external monitor works.

@gnwill Thank you for your reply. I attempted a ‘repair install’ after fully charging the new battery in question (it’s directions had me try to discharge it to ~20% before charging it, but it died after a short time.) The battery seems to have charged OK.

I ran the install from a single stick (not Ventoy this time – I’ve seen people question it, but it has worked every time for me, just removing a potential variable.) Rewrote my original partitions (100GB for /, 100GB for /usr, and remainder of ~730GB for /home ). It had me unlock the previous /home partition (LUKS2) and then presumably overwrote / and /usr without formatting, and (?) left /home untouched.

Same result, asked to unlock /home and then it goes to the black screen. I was just about to nuke all the partitions with a format and re-install – 1 last try*, but hooking up a monitor to test it is a much better next step, thanks.

I’ll post back if it works or doesn’t.

* I really wanted Fedora 40 to work out for me on this laptop

I tried, all I get is a replica of the laptop screen. I’m going to nuke it, see if a format and re-install is worthwhile. Hmm. Not sure I learn from my mistakes! haha

Please make an attempt to help us understand the reasons for a black screen. There are probably other users with the same problem who will benefit.

I gather that the Live USB installer works. You should have a “rescue” kernel that gives you the installer configuration (kernel and modules) in the grub menu. If booting the rescue kernel works, we may be able to get information using journalctl -b -N, where N is the number of the previous boot with the updated kernel. This will take some work as journalctl collects massive amounts of data. You can start by checking for “priority” messages with journalctl -b -N -p 3 | cat (the | cat will wrap the very long lines journalctl produces so they don’t get truncated when you paste the text into a forum post).

Recent kernels have made significant changes to power management (in an effort to meet current energy efficiency standards – before I retired, my cubicle was on a newly renovated floor that provided 300 watts per cubicle, so it was not unusual for someone to plug in a cooling fan or desk light that tripped the breaker in a locked utility room).

Laptop power management on older models was vendor dependent. Now there are some “standards” but it is all to common for older hardware to encounter problems. Often this is just an oversight by developers who are using modern hardware and didn’t anticipate idiosyncracies in older hardware.

It will help us suggest search terms for use with journalctl if you can provide hardware details. Please post the output from running inxi -Fzxx in a terminal (as pre-formatted text using the </> button from the top line of the text entry box). This tells us what devices your system has and which modules are being used.

I did try the rescue kernel: black screen with prompt. Everything I did resulted in the same ultimate conclusion unfortunately. I was able to edit the grub menu inter-vivos, by hitting ‘e’ and removing graphic boot command from the kernel string used to boot, adding nomodeset=0 and also tried nomodeset . They produced different results, both showed messages produced during the boot process; in both cases it stopped with esoteric (to me) messages that essentially requested my LUKS2 password to mount home. In both cases it accepted the password and then continued process but with no more messages to screen, and within a split second went to the black screen with prompt in the top right corner.

I’ve spent too much time on this already, but there’s not much more I can tell you. Running a live boot did not turn up logs from journalctl, and I’m not sure why. I was unable to resurrect the system in 2 days of trying. I had to nuke that installation and restart, so anything that I might have missed on the drive is now overwritten. I can return to this thread and give hardware details, it’ll be a while…life. To start I have to bring that system back up, get networking going, security, clients, etc, and I have hungry animals, plants to get in the ground, repotting the Acer palmatums (into 11^3’ pots!), run the network cable, etc. It’ll be a day or so, but I’ll get the inxi -Fzxx posted at least. For now it’s an HP 6570B laptop running on a 15AMP circuit @ 120VAC

Thanks for your help, sorry I couldn’t preserve the remnants, but that system has work to do.