Fedora 40 Gnome on Wayland issue - screen remains blank after locking

I upgraded f40 from f39, and I was exclusively using Gnome on wayland.
However after upgrading to 40 I am noticing an issue - if I lock the system using Super + L, the screen goes blank, and after that whatever I press the screen remains blank, the login screen does not show up.
Only option from here I found is to click CRTL + ALT + F1 - this shows me the login screen.
Any idea why this is happening and how to resolve it?
Thanks.
P.s. This is not happening in Gnome with X11.

System info from Neofetch:

OS: Fedora Linux 40 (Workstation Edition) x86_64
Host: Strix 15 GL503GE 1.0 
Kernel: 6.8.7-300.fc40.x86_64 
Uptime: 22 hours 
Packages: 2700 (rpm), 32 (flatpak) 
Shell: bash 5.2.26 
Resolution: 1920x1080 
DE: GNOME 46.1 
WM: Mutter 
WM Theme: Adwaita 
Theme: Adwaita [GTK2/3] 
Icons: Papirus [GTK2/3] 
Terminal: gnome-terminal 
CPU: Intel i5-8300H (8) @ 4.000GHz 
GPU: Intel CoffeeLake-H GT2 [UHD Graphics 630] 
GPU: NVIDIA GeForce GTX 1050 Ti Mobile 
Memory: 3635MiB / 23883MiB

Added f40 and removed f39, flatpak, intel, nvidia, workstation

Hey, I’m having a similar Issue after switching from Fedora 39 to Fedora 40:
To me this occurs the second I want to login.
I’m on AMD though, so that may be a factor.
If Wayland stays selected on my login screen I get a grey frozen image. (Funny enough if I turn my Display off and on, the Background Image loads and the mouse cursor starts working again, everything else stays frozen)

We both seem to have an unusual refresh rate…

For anyone else reading along I switched to gnome / mutter on Login Screen (Select my name → click on gear icon menu in lower right → select gnome /x11; then log in) to solve the issue (like parent). Funny enough libvirtd crashes on startup too, but issuing “systemctl restart libvirtd” in Terminal makes everything work again.

OS: Fedora Linux 40 (Workstation Edition) x86_64
Kernel: 6.8.8-300.fc40.x86_64
Packages: 5334 (rpm), 224 (flatpak), 6 (snap), 164 (brew)
Shell: zsh 5.9
Display (ASUS PB277): 2560x1440 @ 75Hz
DE: Gnome 46.1
WM: Mutter (X11)
WM Theme: gnome-shell-selene
Theme: Adwaita [GTK2/3/4]
Icons: Adwaita [GTK2/3/4]
Font: Cantarell (11pt) [GTK2/3/4]
Cursor: Adwaita (24px)
CPU: AMD Ryzen 9 5900HX (16) @ 4,68 GHz
GPU: AMD Radeon Vega Series / Radeon Vega Mobile Series
Memory: 14,40 GiB / 30,77 GiB (47%)
Swap: 0 B / 8,00 GiB (0%)
Disk (/): 44,85 GiB / 87,52 GiB (51%) - ext4
Locale: en_GB.UTF-8

I have a similar issue. After upgrading from 39 to 40 I didn’t experience any issue with the nvidia driver.
However today after the kernel upgrade from kernel-6.8.7-300.fc40.x86_64 to kernel-6.8.8-300.fc40.x86_64 I had the same problem.

At the reboot the system shows the black screen and the prompt.

So I rebooted the system with the nouveau driver removed all the nvidia packages:

# dnf remove *nvidia*

I rebooted once again and I re-installed them:

# dnf install akmod-nvidia -y
# dnf install xorg-x11-drv-nvidia-cuda -y

The module was built and modinfo showed the version:

# modinfo -F version nvidia
550.78

However after the reboot again black screen and prompt. So I booted with the nouveau and I disabled the wayland:

# cat /etc/gdm/custom.conf | grep Way
WaylandEnable=false

My system info:

# neofetch --backend --off
root@fedora 
----------- 
OS: Fedora Linux 40 (Workstation Edition) x86_64 
Host: Z790 GAMING X AX 
Kernel: 6.8.8-300.fc40.x86_64 
Uptime: 28 mins 
Packages: 2791 (rpm), 17 (flatpak) 
Shell: bash 5.2.26 
Resolution: 2560x1440 
WM: Mutter 
WM Theme: Adwaita 
Theme: Adwaita [GTK2/3] 
Icons: Adwaita [GTK2/3] 
Terminal: terminator 
CPU: Intel i9-14900K (32) @ 5.700GHz 
GPU: NVIDIA GeForce GTX 1080 Ti 
GPU: Intel Raptor Lake-S GT1 [UHD Graphics 770] 
Memory: 3782MiB / 64049MiB 

# inxi -Gx
Graphics:
  Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] vendor: Gigabyte
    driver: i915 v: kernel arch: Gen-13 bus-ID: 00:02.0
  Device-2: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: Gigabyte
    driver: nvidia v: 550.78 arch: Pascal bus-ID: 01:00.0
  Display: server: X.Org v: 1.20.14 with: Xwayland v: 23.2.6 driver: X:
    loaded: modesetting,nouveau unloaded: fbdev,vesa failed: nvidia dri: swrast
    gpu: nvidia,nvidia-nvswitch resolution: 2560x1440~60Hz
  API: OpenGL v: 4.5 vendor: mesa v: 24.0.6 glx-v: 1.4 direct-render: yes
    renderer: llvmpipe (LLVM 18.1.1 256 bits)
  API: Vulkan v: 1.3.280 drivers: N/A surfaces: xcb,xlib devices: 3
  API: EGL Message: EGL data requires eglinfo. Check --recommends.

Thank you

Update: I had to reinstall everything from the scratch ( I messed up by playing with the kernel).

However I found what I suspect is the root cause in my case and I wanted to share.

Basically on the same day when I did the kernel upgrade I decided to test the nomachine . I don’t need to be honest but I was curios and I installed.

After few tests I uninstalled it. However after the reboot I started to have the problem reported above with the nvidia drivers and wayland.

Even with the nouveau driver the applications (terminator included) didn’t work in wayland. I was not able to run even nautilus.

The nomachine is someone changing the system in this way.

It creates a udev rule and I suppose rebuild the initfsram disk ( not sure about last point)

# cat /etc/udev/rules.d/99-virtualgl-dri.rules
KERNEL=="card*|renderD*", MODE="0660", OWNER="root", GROUP="vglusers"

I also noticed this file:

# cat /etc/X11/xorg.conf.d/99-virtualgl-dri
Section "DRI"
Mode 0660
Group "vglusers"
EndSection

I dunno why but this was what basically happened to me.

I removed the udev rules and rebuild the ram disk and with the wayland enabled the system started to work, but I had the issue with the nvidia drivers.

Probably I had to remove the akmod:

$ sudo dnf remove kmod-nvidia-$(uname -r)

and rebuild a new module:

$ sudo akmods --force

But I was lazy and I found easy and fast to reinstall everything since the original version installed was the 37 , so next time :slight_smile:

I hope this helps and that someone with much more experience than me can find a real root cause.

Thank you!

1 Like

Even I reinstalled f40, and the issue is gone!