Blank screen after screen locked and no response

  1. I have a new external monitor, LG 29WK600, its screen size is 29". Why does Fedora 34 detect and call it LG Electronics 34" :flushed:. But the resolution detected is correct.
  2. After replacing the old one, Samsung LS24F350FFEXXT, with this new external monitor, blank screen after screen lock with no response has happened every time. Does this new external monitor concern this problem ? After I have removed HDMI cable out of the notebook. Everything is ok.
  3. And this question (updated video link of question) does not occur any more except a warning sound after using this new external monitor. This is good.
1 Like

I’ve had the same problem with a laptop with an intel gpu (n4100 apu).
It didn’t happen on the same hardware with ubuntu.
Probably it’s something related to gnome 40 on wayland.

1 Like

Now both Primary Display and Secondary/External Display,LG 29WK600-W, blackout.
I have to remove and use SAMSUNG LS24F350FHEXXT instead :pensive:.

I also have lg, did you try to check the settings of the monitor it selves? Menu > General > OSD Lock. See if this is on, This might locks you the screen ?!

1 Like

Thank you so much.
Now just right after input the username and password on Fedora login page, both monitors, immediately blackout :disappointed:. Keyboard and mouse still work but anyway notebook has to be switched off.

@afdrnk did you try to log in with x11?

1 Like

I have yet to, but that defies the point of having gnome 40/wayland in the first place.

1 Like

Sometimes hardware incompatibilities override personal preferences. Wayland is not perfect and is much younger than xorg so has had less time to iron out the bugs.

1 Like


I tried GNOME on Xorg, the result is the same :disappointed: .

Did I report this bug to the wrong place ?

It works on ubuntu, clear llinux, cent os, debian, arch linux…
It’s fedora that’s not configured properly.

1 Like

Please have a look on the link below. Maybe this helps you to find out what is wrong. I guess there is a problem with the frequency ?!

Have you both ever checked if there is a firmware update for your laptops/computers?

https://www.leowkahman.com/2019/02/06/ultrawide-monitor-on-linux/

1 Like

Is this external monitor detected automatically on Ubuntu and Arch Linux ?
I am an ordinary user, setting up additionally is not that easy for me :cold_sweat:.

I’m adding this here because it seems to be a similar problem:

I’ve been using my AMD based ThinkPad P14s Gen 2 with the Lenovo Universal USB-C dock and two old LG displays at work for the past year, running Fedora 36, then 37, and Gnome on Wayland.

A few days ago, a few things happened:

  • I installed the same dock at home
  • I ran fedora updates, which:
    • Updated the firmware of the laptop
    • Updated the firmware of the new dock (probably with a firmware the work dock already had)
    • Updated the system itself

After this, everything worked fine at home, but today, at the office, the screens never wake up once I locked the screen once and let the screens turn off.

The screens are still recognized in the display options, and disabling and re-enabling one of them gets both working again.

Switching to X.org based Gnome removes the problem.

I got a few traces from the kernel which are “unreportable” due to too little information

WARNING: CPU: 5 PID: 5229 at drivers/gpu/drm/amd/amdgpu/../display/dc/core/dc_link.c:3533 update_mst_stream_alloc_table+0x129/0x130 [amdgpu]
Modules linked in: uinput overlay veth rfcomm snd_seq_dummy snd_hrtimer xt_nat xt_conntrack xt_MASQUERADE nf_conntrack_netlink xt_addrtype nft_compat br_netfilter bridge stp llc nft_objref nf_conntrack_netbios_ns nf_conntrack_broadcast nft_fib_inet nft_fib_ipv4 nft_fib_ipv6 nft_fib nft_reject_inet nf_reject_ipv4 nf_reject_ipv6 nft_reject nft_ct nft_chain_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 ip_set nf_tables nfnetlink qrtr bnep sunrpc vfat fat rtw89_8852ae snd_soc_dmic snd_acp3x_pdm_dma snd_acp3x_rn intel_rapl_msr snd_sof_amd_rembrandt intel_rapl_common rtw89_8852a snd_ctl_led snd_sof_amd_renoir snd_sof_amd_acp snd_hda_codec_realtek rtw89_pci snd_sof_pci snd_sof snd_hda_codec_generic rtw89_core edac_mce_amd snd_hda_codec_hdmi snd_hda_intel snd_sof_utils kvm_amd mac80211 snd_intel_dspcfg snd_soc_core uvcvideo btusb snd_intel_sdw_acpi kvm btrtl snd_compress videobuf2_vmalloc snd_hda_codec videobuf2_memops btbcm ac97_bus videobuf2_v4l2 btintel snd_hda_core
 snd_pcm_dmaengine libarc4 videobuf2_common btmtk snd_pci_ps snd_hwdep irqbypass snd_rpl_pci_acp6x snd_seq bluetooth videodev snd_pci_acp6x snd_seq_device rapl cfg80211 think_lmi snd_pci_acp5x joydev mc snd_pcm thinkpad_acpi pcspkr firmware_attributes_class wmi_bmof k10temp snd_rn_pci_acp3x ledtrig_audio snd_timer platform_profile snd_acp_config snd_soc_acpi snd nxp_nci_i2c nxp_nci snd_pci_acp3x i2c_piix4 soundcore nci nfc rfkill i2c_scmi acpi_cpufreq zram dm_crypt amdgpu drm_ttm_helper ttm rtsx_pci_sdmmc iommu_v2 crct10dif_pclmul crc32_pclmul crc32c_intel mmc_core gpu_sched polyval_clmulni nvme polyval_generic drm_buddy drm_display_helper nvme_core ghash_clmulni_intel sha512_ssse3 ucsi_acpi ccp serio_raw typec_ucsi r8169 cec sp5100_tco rtsx_pci typec nvme_common video wmi ip6_tables ip_tables fuse
CPU: 5 PID: 5229 Comm: gnome-shell Not tainted 6.1.7-200.fc37.x86_64 #1
Hardware name: LENOVO 21A1S00E00/21A1S00E00, BIOS R1MET51W (1.21 ) 09/15/2022
RIP: 0010:update_mst_stream_alloc_table+0x129/0x130 [amdgpu]
Code: e8 03 89 c1 f3 48 a5 48 81 c4 90 00 00 00 5b 5d 41 5c c3 cc cc cc cc 41 0f b7 40 04 4d 89 19 49 89 59 08 66 41 89 41 10 eb 87 <0f> 0b e9 14 ff ff ff 0f 1f 44 00 00 55 48 89 fd 53 bb 0a 00 00 00
RSP: 0018:ffffab6482ecb580 EFLAGS: 00010202
RAX: 0000000000000002 RBX: 0000000000000000 RCX: 0000000000000000
RDX: 0000000000000000 RSI: ffffab6482ecb580 RDI: ffffab6482ecb610
RBP: ffff956f9e5c0aa0 R08: ffffab6482ecb638 R09: ffffab6482ecb3b8
R10: ffff956e4e795400 R11: ffff956e58315660 R12: 0000000000000002
R13: ffff956ef87e6800 R14: ffffffffc0ed98e0 R15: 0000000000000000
FS:  00007f3761b755c0(0000) GS:ffff957451f40000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000565452815004 CR3: 00000001fa598000 CR4: 0000000000750ee0
PKRU: 55555554
Call Trace:

Note the missing call stack.

I don’t really know how to proceed with that. Switching to X gets me working again temporarily, but it breaks a lot of my setup and seems to be less performant than Wayland.