Sometimes there is no screen at all after login (Fedora 39)

Hi, I am very new to Fedora. I switched from another distro a few weeks ago. My problem is, sometimes when i start my system (or reboot) after i login in login screen there is no screen at all. I’m not talking about black screen. There is no screen view at all. I did not experienced this thing before with other distros.

What i tried:

  • I tried to reboot system in terminal without seeing a thing (with shortcuts) to see if the problem is with my monitor or something else. System doesnt reboot so system is not loading (probably is booting session?)

  • Tried with different kernels. No change.

PS: I did not tried to use xorg istead of wayland yet. And this could be a gpu compatibility problem since so many applications i want to use have this screen flickering issue.

Everytime i get this bug(?) i have to power off my system by using power button and restart again. It can takes 2-3 starts for me to see the screen again. Does someone else have this experience? I liked Fedora a lot and i am exploring its ecosystem so i hope anyone can give me an idea.

System Details Report


Hardware Information:

  • Hardware Model: Micro-Star International Co., Ltd. MS-7D43
  • Memory: 32.0 GiB
  • Processor: 12th Gen Intel® Core™ i5-12400F × 12
  • Graphics: NVIDIA GeForce RTX™ 3060
  • Disk Capacity: 500.1 GB

Software Information:

  • Firmware Version: 1.G0
  • OS Name: Fedora Linux 39 (Workstation Edition)
  • OS Build: (null)
  • OS Type: 64-bit
  • GNOME Version: 45.3
  • Windowing System: Wayland
  • Kernel Version: Linux 6.6.14-200.fc39.x86_64
1 Like

Linux has varying degrees of compatibility with all the hardware that exists.

Especially with hardware, Fedora Linux can encounter problems before other distros because Fedora Linux tends to run the latest versions of the Linux kernel. Often times this means that Fedora Linux will be the first to work with hardware or to support more advanced features of hardware, but it also means that sometimes Fedora Linux will encounter a bug before another distro.

Since the problem in this case seems to be something to do with the video, have you tried adding nomodeset to your list of kernel parameters? That will try to run your video card in a “basic graphics” mode with most of the advanced features disabled (e.g. stuff like 3D acceleration that is used by video games).

1 Like

This is common when using a newer nvidia GPU such as you have when the nvidia drivers are not installed or were possibly corrupted during an update.

You should be able to boot with basic graphics by pressing e at the grub menu then edit the line that begins with linux and remove the part that says nvidia-drm.modeset=1 and replace that with nomodeset.
After it boots you should either install the nvidia drivers from rpmfusion (assuming they are not installed) or repair the already installed drivers.

Repair consists of

  1. sudo dnf remove kmod-nvidia-* to remove the current modules
  2. sudo akmods --force to rebuild and install the new modules.
  3. reboot

If the nvidia drivers are not already installed verify you have the rpmfusion-nonfree-nvidia-drivers repo enabled using dnf repolist If not already enabled it can be enabled by opening the gnome software app and select 3rd party repos from the ‘hamburger’ menu at the upper right corner.
Once that repo is enabled the drivers can be installed by doing the simple steps of.

  1. sudo dnf upgrade to ensure everything is up to date
  2. sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda to install the drivers and all dependencies.
  3. Wait at least 5 minutes after step 3 completes then reboot.

As long as secure boot is disabled this should be all that is required.

1 Like