Fedora 39 Workstation (Wayland) and AMD FreeSync?

I’m new to Fedora and started with an installation of Fedora 39 Workstation Final. Because I’m using an AMD Radeon RX 7800 XT I want to enable and use AMD FreeSync like I use it on Windows 11.

Searching for a solution, I found out that Linux Kernel 6.5 is now supporting AMD FreeSync (https://www.hostzealot.com/blog/news/discovering-fedora-39-exciting-features-and-enhancements). Is it enabled by default in Fedora 39?

I also found Gnome-VRR project that deals with this topic (kylegospo/gnome-vrr Copr), and it looks like I have to install modified Gnome files. But actually there isn’t a repository that matches Gnome 45.1.

What can I do now? Should I wait for a newer version of Gnome-VRR? Or is there any other possibility to use AMD FreeSync?

1 Like

No one? :cry:

To the best of my knowledge, there is no estimated time in which Variable Refresh Rate (VRR) will be supported by Mutter and GNOME Shell. @jadahl would probably have more concrete information on this, but right now, you’re only real choice (without patching and forked packages) for this capability is KDE Plasma.

1 Like

Thanks a lot, Neal! So, with Gnome I have to wait or use VSync instead.

It looks like the kylegospo repo you mentioned has been updated the most, so that is probably the best bet for getting the patch updated for 45.1. That or wescode. He just did one for 44.5. That is what I was using prior to the Fedora 39 update and it worked perfectly for me on both monitors.
I now regret not waiting to update to Fedora 39. I saw the repo for 39, but didn’t realize it was for the beta of Fedora 39. I would probably pay someone $50 (more updates included) if they would update the COPR repo. Maybe we can pool a bunch of us together to create more interest?

Gnome needs to bake this in IMO. Supposedly there are a couple small issues that I never experienced. However, there is a toggle switch in display settings. Just have it default to off until they are fixed.

There must be a way to manually compile and replace mutter and control center from the Dor Ayasko MR manually (seems like they’ve updated for 45.1 and 45.2, but I’m not certain I am interpreting correctly). I’ve only built from source once with explicit instructions, so it could be a bit risky for me without that! I have been unable to find anyone providing instructions however.

I also would pay for a solution here. :slight_smile:

1 Like

Thanks. I’m not sure how we’d organize such a thing but I will keep you in mind if I see more interest. It’s possibly just a time issue and it may not motivate anyone. There is a website to create a bounty for opensource developers as well. I’ll try to dig that up again.
For now, I just installed the KDE DE in Fedora and VRR is working great in a Wayland session after turning adaptive sync on in display settings. It’s easy to switch DE’s. Just log out and back in the other one you want.
Sometimes life is easier if you don’t resist things. May just have to accept KDE is better for gaming. Now whether I will stay with it for everyday PC use, we’ll see. I didn’t like it much before. I find it cluttered and unrefined and had a good amount of glitches last time I used it. None so far though.

1 Like

I found a guy who has a deeper sight into the Gnome development. He pointed me to the Gnome Roadmap, where you can see that VRR function is planned for Gnome 46 release.

Apparently there seems to be a bigger problem when you activate or deactivate Freesync or set it to automatic. Sometimes there are strange artifacts or flickering with certain things. This does not seem to be a problem of Gnome/Mother integration. Since KDE has the same problem.
It seems to be an issue with drivers. AMD is involved.

Hopefully they are able to fix the issue and developers will integrate VRR into Gnome as soon as possible.

1 Like

This is great news! I’m not liking KDE at all. It’s not worth the hassle having two DEs either as it contaminated Gnome with other fonts and icons and appearance settings. Major pain switching it back.
I’ll have to deal with no VRR until April/May unless someone updates the COPR. At least we know when to expect it now.

1 Like

Looks like there is an update available for Gnome 45.2. I didn’t test it yet. But will test it soon. :wink:

Installed the new version and it works. :slight_smile:

Thanks for info and update! Good to hear. I was planning to give it a try in a few hours.

Works also on Nobara linux :+1:

1 Like

I just noticed a screen flickering when watching videos (e.g. YouTube) in full screen and moving the mouse. Do you also notice that behavior?

Actually, I think about removing VRR again because of that. :confused:

No issues with anything full screen here. I just double checked some YT videos fullscreen as well in Brave and Librewolf. In Librewolf the cursor is laggy but works fine.
Are you using an AMD GPU?
DP cable? I thought I heard that’s more reliable than HDMI.
Or maybe the monitor brand. No issues with Samsung and ACER here.

1 Like

Yes, an AMD Radeon RX 7800 XT.

Display Port is used.

I’m with Dell … Maybe that’s my problem? :confused:

I just found out a strange thing.

My default Refresh Rate is set to 120 Hz, and full screen is flickering. So I tried switching the Refresh Rate to the maximum of 164,06 Hz. But flickering is still there. Switching to 120,02 Hz solved the issue. There is no flickering anymore. :confused:


I think I’ll keep an eye on this. Hopefully this is the solution for me. Fingers crossed. :wink:

That was smart to try that. Honestly I don’t know why there are multiple refresh rates not in whole numbers. I get that sometimes too. Even in Windows. Glad it worked!

I installed this but I didn’t get the toggle button like you. I verified that VRR is working in my games under Wayland.