Fedora 39 installation and shutdown issues with Lexar NM790

Hey guys,

my first post so please tell me if something is wrong.
I bought a new Lexar NM790 4TB and want to install Fedora 39. I ran in an issue that Fedora 38 can’t found the nvme drive. Fedora 39 found the nvme drive but run in an issue with allocation storage with the partitions schema. I made a custom partition scheme and can successfully install Fedora 39 on my machine. But when I want to shutdown the machine it stucks in the shutdown process. The reboot process works as expected-

I google a little bit that the Lexar NM790 nvme drive encounter issues with Linux but only with the boot process which should be fixed with kernel version 6.5.

What the currenty issue is with the shotdown i don’t know. I will provide logs today.


the last log lines from the shutdown process:

[20.6757121] systemd-shutdown[1]: Sending SIGKILL to remaining processes…
[20.6785161] systemd-shutdown[1]: Unmounting file systems.
[20.6789451] (sd-remount)[19381]: Remounting '/' read-only with options seclabel ,compress=zstd:1,ssd, discard-async ,space_cache=v2, subvolid=257 ,subvol=/r-...
[20.7077401] systemd-shutdow[1]: All filesystems
[20.7078121] systemd-shutdown[1]: Deactivating swaps.
[20.7078851] systemd-shutdown[1]: All swaps deactivated.
[20.7079401] systemd-shutdown[1]: Detaching loop devices.
[20.7081051] systemd-shutdown[1]: All loop devices detached.
[20.7081351] systemd-shutdown[1]: Stopping MD devices.
[20.7082191] systend-shutdown[1]: All MD devices stopped.
[20.7082291] systemd-shutdown[1]: Detaching DM devices.
[20.7082691] systend-shutdown[1]: All DM devices detached.
[20.7082781] systemd-shutdown[1]: All filesystems, swaps, loop devices, MD devices and DM devices detached.
[20.7333761] systemd-shutdown[1]: Syncing filesystems and block devices.
[20.7334951] systemd-shutdownI11: Powering off.
[20.7335751] kvm: exiting hardware virtualization
[20.8591511] sd 9:0:0:0: [sdc] Synchronizing SCSI cache
[20.8636251] sd 9:0:0:0: [sdc] Stopping disk
[20.9364531] sd 8:0:0:0: [sdb] Synchronizing SCSI cache
[20.9406931] sd 8:0:0:0: [sdb] Stopping disk
[20.9883201] sd 6:0:0:0: [sda] Synchronizing SCSI cache
[20.9910171] sd 6:0:0:0: [sda] Stopping disk
[21.5353101] r8169 0000:0e:00.0 enp14s0: Link is Down
[21.7056641] ACPI: PM: Preparing to enter system sleep state S5

Hey, have you solved the problem? Upgraded to F40 already?