Fedora 39 Kernel 6.7.4 Shutdown Freezes

Good afternoon all. I am a new Fedora user and just installed Fedora 39 on my 2013 MacBook Pro (macbookpro11,3). When I did the initial install, everything ran smoothly. The update process updated my linux kernel from 6.6.8 to 6.7.4. Now, I am finding that the computer freezes during the shutdown process (the “circle” will spin, then disappear, and the laptop remains in that state until I press the power button to shutdown).

When I boot with the 6.6.8 kernel, everything operates fine. It’s only on the 6.7.4 kernel.

I tried the command “shutdown -P now” on 6.6.8 - worked fine. The command on 6.7.4 hangs.

Some specs from Neofetch:

Host: MacBookPro11,3 1.0
Kernel: 6.6.8-200.fc39.x86_64
CPU: Intel i7-4850HQ (8) @ 3.500GHz
GPU: NVIDIA GeForce GT 750M Mac Edition
Memory: 1782MiB / 15898MiB

Currently using nouveau driver on Wayland.

Any advice would be greatly appreciated. Thanks.

So, I got some additional information. I did a shutdown with both 6.6.8 and 6.7.4 and got the journal from each shutdown (command “journalctl -rb -1”). One thing that keeps showing up in the 6.7.4 shutdown is the following entry (it appears multiple times in the journal during shutdown):

audit[3601]: AVC avc: denied { checkpoint_restore } for pid=3601 comm=“plymouthd” capability=40 scontext=system_u:system_r:plymouthd_t:s0 tcontext=system_u:system_r:plymouthd_t:s0 tclass=capability2 permissive=0