Fedora 38 - Printer problem

My printer started printing the text and image with a mirror effect this morning. I tested the printer using various applications, and the outcome was the same.

I’m using Fedora 38, and my laptop is directly connected to the Brother DCP-135 printer via USB. I’ve had no problems using this printer for a very long time.

In order to troubleshoot:

  1. Same issue after removing and re-adding the printer in the gnome settings.
  2. I used another printer (HP Envy) with the Fedora laptop and it worked.
  3. I connect the Brother printer to another laptop with Debian and it worked.

The cups and gnome printer settings looks fine.

I am unsure of what else to look into.

Thank you

What is the history? Was this printer working wth some previous Fedora version that has been upgraded to F38?

CUPS has undergone significant changes since the author left Apple. The main focus is now on network printing using IPP (aka AirPrint until Apple changes Airprint). Follow the URL given by dnf info gutenprint.x86_64 (http://www.cups.org) and you will see “High quality drivers for Canon, Epson, Lexmark, Sony, Olympus, and PCL printers for use with CUPS”.

The site has a list of supported printers that has some Brother printers. Printer vendors often sell several models using the same basic printer language with different “newer and better” features, so sometimes a different driver will work if you avoid features not supported by your model. If you have an old PPD file that used to work, you may be able to find a similar PPD in the current Fedora package.

Since F34, I have used the printer without problems. As previously reported, the printer has a mirror effect since the other day. I attempted to use the settings to enable the mirror printer, but it didn’t work.
gutenprinter is currently at version 5.3.4.

Name : gutenprint
Version : 5.3.4
Release : 10.fc38
Architecture : x86_64

Updates don’t always replace CUPS configuration and PPD files that were installed for previous versions (especially if there is no “official” PPD in 5.3.4 for your printer). Look for .rpmnew and .rpmsave files in /etc/cups and subdirectories.

ls /usr/share/gutenprint/5.3/xml/printers lists several vendor print protocols and “generic” protocols (PS, PCL) .

What versions of CUPS and Gutenprint does Debian have? You might be able to convert the Debian configuration to the Fedora versions.

Since you are printing, I wonder if somehow your printer options got saved with a “Flip Horizontally” box ticked.

Have you looked at the options page you get just before you print for this? It might be under a layout menu, or other options menu.

Good luck!

And many more printer drivers are found in the foomatic packages. The PPD files for installed printers are never replaced. They are copied from the foomatic or gutenprint data bases when creating the printer definition into the /etc/cups/ppd directory and thereafter not updated.

I get the ppd files from Debian, and the code is the same.
I attempted to eliminate the mirror effect, by enabling the mirror print as by default was off, but the problem persists.

*%=== Mirror Printing ================================
*OpenUI *MirrorPrint/Mirror Print: Boolean
*OrderDependency: 20 AnySetup *MirrorPrint
*DefaultMirrorPrint: OFF
*MirrorPrint OFF/OFF: " "
*MirrorPrint ON/ON: " "
*CloseUI: *MirrorPrint

*%=== Mirror Printing ================================
*OpenUI *MirrorPrint/Mirror Print: Boolean
*OrderDependency: 20 AnySetup *MirrorPrint
*DefaultMirrorPrint: ON
*MirrorPrint OFF/OFF: " "
*MirrorPrint ON/ON: " "
*CloseUI: *MirrorPrint

This is the problem when I print…

Here is a random example from a web search for *OpenUI *MirrorPrint/Mirror Print: Boolean:

*OpenUI *MirrorPrint/Mirror Print: Boolean
*OrderDependency: 40 AnySetup *MirrorPrint
*DefaultMirrorPrint: False
*MirrorPrint False: "<</MirrorPrint false>>setpagedevice"
*MirrorPrint True: "<</MirrorPrint true>>setpagedevice"
*CloseUI: *MirrorPrint

This looks more like what I remember of PPD files.

I wasn’t thinking about the PPD default.

I was thinking of something along the lines of an option within an Options or a More Options tab you might see on your print preview page.

Sometimes, if such an option exists for your printer, it gets selected mistakenly. It seems to be a possibility for you; it also seems to be remembering that across print jobs.

This seems pretty frustrating, so good luck getting to the bottom of it!

Hi All,
First of all, I want to thank everyone for your assistance and support.

By installing the printer drivers in the rpm package from this page, I was able to remedy the issue.
Everything started working as it had previously once I removed and added the printer in the settings page.

I’m hoping that these drivers may help someone else who is experiencing the same issue.

Happy to learn you’re back in business with your printer.

One question: Were you able to save a copy of your original printer-related files so that you could run a diff on them? That would really be helpful to others, I believe.

As for the business of IPP being the standard since the early 2000s, I could not get my Canon LBP 6030 to install until I found an archive with the rpm files necessary to make my networked printer work. This is after following the process outlined in the CUPS web interface’s administration page for my network (port 631 by default). The system couldn’t find the printer’s driver. I believe that this printer was first made available in the mid 2010s.

IPP is “Internet Printing Protocol” and not found on USB only printers. Printer manufacturers need not conform to any particular standard, but because Apple AirPrint has been the same as IPP for years, many printers with network capabilities do support IPP. I don’t think either
the LBP 6030 or 6030w (wireless) support AirPrint/IPP.

There are three standards which are almost identical

  • AirPrint
  • IPP Everywhre
  • Mopria

And CUPS supports all three of them.

There is also IPP over USB which some printers support. For this you need the package ipp-usb. What it does is creating a deamon which will convert TCP/IP to USB.

Yeah, of course I got the model of my printer incorrectly when I was describing this matter: My printer is the wifi version, LBP 6030w.

I set it up with a static IP address, and the IPP url strategy didn’t work for me. So I followed the CUPS-suggested network printer discovery process to find it and the only option given was as a dnssd url type. No ipp option was offered at that time either. When I tried to add the printer with this url type, I was prompted to select among a number of printer models in a list. Before I installed the manufacturer rpms, the LPB 6030w wasn’t in the list; afterwards, it was found and allowed me to add it.

I always seem to tell my stories slightly incorrectly on here, apologies for that!