Fedora 38, on wireless I can reach the internet, but non of the devices on my local network. DNS issue?

Hello all,

I am not super new to linux but I am no wizard by any stretch of the imagination. I just started a new job at a small company and I am having an issue with my laptop wireless adapter.

When I connect to the office network wirelessly, I can use the internet, send and receive e-mails, etc. no slowdowns or anything f the sort.
However, I cant ping any other device on the local network, no printers, computers, not even the router (a Linksys WRT1900AC).

When I connect to the router through the wired lan, I have no issues whatsoever, I can print, ping and everything.

Since I do have internet, I am ruling out the driver, and I can ping both and www.google.com, so not sure about the DNS server.

I am pretty sure it must be some config somewhere but my linux experience is not that advanced.

Any help will be greatly apreciated

It would be best to provide a diagram illustrating your network topology.
Clarify if you can reproduce this issue using other devices.
Test ping and traceroute by IP address.

Hello Vladislav,

Thank you very much for your response. The topology is quite what you would expect at a small office with no it support.

I havent been able to test using other devices per-ce as I dont have another router at my disposal, but all other computers can print, and if they ping any other computer they can see each other (all of them Windows or Mac, I am the only linux)
However, when I am on wireless connection They can’t ping me.

When I am on wired, everything works as normal.

a rather obvious observation, but just to put everything on the table, Wireless and ethernet adapters are separate.

I did a traceroute from my computer to google and then to the printer, here are the results:

[cristobal@cris-fedora ~]$ traceroute -n google.com
traceroute to google.com (, 30 hops max, 60 byte packets
 1  2.338 ms  2.354 ms  2.306 ms
 2  2.725 ms  2.709 ms  2.692 ms
 3  4.144 ms  4.738 ms  4.721 ms
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * *^C
[cristobal@cris-fedora ~]$ traceroute -n
traceroute to (, 30 hops max, 60 byte packets
 1  3086.399 ms !H  3086.372 ms !H  3086.345 ms !H
[cristobal@cris-fedora ~]$ 

1 Like

Sorry, forgot to add the traceroute to the printer when on ethernet

[cristobal@cris-fedora ~]$ traceroute -n
traceroute to (, 30 hops max, 60 byte packets
 1  3086.399 ms !H  3086.372 ms !H  3086.345 ms !H
[cristobal@cris-fedora ~]$ traceroute -n
traceroute to (, 30 hops max, 60 byte packets
 1  54.082 ms  51.558 ms *
[cristobal@cris-fedora ~]$ traceroute -n
traceroute to (, 30 hops max, 60 byte packets
 1  10.221 ms  8.481 ms  11.908 ms
[cristobal@cris-fedora ~]$ 

The failed one is on wireless, the otherr 2 are on ethernet

Are wired and wireless clients in the same subnet?
Are there any other wireless clients affected by the issue?
Are you connecting to the same SSID as other wireless clients?

Are wired and wireless clients in the same subnet? → Yes
Are there any other wireless clients affected by the issue? → No
Are you connecting to the same SSID as other wireless clients? → Yes

If both ping and traceroute by IP fail, it looks like a problem with the router.
There’s a high chance the router filters wireless transit traffic, so the destinations matching the local subnet are allowed only for whitelisted MACs.

but pretty much everything in the office is connected wirelessly and one of the first things that I tried to fix this issue was to reset the router to factory default, so there are no whitelisted MAC addresses… :thinking:

Hello @cristo87 ,
Out of curiosity, what does nmcli show you? From your laptop, I mean.

Hello @jakfrost ,

Here you go

[cristobal@cris-fedora ~]$ nmcli
wlp2s0: connected to IRIG (2)
        "Qualcomm Atheros QCA6174"
        wifi (ath10k_pci), D8:0F:99:28:B6:A7, hw, mtu 1500
        ip4 default
        route4 metric 600
        route4 default via metric 600
        inet6 fe80::d1a4:e427:545e:890f/64
        route6 fe80::/64 metric 1024

lo: connected (externally) to lo
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536
        inet6 ::1/128

br0: connected to br0
        bridge, F2:B5:92:4A:37:BD, sw, mtu 1500
        route4 metric 425
        route4 default via metric 20425

58:24:29:E2:89:CC: disconnected
        "Pixel 6"
        1 connection available
        bt (bluez), 58:24:29:E2:89:CC, hw

p2p-dev-wlp2s0: disconnected
        wifi-p2p, hw

enp0s31f6: unavailable
        "Intel I219-LM"
        ethernet (e1000e), D4:81:D7:BB:D9:68, hw, mtu 1500

DNS configuration:
        interface: br0

        interface: wlp2s0

Use "nmcli device show" to get complete information about known devices and
"nmcli connection show" to get an overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(7) manual pages for complete usage details.
[cristobal@cris-fedora ~]$

Thanks for that. Can you connect both wired and wireless at the same time and repeat the command to see if there are differences? then possibly nmcli connection show then nmcli device show <device name> for both to get a more detailed comparison on what NetworkManager is doing with your connections.

I will do that, but it will have to be tomorrow, because I had to leave the office for today.

I will try it as soon as I am in tomorrow morning

The bridge br0 conflicts with your wireless connection.
By using a lower metric, it overrides your subnet route.
Disable the bridge for routing to work correctly:

sudo nmcli connection modify br0 connection.autoconnect no
sudo nmcli connection down br0

@cristo87 did you install Fedora 38 using the “Fedora Server” installation iso or did you install Fedora 38 using “Fedora Workstation” or one of the desktop “Fedora Spins”?

The Fedora Server installation will allow you to connect to the internet and get updates, but it will block other devices from seeing your system when your are connected wirelessly. If you connect to the network using a wired ethernet connection, the other devices on the network will be able to see your system and ping and even remote log into the system.

If you use the “Fedora Workstation” install or one of the desktop “Fedora Spins” I don’t believe you will encounter this issue.

I discovered this while doing some testing for Fedora Server 38 on an old laptop for the Server Working Group. I’m not sure of the cause, I’m thinking it might be some firewall settings, I’m still trying to figure out the cause myself.

Hello Guys, sorry for disapearing for a few days, I had work outside of the office and had not been abe to test any of this.

Interestingly enough, I also moved into my new flat and this is the first time that I tried connecting to the wifi with my laptop, attempted to log into the router and I had the same issue. However, I followed @vgaetera 's advice, and it fixed it at home at least.

I will need to try this at the office but it wont be for a few days, however, I think that was the issue.

@mowest I installed it from the Fedora workstation iso. However I have been playing around with it not 100% taking notes of all the steps that I do. so at some point I transformed it to the KDE spin, now I reverted back to the GNOME default (although I still have all the KDE stuff installed, but I dont know how to do a clean up without re-installing everything from scratch)

@vgaetera , any idea why this bridge got activated? could it have to do with having a couple of virtual machines with QEMU? if so, any advice on how to configure it properly?

As soon as I test this at the office network, I will mark this as solved


@cristo87 Unless you are hurting for space in your root partition, I would encourage you to just continue running your current Fedora install. Yes, it has some extra stuff from your KDE install, but many of the plasma libraries you would pull into your default Fedora Workstation install when you install and try a program that is built on the plasma framework used by KDE Plasma. I’ve been running Fedora Workstation on the current SSD since Fedora 31. I’m sure that I have stuff installed that I don’t use, but I haven’t felt the need to recapture the space. Upgrades from one version to the next, so far, have gone flawlessly, so I don’t mess with it.

How did you install and configure he VM’s? Some installation instructions may assume you are installing on a server (e.g., without wifi).

That’s how the bridge works, it doesn’t disconnect automatically and keeps its address and routes once configured either with DHCP or statically.
Since there is no bridge by default, this means you created one at some point.

There are multiple different solutions with their own pros and cons.
The most simple way is to remove the bridge for switching between wired and wireless connections to work automatically.

The host can share its network connection with guests using virtual networking with NAT which doesn’t require host connection bridging.

@vgaetera Thank you very much for the explanations and help!

@gnwiii I will be honest, I dont remember, I setup QEMU a while ago and then have basically just cloned a clean install of windows a couple of times. The nly reason I use the VMs is for the ocasional times I need to run some Windows software. As I am more of a Tinkerer than linux extraordinaire, I am sure I followed a tutoral somewhere online.

1 Like