Can only reach local devices via WiFi, not via wired connection

Hello all! I’ve recently made some changes to my home network (ISP and router) and discovered yesterday that I couldn’t print from my wired Fedora 39 laptop. Full disclosure, I haven’t tried to print from my Fedora laptop in several weeks, so I can’t give any causation based on correlation beyond the ISP provider and router hw change. I did a simple ping to check connectivity and realized the only local device I could reach was the router itself and nothing else, however, I can reach external host without any issues. When I switch from wired to WiFi connection on the same laptop, I have no issues pinging or printing. In summary - can’t reach/ping “local” devices when using wired connection, can reach/ping “local” devices when using WiFi. Anything obvious come to mind? Bear with me, my Linux game is not strong but following other discussions I found, nothing really stands out from a configuration standpoint. Thanks in advance!

I wonder if your wired connection is not getting an address from your router.

What does ip addr report?

Its a Thinkpad sans a physical eth port, so “enp58s0u1c2” is the wired connection (USB-C to RJ45 adapter). Just to clarify, the only connectivity issue I have via the wired connection is to local devices; all else is normal, i.e., I can reach the internet, ping external host, etc., without issues.

Please do not poat screen shots of text. Copy-n-paste it here as pre formatted text using the </> button.
Which appears like…

this example

Can you connect the wifi at the same time as the wired and post the output of ip addr again and also ip route.

What is the ip address of the local device that you have difficult connecting to?

I wonder if your router has a guest network feature that meams wifi and wired are on separate networks.

As requested. Regarding your “guest network” statement, yes, there is one, however its strictly a guest network; no devices are currently connected to it. This Fedora machine is the only device that can’t ping locally wired.

$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host noprefixroute 
       valid_lft forever preferred_lft forever
3: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 48:2a:e3:3e:42:03 brd ff:ff:ff:ff:ff:ff
4: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 38:68:93:b7:2b:cc brd ff:ff:ff:ff:ff:ff
    inet 192.168.50.237/24 brd 192.168.50.255 scope global dynamic noprefixroute wlp0s20f3
       valid_lft 86390sec preferred_lft 86390sec
    inet6 fe80::596e:a625:98c4:a68f/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
12: enp58s0u1c2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether f8:e4:3b:90:32:59 brd ff:ff:ff:ff:ff:ff
    inet 192.168.50.22/24 brd 192.168.50.255 scope global dynamic noprefixroute enp58s0u1c2
       valid_lft 82961sec preferred_lft 82961sec
    inet6 fe80::e3d6:f899:2bca:82a/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

ip route
default via 192.168.50.1 dev enp58s0u1c2 proto dhcp src 192.168.50.22 metric 100 
default via 192.168.50.1 dev wlp0s20f3 proto dhcp src 192.168.50.237 metric 600 
192.168.50.0/24 dev enp58s0u1c2 proto kernel scope link src 192.168.50.22 metric 100 
192.168.50.0/24 dev wlp0s20f3 proto kernel scope link src 192.168.50.237 metric 600 

The IP of the printer is 192.168.50.141 (manual, not DHCP because we’ve had issues before with it when printing from our phones in DHCP). Its also wired, not wireless.

UPDATE (and possibly adding to the confusion) - I looked at tcpdump and noticed several arp queries from the laptop to the printer. I checked the arp table and saw the printer (and my switch) were showing incomplete data. I manually added them to the arp table and can now ping them.

Ok your ip address are find. Both on the same network.
You comment about ARP is interesting.

I think you should see ARP entries for both interfaces for your printer.
But for some reason ARP is oinly working from the WiFi connection?

Correct, only for WiFi (it can see it, so it builds it… wired cannot, so the ARP table is incomplete). All the usual suspects I have eliminated (firewall, etc.,). I have tried to isolate it to the router, however, I cannot find a specific setting that I haven’t already toggled to try and fix this, so I continue to lean on it being a issue with the laptop. Further to my last, I have no issues with pinging or connectivity to local devices from two other wired Windows machines, so its 99.9% the Fedora laptop.

I have often seen problems when 2 different interfaces on the same machine are connected to the same network and share a common subnet such as yours.

Please try turning off the wifi and connecting the wired interface and see if the problem remains or if it disappears.

The problem as I have seen in the past appears that the router sees one interface as primary for the system and pings may be sent out from one interface but are returned to the other interface, so it appears incomplete since the return is not received on the same interface from which it was sent.

I wish it were only that simple; the WiFi has only been used (on) in conjunction with having the wire connected for testing since I noticed the issue and at the request of the other poster.

Just to be clear: I asked for both to be on to gather information, not as a fix.