Fedora 38 KDE Spin didn't set keyboard layout at login screen properly


I have set programmer’s dvorak during installation.
After installation, the keyboard layout at login screen is still qwerty. But after logged in, my keyboard layout became programmer’s dvorak.
The strange thing is, this only happens to my real pc, I tried to repeat the same steps I have done in a virtual machine, but nothing happens, everything is normal.

I’m using a laptop with i7-11800H and rtx3070, with a 240hz display. I have no other PCs to test.

Fixed it by setting
in /etc/sddm.conf

1 Like