Fedora 36: USB C Dock disappears after suspend/sleep

This problem is new to Fedora 36. Everything described here worked fine in Fedora 35.

I have a Framework laptop attached via USBC to a dock that hosts my monitor via HDMI, keyboard, trackpad, and 2.4GHz mouse dongle (all via USB A).

Everything works when the dock is plugged in.

When the system goes to sleep, either because it was left idle or by shortcut keys, the dock essentially disappears from the system.

In Fedora 35, moving the mouse, clicking the trackpad, or touching a keyboard key would wake the system and everything returned to working order.

In Fedora 36, none of those behaviors wake the system. I have to physically open the laptop to wake the system, but that does not wake the USBC dock. I have to physically disconnect the dock from the USBC port and reattach it. This wakes the keyboard, mouse, trackpad, and monitor.

My laptop is docked 98% of the time, so this has made using Fedora 36 EXTREMELY frustrating.

I have the same issue. Seems to have occurred after a recent kernel update, worked ok before.
Any suggestions on troubleshooting are appreciated.

Welcome to ask.:fedora:edora @openminded @rbarbosa

Please be so kind and read the section of #start-here to see how you can do the first step to help your selves.
For us it is also extremely frustrating when new users come here and like help without giving any information of their systems.

To begin, executing inxi -Fzx in terminal and post the output as </> Preformatted text here would help.

My issue is resolved, either by:

    sudo systemctl enable nvidia-suspend.service
    sudo systemctl enable nvidia-resume.service
    sudo systemctl enable nvidia-hibernate.service

if they were not enabled.

Then I reinstall the evdi driver that is included in the displaylink driver, since I had a kernel update.
The driver seemed to work, but I did:

  • run intalll
  • reboot & rmmod evdi ( otherwise installer complains it’s loaded )
  • run installer again and reboot
    The installer in my case is the one for ubuntu.

I also needed to set as mentioned here: Fedora 34 KDE unable to suspend after nvidia driver update

and edited /usr/lib/modprobe.d/nvidia-power-management.conf by replacing the “1” by a “0” and it looks like it’s working!

You may have another issue with the USB-c dock.
Check dmesg output for hints on the exact cause if the above did not help, it will hopefully point you further.
It may be xhci related.
Please post you findings, good luck!