Fedora 36 Kernel panic in KVM


I am currently running F36 and I was going to try a new window manager(WM). So I decided to download F36-GNOME from Fedora Media Writer (FMW) and test the new WM in the KVM.

However, after installing F36 to the virtual hard drive and running sudo dnf upgrade two things happen:

  1. The terminal closes suddenly near or at the end of the upgrade process
  2. Kernel panic occurs after the reboot

I have also tried to run F37 Beta and F36-XFCE in KVM to see if there’s something wrong with either KVM or FMW and I have not encountered the same problem (they are working fine).

Is there something wrong with the F36 iso in FMW?

Is the VM drive too small to allow a full upgrade?
This sounds like it is possibly running out of space when trying to do the upgrade. The kernel panic could be caused by corrupted files with an incomplete upgrade.

It was not actually, I gave about 40 GiB and before that 80GiB.

I am just leaving my computer like that and not closing anything etc…the terminal suddenly closes by itself. I am not sure it closes either at the end or near the end cause I kind of missed it. I have tried this like 5 times I guess.

Interestingly I run F36 in KVM like a couple of weeks ago without a problem. Then I recieved a FMW upgrade. I guess after that I started to experience problems

Please try:

  1. offline update
    Restarting and Offline Updates - Fedora Magazine

  2. Switch to Console and run dnf upgrade in text mode

It will isolate a not of factors on why the upgrade is aborted and failed.