Fedora 36 colors are dark, dull and display incorrectly

Greetings Fedora community,

I’ve recently installed Fedora 36 Gnome, and the pure Gnome experience is the best. I’ve also installed the proprietary Nvidia drivers and set my Nvidia GPU as my primary as per this Fedora Docs guide , everything installed and worked perfectly. However I do have some sort of color issue that I am absolutely unable to solve. On other distros like Solus, EndeavourOS, PopOS, my colors for my single laptop display are bright and colorful. But on Fedora the colors are deep, dark reds, and olive army greens, I don’t know what the issue is, but I enjoy Fedora and don’t want to leave it because of this issue.

With Fedora 36, my colors look muted and dull. I’ve tried using the exact same .icc color profile file as my EndeavourOS Gnome install that displays colors correctly, but for reason(s) beyond me, Fedora (or perhaps Nvidia?) won’t display colors correctly even with that .icc file.

Steps I’ve taken so far include turning all the color profiles off in Gnome Settings, with little results. I’ve tested various other .icc color profiles to no avail. I even tried downloading a few .icc files for Acer displays with mixed results, but no matter what I just couldn’t get the colors to not look dark and faded.

I’m running out of ideas and I would really like to keep using Fedora, but I need to be able to fix this issue somehow. I would greatly appreciate any help to track down the issue or if it’s just some .config file I need to add a few parameters to and be all set I would be very grateful for any guidance. As far as I can tell I am using the full dynamic range of colors with my Nvidia GPU, but I am just stuck on this issue right now.

I have an Acer Aspire E5-576G laptop with an Nvidia MX150 and an Intel integrated card, running on Xorg btw. I’m happy to provide any more details for anyone I’m just not sure what else I can do to try to fix this issue, thank you.

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Are you using a docking station?

1 Like

Thanks for the quick reply. And to answer your question no I’m not using any type of docking station or any type of peripherals other than my wired mouse. I’m a simple user, so it’s just a laptop and that’s it.

[scott@fedora ~]$ inxi -Fzx
  Kernel: 5.18.18-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.4
    Distro: Fedora release 36 (Thirty Six)
  Type: Laptop System: Acer product: Aspire E5-576G v: V1.32
    serial: <superuser required>
  Mobo: KBL model: Ironman_SK v: V1.32 serial: <superuser required>
    UEFI: Insyde v: 1.32 date: 10/24/2017
  ID-1: BAT1 charge: 10.9 Wh (100.0%) condition: 10.9/62.2 Wh (17.6%)
    volts: 12.7 min: 11.1 model: PANASONIC AS16B5J status: full
  Info: quad core model: Intel Core i5-8250U bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 3325 high: 3401 min/max: 400/3400 cores: 1: 3401
    2: 3400 3: 3400 4: 3401 5: 2800 6: 3400 7: 3400 8: 3400 bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915
    v: kernel arch: Gen9.5 bus-ID: 00:02.0
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Acer Incorporated ALI
    driver: nvidia v: 515.65.01 arch: Maxwell bus-ID: 01:00.0
  Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-7:4
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3 driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa gpu: i915
    resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce MX150/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.65.01 direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.18.18-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
    v: kernel bus-ID: 03:00.0
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000
    bus-ID: 04:00.1
  IF: enp4s0f1 state: down mac: <filter>
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-5:3
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 238.47 GiB used: 130.24 GiB (54.6%)
  ID-1: /dev/sda vendor: SK Hynix model: HFS256G39TND-N210A
    size: 238.47 GiB
  ID-1: / size: 236.87 GiB used: 130.03 GiB (54.9%) fs: btrfs dev: /dev/dm-0
    mapped: luks-dd1df2eb-658f-4be4-86b8-8271fd0832d9
  ID-2: /boot size: 973.4 MiB used: 208.6 MiB (21.4%) fs: ext4
    dev: /dev/sda2
  ID-3: /boot/efi size: 598.8 MiB used: 14 MiB (2.3%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 236.87 GiB used: 130.03 GiB (54.9%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-dd1df2eb-658f-4be4-86b8-8271fd0832d9
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 73.0 C pch: 64.0 C mobo: N/A gpu: nvidia
    temp: 60 C
  Fan Speeds (RPM): N/A
  Processes: 342 Uptime: 26m Memory: 15.5 GiB used: 3.67 GiB (23.7%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 41
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19

One simple thing that may be an issue is modesetting.
During boot you can (from the grub menu) press the e key to edit the options. On the line that begins with ‘linux’ there is likely a nvidia-drm.modeset=1 If you change that to nvidia-drm.modeset=0 then finish booting with ctrl-X it will start without modesetting enabled and you can quickly see if there is a difference.

This change is temporary and will not be in effect with the next boot so this time it is only for testing. If, however, it makes the change you are looking for it can be made permanent by editing /etc/default/grub and making the same change in the line beginning with “GRUB_CMDLINE_LINUX” then running grub2-mkconfig -o /boot/grub2/grub.cfg which will make that change permanent for your system.

Additionally, this gnome settings screen allows setting a color profile for your display where you may be able to adjust the colors as needed.

Thanks for your suggestion. I gave that a try and reboot, it unfortunately it only made the colors look even worse and with nomodeset to 0 it made the performance and animations slow and screen tearing, so that option was worth a try, but didn’t prove the results I was hoping for, but I thank you for the suggestion nonetheless. I’ve also adjusted color profiles before, but none of them make the colors vibrant again, the reds always end up like a burgundy red instead of like a light cherry red. My eyes just can’t get used to it as the colors are being displayed incorrectly, I just don’t know what settings I can do to fix this. I really don’t want to have to uninstall Fedora ya know what I mean. But the color issue is a deal breaker for me if I can’t fix it.

1 Like

Another thing I can think of is the brightness settings on your laptop screen or the eye saver settings. Both of which can lower the intensity of the whites & reds and increase the blues. The eye saver is available under the gnome settings → display → nightlight settings. The colors may also be influenced by what you have chosen as the desktop background and the theme in use.

Don’t know if that will help, but maybe?

Tried those as well, but to no luck. I think it might have something to do with Nvidia, but I don’t have this problem at all on any other distro when running Gnome, so it’s most unfortunate. I’m probably going to have to reinstall EndeavourOS this week since this issue I have is not common enough to find easy/known solutions. Truly a real bummer, Fedora runs great otherwise. But thanks for the help so far of course!

Could you try fedora KDE spin and check whether it works fine?

I use Fedora for it’s pure Gnome. I want to use Gnome, not KDE…

I am not asking you to use only KDE and leave gnome.


You asked me to wipe my entire system to install a completely different setup. That isn’t really a good solution or helpful advice…

For what it’s worth, it’s possible to have gnome and KDE installed on the same machine and switch between them without reinstall. The KDE Spin can also be tried with a live image, without installing anything. That said, it’s also a perfectly valid topic to ask how to make this work in Gnome.

1 Like

Can he also install the nvidia drivers without have to reboot? I guess this is the point.

Is there an alternative driver who could be tested ?

Yes this is what we try to help here to find out … a bit more collaboration would be helpful.

You could also use a F35 wokrstation live ISO and do the check proposed from the other participants.

Since the user has both Intel and nVidia, the display itself is likely running on the integrated Intel card. Might be useful to see if the colors are better when launching in discrete mode (or DRI_PRIME=1). Ultimately, the KDE spin is going to have the same drivers, anyway.

Drivers can be installed without rebooting. Activating them with the gui desktop would require a reboot though.

The fact this is a laptop with dual GPU reminds me of something I was forced to do in order to get the nvidia drivers working for the built in screen. The screen by default may be limited to running on the IGP without proper config.

  1. Install the nvidia drivers from rpmfusion.
    dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda
  2. sudo cp /usr/share/X11/xorg.conf.d/nvidia.conf /etc/X11/xorg.conf.d/
  3. reboot
    This allows the nvidia gpu to use the built in screen
  4. log back in with xorg instead of wayland.
    to activate the xorg config for nvidia.

It also may be necessary to make the nvidia GPU primary by editing the new file /etc/X11/xorg.conf.d/nvidia.conf and adding Option "PrimayGPU" "yes" to both stanzas of that file, then reboot to activate it.
Instructions are here


Thanks for writing out all the steps, but as I mentioned in my first post, I followed the Fedora docs to set up my Nvidia GPU as the primary, and even after reboots and trying both Xorg or Wayland, the color results still prove undesirable, which is most unfortunate. Not sure where else to go from here, but I appreciate everyone’s efforts.

Limited RGB Range by default?

Had this on Plasma, luckily there is an option to switch it easily

Thanks for the link, but I’ve already tried those steps before in that exact post before (they have a similar one in the r/Gnome subreddit too), with no different results because my laptop says I’m already running my RGB range in full.

I’ve tested setting it to “limited” just to see and that does change the colors (they look even worse), so setting it back to “full” just puts me back to square one, with colors that are still unfortunately displaying incorrectly.

This might not be relevant, but it could be something simpler going on. I noticed this recently and the issue was that my monitor color profile just needed to be changed on the monitor itself. I changed it to one of the stock profiles and that made an significant improvement for me. I had done a “custom” profile for an HP and never switched it when I got a Lenovo. It turned out to be my monitor settings and nothing wrong with the video driver itself.

Steps I’ve taken so far include turning all the color profiles off in Gnome Settings, with little results. I’ve tested various other .icc color profiles to no avail. I even tried downloading a few .icc files for Acer displays with mixed results, but no matter what I just couldn’t get the colors to not look dark and faded.

The color profiles was the very first options I tried to change, using the default, using others, using none, but nothing got the colors to the levels that I am used to.