Fedora 35 PPC64LE Radeon RX580 no video

A couple of years ago I assembled a Raptor Systems Blackbird IBM POWER9 board into a case with a Radeon RX580 GPU, installed a version of Fedora Linux and I don’t recall having to do anything special to make it work.

This week I dropped the Radeon back into the Blackbird which now runs Fedora 35 Workstation, and it doesn’t produce video.

uname -r

The card is seen along with the Blackbird’s built-in aspeed one:

lspci | grep VGA
0000:01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev e7)
0005:02:00.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 41)

And the kernel is loading modules for it:

lsmod | grep -i amdgpu
amdgpu 8257536 1
drm_ttm_helper 262144 3 drm_vram_helper,ast,amdgpu
ttm 327680 3 drm_vram_helper,amdgpu,drm_ttm_helper
mfd_core 327680 1 amdgpu
gpu_sched 327680 1 amdgpu
i2c_algo_bit 262144 2 ast,amdgpu
drm_kms_helper 524288 5 drm_vram_helper,ast,amdgpu
drm 851968 10 gpu_sched,drm_kms_helper,drm_vram_helper,ast,amdgpu,drm_ttm_helper,ttm
i2c_core 327680 8 drm_kms_helper,i2c_algo_bit,at24,ast,amdgpu,i2c_opal,regmap_i2c,drm

The only clue I have found so far comes from dmesg, which says in part:

[ 121.619204] amdgpu 0000:01:00.0: [drm] Cannot find any crtc or sizes
[ 133.894384] amdgpu 0000:01:00.0: refused to change power state from D0 to D3hot

I have tried booting by adding a kernel command line parameter ‘amdgpu.dc=0’ which made no difference and with ‘amdgpu.aspm=0’ which gave me video from the GPU during boot, but not after the login prompt is displayed.

Any input from people with experience in getting Radeon cards going on recent kernels will be much appreciated.



sudo grubby --update-kernel=ALL --args=“modprobe.blacklist=ast”


As an additional note, this disables the onbaord aspeed video card (ast kernel module) so that only the other discrete GPU is available.

Hello @mcarden ,
Would you be so kind as to mark this post as the solution for you? That way someone else who may have the same or similar issue can find your solution here.

@jakfrost I’ve clicked the ‘Solution’ checkbox. I hope that’s what’s needed.