2 GPUs, no video output on the new one in BIOS or OS

Wondering if anyone has any advice on getting video output on a GPU. I just got my hands on a Radeon 6800 XT (upgrading from GTX 1060), but there’s no video output (from BIOS or OS) on that card, even though it’s recognized in BIOS (after firmware update) and OS. I’m also running Silverblue (for extra fun). In “About” the graphics are listed as running “NV136” after I removed the nvidia drivers and unblacklisted the kernel arguments blacklisted from the NVIDIA install – but still the only video output (even on the same cable to same monitor) is via the NVIDIA 1060.

Any advice/leads appreciated. Is there a way I can tell Fedora Silverblue to do video output via another card that it sees?

Thank kindly!

Motherboard: ASUS TUF GAMING X570-PRO (updated BIOS 4802)
CPU: AMD Ryzen 7 5800X 8-Core Processor
OS: Fedora Linux 38.20230915.0 (Silverblue)

lspci -nn | grep VGA
05:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1)
0d:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] [1002:73bf] (rev c1)

Below are some other outputs that I believe may be useful, but I’m not entirely certain in what way.

$ glxinfo | grep -i device
    Device: NV136 (0x1c03)
$ lsmod | grep -i amdgpu
amdgpu              11882496  0
iommu_v2               24576  1 amdgpu
drm_buddy              20480  1 amdgpu
gpu_sched              53248  1 amdgpu
video                  77824  3 asus_wmi,amdgpu,nouveau
i2c_algo_bit           20480  2 amdgpu,nouveau
drm_suballoc_helper    12288  1 amdgpu
drm_display_helper    208896  2 amdgpu,nouveau
drm_ttm_helper         12288  2 amdgpu,nouveau
ttm                    98304  3 amdgpu,drm_ttm_helper,nouveau

This seems to be because the OS was installed with the nvidia and then later you removed it and installed the amdgpu.

The initramfs probably still has the drivers for the nvidia and does not have the drivers for the amdgpu.

Fixing that would be my first step since the initramfs must support the installed gpu.

I think I would suggest reinstalling the nvidia gpu, then after booting create a new initramfs with dracut using the --no-hostonly option to it will load all drivers instead of only those for the hardware installed.
sudo dracut --force --no-hostonly
After the new initramfs is built then swap gpus and repeat the dracut step to build the new initramfs with only the drivers for the installed hardware.
(I think the default is using the --hostonly option)
sudo dracut --force

You may also be able to use sudo dracut --force --adddrivers amdgpu or similar, but I have never tried that.

1 Like

Do not run Dracut manually on Silverblue, it will not work.

What’s your rpm-ostree status? Have you double checked that the NVIDIA kernel arguments have been removed from the kernel command line / boot entry?

1 Like

Fairly sure it’s an return situation. The “no video on bios” made me suspicious.

I posted more here: 6800 XT - No Video Output (BIOS or OS) - Advice before RMA? - Build a PC - Level1Techs Forums

Rpm-ostree status doesn’t show any nvidia anymore, and kernel parameters blacklisting etc. have been removed.

I even booted from live USB, but BIOS and OS still have no video output.

Thanks all for responses. If I am missing something obvious would love to know.

If it does not boot a Live CD then there is indeed not much we can do.

Make sure to check your cables, screen, etc.

1 Like

Yeah, I’ve swapped pcie slots, power cables, output cables… It all works for the 1060, nothing for the 6800.

I’m assuming since the card is recognized by Linux that the issue is somewhere in the cards video output specifically, but beyond that mental leap I’m at a loss.

Thanks for the response!

I have an AMD RX 6700 XT and it worked out of the box, no config, no tweaks.

1 Like


1 Like