Dual monitor and Fedora 38 Silverblue

Over the past couple of years, I was getting happy as I saw common but incredibly frustrating linux-on-the-desktop issues getting solved: audio, hibernate, printer, etc.

Now, when I’ve decided to switch to Silverblue as my primary, the “second” (actually my primary) display doesn’t work. The OS doesn’t see it at all.

Primary: 27" 1080p, landscape. Connected via DisplayPort.
Secondary: 24" 1080p, portrait clockwise 90 degrees rotated. Connected via HDMI.
No separate graphics card, working from onboard graphics on AMD Ryzen 5600G.
The OS only sees and uses the 24" display.

I should note that I use up all the ports on both monitors.
Each of my 2 machines (one of which is running Silverblue) connects to each of the monitors.
I manually switch source on the monitor.

For one random “session”, both displays worked and I thought all is well.

Please, can someone help me sort this, so I can go back to doing regular work and stop wasting time trying to fix time-devouring issues.

You mention that it used to work. What was the system where it used to work? Silverblue uses the same kernel, mesa, etc. packages as Fedora Workstation so if it works on Workstation, it’s likely to work on Silverblue.

Thank you, it’s reassuring to hear from you (I see your blog!).

It worked on the same system.
I was trying to switch sources, reboot, turn monitor power on/off.
While doing various permutations of these, after a reboot of the system, I saw output on both displays… just once.
Oh, this was right after I updated my BIOS from an older version to the latest available (B550M AORUS PRO).

Seems to work now.

Here’s what I did:

Plug in only DisplayPort. The monitor that wouldn’t work before, now works.
Go into BIOS and select initial output target (forgot its name, it’ll vary by mobo manufacturer anyway) to Integrated Graphics Driver.
Then, force integrated graphics for good measure (because I don’t have anything on PCIe; no external graphics cards).
“force integrated graphics” => What do I do with integrated graphics? Answer is to ‘force’ using it.
For people with a graphics card, you’d want to disable integrated instead.
Save & reboot.

Thank you @siosm for your quick initial response.
Sincerely appreciate it.

I suspect this is a default hardware config.
With workstation on a laptop that has 2 GPUs the default seems to be that the laptop screen always uses the iGPU and the external screen always uses the dGPU. It can be forced that one GPU manages both ports as you have seen.

Sometimes if one is using the built-in (iGPU) on a desktop the same actions seem to occur.