F38 Silverblue, second monitor "unknown display" black screen

Hi all,

Fedora Linux 38.20230421.0 (Silverblue)
AMD Ryzen™ 7 PRO 4750G with Radeon™ Graphics × 16

The second monitor is always a black screen, listed as “unknown display 640x480”. This persists on wayland and Xorg.

Prior to f38, the it happened only after a suspend, and a hard reboot solved the problem, but now on 38 that doesn’t work either.

When I turn on the second moitor and scans the sources, I see this in systemctl -r -k, so thats three scan loops.

Apr 24 12:09:57 fedora kernel: [drm:detect_link_and_local_sink [amdgpu]] *ERROR* No EDID read.
Apr 24 12:09:48 fedora kernel: [drm:detect_link_and_local_sink [amdgpu]] *ERROR* No EDID read.
Apr 24 12:09:39 fedora kernel: [drm:detect_link_and_local_sink [amdgpu]] *ERROR* No EDID read.

I have no idea on how to approach this, it’s way above my skill level, so if anyone have a fix, pls chime in.


(EDIT: I removed the debug-info that was here)

Yeah, uh well, unplugging and re-plugging the DP → HDMI adapter from the machine (not just the HDMI into the adapter-port) when the machine is running worked…

This sounds like a race condition where the attempt to read the device EDID data occurs before the adapter is recognized. Unplugging the adapter then plugging it back in then seems to do it in the proper order.

Maybe someone else has an idea how to handle such a problem, but I don’t use silverblue so cannot assist.

That sounds very reasonable, yes, and gives me other options than assuming the EDID was somehow mangled by the adapter and needed to be set hard.