Fedora 35 Fails to boot up from Suspend, the screen stays blank

Dell Laptop
Intel Core i5 8250u
GPU1: intel UHD 620
GPU2: AMD 530
SSD Nvme

Tried Kernel and 5.15.4 and 5.15.5 all with the same issue

1 Like

We need a little more information. What exactly do you mean by “fail to recover from suspend”? What exactly is the problem (e.g., freeze?), and when exactly does it appear? How does it develop? How develops the screen output? Does the output end in the command line or GUI? Is there an error message? The more information you give us, the more likely it is that we can help :slight_smile:

OK sorry
when i try to wake up my laptop from suspend it wakes up but the screen still black, fans are working and hard drive but the screen is not showing anything.
i had to keep pressing the power button to shutdown then boot again, first it happens few time but not with every suspend now it’s happening all the times,

1 Like

Have you just installed Fedora from scratch or have you upgraded from Fedora 34? If it is the latter, I assume this problem came with the upgrade?

It makes sense to have a look on the log files. My suggestion is, boot your machine, try the suspend (which will of course not work), then force shutdown by powerbutton as you did it before and then, boot it again. Now, get the log files of the last and of the then-current boot and show us.

Most important, the logs of the last boot (which finally ended in the black screen):
journalctl --boot=0

Complementary, your then-current boot after the forced shutdown:
journalctl --boot=-1

journalctl --boot=0

journalctl --boot=-1

Fresh install Fedora 35
Just install it month ago i was using Pop OS
but this is new issue, couple weeks ago when i start using fedora suspend was working fine,

1 Like

Unfortunately, I don’t see anything in the logs that points to the origin of the problem. However, given the last log entry (which is not an error), I found another present issue:

Related, recent issues here in ask Fedora:

This seems to be a kernel issue in conjunction with some hardware. Maybe the coming kernel updates will fix it. At the worst, do not use the function until the next kernel update and then try it again.

Another thing you can try is, if you have a proprietary graphics driver, deactivate it and check whether the problem persists with the default driver.

For one person it seems to be even the opposite: Joel switched from the default driver to the proprietary NVIDIA one and it worked for him (even if his problem is not the exact same, it could be a different manifestation of the same issue). So, this could be tried as well if proprietary drivers are an option for you.

By the way, are you still able to enter a terminal with STRG+ALT+F4 ?

I’m Using Open Source Drivers
AMD and Intel, i don’t have NVIDIA card
Can i roll back to the old LTS Kernel, i don’t know it was 5.10 Right?

That the Linux kernel community continues to update a kernel as LTS does not mean that the distributions do the same. For 5.10 there are still updates from the kernel community, so it is already 5.10.83. But Fedora focuses on newer kernels and is not designed as an LTS system. So I don’t think you’ll get updates for 5.10 in any Fedora repo anymore: the last official 5.10 update in Fedora was 5.10.23 for Fedora 33 (current: 5.10.83). In this respect, 5.10 seems to be not even tested with Fedora 35, which can cause many more problems (including security). Therefore I advise against trying to add this old kernel to your system.

However, I have never dealt with this specific question in depth and would therefore ask @mattdm if he can make a brief statement on this.


Recently I also having trouble with suspend with kernel 5.15 on my amdgpu. Not only that but also with poweroff and reboot. But on recent version 5.15.5 it fixed. The newer kernel 5.15.6 also work fine. Maybe you could try with kernel 5.15.6 first.

If kernel 5.15.6 didn’t work, you could try kernel 5.10 LTS that maintained by other Fedora user on Fedora Copr here: kwizart/kernel-longterm-5.10.

Thanks for the information! I didn’t know that repo. However, the author already

remind that 5.15 will be the next kernel LT.

So don’t forget to adjust your repos again when 5.10 exceeded its end of life. Given the repo structure (its no general LTS repo, but 5.10-LTS repo), there will not be an automatic update/upgrade to the next LTS!

Be aware that this kernel is not as good tested as the official kernel, and updates [1] [2] are sometimes a bit behind (which can be a security issue, depending on what you use your system for).

I am a bit suspicious because the majority of builds for fedora-35-x86_64 have failed with the same error (e.g. 77).

So it is less suitable if the system you use it on is critical. But with a little luck your system will also work again with 5.15.6 :slight_smile:

1 Like

I’ve updated to 5.15.6 this morning and the problem is gone :v: :v: :v:

Still Happening maybe recent updates broke it again but i’m still on 5.15.6 the latest Kernel

I’ve also been experiencing this issue the last few days, same hardware only I have an Intel i5 8350u, and no dedicated graphics. Downgraded to Kernel 5.10 manually for now, I know it’s a hack but I need suspend to work. I’ve also checked journalctl and found nothing to indicate what is going wrong.

Waking from suspend basically fails at random, sometimes it works and sometimes it doesn’t.