Suspend does not recover back the display


My system is amd ryzen zen2 architecture 5500U 6C/12T cpu
8gb ram
Kernel v : 5.16.20-200.fc35
Os: fedora 35 stable workstation
After yesterdays update there was a kernel update which lead to that issue how can solve this.?
should i post a bug report bugzilla

Use grubby to change the boot option to the last working one.

5.16.20 is EOL. I have doubts that this version get fixed.

But feel free to check if there is already a bug reported.

1 Like

5.17 is available from testing if you’d like to give it a go.


Updated to 5.17.4-200 still same issue what to do next.

What is the GPU? inxi -GSzx

Radeon RX Vega 7 is the integrated gpu


Kernel: 5.17.4-200.fc35.x86_64 arch: x86_64 bits: 64 compiler: gcc
   v: 2.37-10.fc35 Desktop: GNOME v: 41.4
   Distro: Fedora release 35 (Thirty Five)
 Device-1: AMD Lucienne vendor: Micro-Star MSI driver: amdgpu v: kernel
   bus-ID: 04:00.0
 Device-2: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 1-4:2
 Display: wayland server: X.Org v: with: Xwayland v: 21.1.4
   compositor: gnome-shell driver: gpu: amdgpu resolution: 1920x1080~60Hz
   renderer: AMD RENOIR (DRM 3.44.0 5.17.4-200.fc35.x86_64 LLVM 13.0.0)
   v: 4.6 Mesa 21.3.8 direct render: Yes

I’m facing the same weird issue
Whenever I suspend my laptop it doesn’t wake up again
I need to force shutdown to restart it and also when I’m force shutdown the bios entry changes to windows and actually I guess it is restoring to defaults. Waited for kernel update but no use with it. Tried different kernels 5.15 and 5.10 and reinstalled the kernel pkgs nothing worked out.

I’m actually not sure but I guess the cause of this problem is due to the steps I followed while installing the tlp. As per documentation in the , I masked the systemd-rfkill.service systemd-rfkill.socket services and removed the power-profiles-daemon. But after this, I uninstalled the tlp. This happened the night before the problem started. And in the morning I manually blocked the sleep and screen-locking and closed the lid of the laptop and when I turned it on after an hour it didn’t start which was usually turned on by pressing the power button once but it didn’t turn on and it only got right when I force shutdown it and after the reboot, my kernel-modules failed to start but everything worked fine and I disable the secure boot which is generally never been a problem but now with 5.17 kernel update the kernel is loading perfectly with secure boot and TPM on but still the issue of suspending didn’t go. I reinstalled the power-profiles-daemon and tried to unmask the services and enabled them but when I checked their status only systemd-rfkill.socket is active and running and the systemd-rfkill.service is inactive. To be specific the output is

$ systemctl status systemd-rfkill.service systemd-rfkill.socket

○ systemd-rfkill.service - Load/Save RF Kill Switch Status
     Loaded: loaded (/usr/lib/systemd/system/systemd-rfkill.service; static)
     Active: inactive (dead) since Tue 2022-04-12 05:30:06 IST; 2 weeks 0 days ago
TriggeredBy: ● systemd-rfkill.socket
       Docs: man:systemd-rfkill.service(8)
   Main PID: 802 (code=exited, status=0/SUCCESS)

Apr 12 05:30:01 Fedora systemd[1]: Starting Load/Save RF Kill Switch Status...
Apr 12 05:30:01 Fedora systemd[1]: Started Load/Save RF Kill Switch Status.
Apr 12 05:30:06 Fedora systemd[1]: systemd-rfkill.service: Deactivated successfully.

● $systemd-rfkill.socket - Load/Save RF Kill Switch Status /dev/rfkill Watch
     Loaded: loaded (/usr/lib/systemd/system/systemd-rfkill.socket; static)
     Active: active (listening) since Tue 2022-04-12 05:30:01 IST; 2 weeks 0 days ago
   Triggers: ● systemd-rfkill.service
       Docs: man:systemd-rfkill.socket(8)
     Listen: /dev/rfkill (Special)
     CGroup: /system.slice/systemd-rfkill.socket

Apr 12 05:30:01 Fedora systemd[1]: Listening on Load/Save RF Kill Switch Status /dev/rfkill Watch.

What should I do now?

Also, my hardware is the same as
Ryzen 5 5500U with integrated graphics only and 8GB Ram

Probably want to start looking at logs/journal from boot where the problem occurred.

And consider filing a bug

@frankjunior does it work on a kernel version lower than 5.16.20?

i want to confirm its happening to my huawei matebook 16 with AMD 5800H. Having only the integrated iGPU. and its not easy reproduceble although it happens daily. but its random. sometimes after many hours a open up the screen, can login and everything is fine. but sometimes even after couple minutes, i open up the device again and the screen stays black and i have to force shutdown.

this is what the gnome-abrt is showning me on after all the times it happens:

WARNING: CPU: 15 PID: 1913 at drivers/gpu/drm/amd/amdgpu/…/display/dc/dcn20/dcn20_mpc.c:502 mpc2_assert_mpcc_idle_before_connect+0x10e/0x120 [amdgpu]
Modules linked in: wireguard curve25519_x86_64 libcurve25519_generic ip6_udp_tunnel udp_tunnel nft_masq tls uinput rfcomm snd_seq_dummy snd_hrtimer bnep nft_objref nf_conntrack_netbios_ns nf_conntrack_broadcast nft_fib_inet nft_fib_ipv4 nft_fib_ipv6 nft_fib btusb nft_reject_inet btrtl nf_reject_ipv4 btbcm nf_reject_ipv6 btintel nft_reject btmtk uvcvideo bluetooth videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common nft_ct videodev mc ecdh_generic nft_chain_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 ip_set nf_tables nfnetlink sunrpc qrtr snd_ctl_led iwlmvm vfat fat snd_acp3x_rn snd_soc_dmic snd_acp3x_pdm_dma snd_sof_amd_renoir intel_rapl_msr snd_acp_config intel_rapl_common mac80211 snd_sof_amd_acp snd_sof_pci snd_hda_codec_conexant libarc4 snd_hda_codec_generic snd_sof snd_hda_codec_hdmi edac_mce_amd snd_soc_acpi snd_hda_intel snd_soc_core snd_intel_dspcfg snd_intel_sdw_acpi snd_hda_codec snd_compress ac97_bus snd_pcm_dmaengine iwlwifi snd_hda_core
kvm_amd snd_pci_acp6x snd_hwdep snd_seq iwlmei snd_seq_device kvm cfg80211 snd_pcm irqbypass huawei_wmi joydev rapl snd_timer ledtrig_audio pcspkr sparse_keymap rfkill wmi_bmof snd snd_pci_acp5x mei snd_rn_pci_acp3x snd_pci_acp3x soundcore i2c_piix4 cm32181 industrialio acpi_cpufreq amd_pmc zram f2fs crc32_generic lz4hc_compress lz4_compress dm_crypt amdgpu drm_ttm_helper ttm crct10dif_pclmul nvme crc32_pclmul hid_multitouch iommu_v2 crc32c_intel ghash_clmulni_intel nvme_core ccp serio_raw sp5100_tco gpu_sched wmi video i2c_hid_acpi i2c_hid ip6_tables ip_tables ipmi_devintf ipmi_msghandler fuse
CPU: 15 PID: 1913 Comm: gnome-shell Tainted: G W 5.17.4-300.fc36.x86_64 #1
Hardware name: HUAWEI CREM-WXX9/CREM-WXX9-PCB-B1, BIOS 2.20 12/20/2021
RIP: 0010:mpc2_assert_mpcc_idle_before_connect+0x10e/0x120 [amdgpu]
Code: f9 ff 48 83 c4 10 5b 5d c3 cc 8b 7c 24 04 85 ff 75 1c 8b 74 24 08 85 f6 74 18 8b 4c 24 0c 85 c9 75 a4 0f 0b eb a0 0f 0b eb 94 <0f> 0b eb 98 0f 0b eb e0 0f 0b eb e4 66 0f 1f 44 00 00 0f 1f 44 00
RSP: 0018:ffffb422819477a0 EFLAGS: 00010202
RAX: 0000000000000001 RBX: ffff9bcd07670000 RCX: ffffb422819477ac
RDX: 0000000000000000 RSI: 0000000000004790 RDI: ffff9bcd07620000
RBP: 0000000000000003 R08: ffffb422819477a4 R09: 0000000000000000
R10: 0000000000000001 R11: 0000000000000008 R12: ffff9bcd07670000
R13: ffffb422819477d0 R14: 0000000000000003 R15: ffff9bcd00dce800
FS: 00007f3c675c8600(0000) GS:ffff9bd00dfc0000(0000) knlGS:0000000000000000
CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00007fde56da8008 CR3: 0000000109778000 CR4: 0000000000750ee0
PKRU: 55555554
Call Trace:

I was actually looking at i didn’t find anything wrong but if you want i will post that log.

Yes it was alright i have tried with 5.16.18 and older previous kernels it was okey and fine. Now i only have 5.16.18 after update 5.17.4

Sure i will.

Works correctly on 5.16.18-200 and doesn’t seem to work on anything newer than that.

As far as journal logs… last entry is the attempt to suspend. Nothing after that. It just fails to re-start.

Apr 22 11:21:40 droid systemd-sleep[6623]: Entering sleep state ‘suspend’…
Apr 22 11:21:40 droid kernel: PM: suspend entry (s2idle)

I have the same issue, it started a week or so prior. I even switched from fedora to the silverblue edition (partly because of this issue, partly because I just wanted to try it out), but still the issue persists. One thing I’d like to mention is that I have a laptop and the laptop wakes up when I plug it in. It only doesn’t respond when not plugged in.