Fedora 35 - Cannot login after fresh minimal install


Today I installed a Fedora 35 on my RaspberryPi4 (aarch64). I left defaults for the installation, keyboard layout was left unchanged (en-US) and my selection of software was set to minimal. Drive partitioning was also left to auto. I set the root password and created myself a user from the installer level. I tried installing two times - with and without a password, but none of them let me login.

I tried the same with minimal installation on my desktop in VirtualBox, but the result was the same. I did that to check whether the problem isn’t with the RaspberryPi itself, but doesn’t seem to be.

I used the “Everything-netinst” ISO in both cases. What can I do in this situation to succesfully login?

Any help appreciated

Welcome to ask.:fedora:edora @kazik

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

It would might be a good idea to read the section #start-here to get an idea what kind of info we are looking for.

I do not know what kind of installer the aarch64 image uses?

On Virtualbox did you use the x86_64 version?
There i know, that you get asked if you want to login with ssh using the password you have to activate this option.

Are you try to login in a DE or SSH or is it just a normal terminal login?

Thanks for the reply! First of all:

Wish I could do that. As I said - this is a fresh install. I couldn’t successfully login even once.

I used the “Everything” ISO (not raw image) from fedora alt download page. To me the installer looked the same as it was looking on the desktop in VirtualBox.

Yes, that’s correct.

I have activated this option during the install. I haven’t tried using it though. I will try connecting through SSH from my phone tomorrow.

Just into a terminal. It’s a minimal installation, no desktop enviroments.

In the meantime I also booted-up RaspberryPi OS and mounted the root partition of the Fedora system to check whether my user is even present in /etc/shadow and I couldn’t see it there. Is there a chance that the installer didn’t create this account and possibly didn’t set the root’s password too?

I also forgot to mention that at the end of installation, somewhat after the bootloader (grub) was installed, there was a python exception that stopped the installation. However the system boot’s up normally. Might this be a root of this problem? I could try reinstalling with different ISO, like Fedora Server.

I would guess that the exception that stopped the installation caused the problem. Usually an install has to complete successfully before the final configs, such as user creation are done. All the OS needs to be functional to support those final tweaks.

You might try a new install with the same iso, or a different one, but it seems that the installer itself booted, just an error at the end. Hope this can be worked out.

I used the Server ISO this time and performed offline install. It worked and I could login successfully afterwards. So it seems that there’s something wrong with “Everything” ISO. Thanks!

Did you do the verification of the Everything iso you downloaded? If you did and this error still occurred then I would suggest you file a bug report against the released ISO.

Yes, the checksums were fine for all the ISOs I downloaded.

I filled a bugreport but it seems it was already reported. After reading all the comments the one that suggested editing the boot options of installer has worked for me.

The option that solved the problem (added to boot option from grub menu):


Thanks for the help!

1 Like