Fedora 34 XFCE Nvidia drivers

HI Guys…

I have a Lenovo Thinkpad E470 laptop with an Intel(R) Core™ i5-7200U CPU @ 2.50GHz cpu & Nvidia GeForce 940MX graphics. Over the weekend I used the everything installer to install Fedora 34 with xfce. After the install had finished I booted to the desktop & straight away enable RPMFusion along with RPM Sphere. Next thing I done was to install nvidia-drivers following the page on the RPM Fusion website. After rebooting I could not boot to the desktop & would get stuck on the Fedora splash screen. I was able to get back to the desktop by removing the nouveau blacklist from grub. When back at the desktop I removed all nvidia-driver stuff that I had just installed & gave the auto-installer from copr a try. The same thing happened & I was unable to boot back into the desktop upon reboot. I’ve now permanently removed the nouveau blacklist from grub so that I’m able to boot without always having to modify grub on boot. Could someone please help me get my nvidia-drivers working so that I’m able to play games on steam & have a desktop experience that is free from screen tearing. Many thanks in advanced…

Nvidia cards can be tricky to get working. What version of the driver is rpm-fusion installing? Anything in /var/log/Xorg.0.log?

I’m assuming the latest available driver is what is installed. I first tried akmod-nvidia using dnf & whenever I uninstalled it I then tried sudo nvautoinstall --getall. Here’s a copy of my Xorg.0.log

Disable secureboot from bios/uefi .

Install nvidia driver .

If you have Nvidia optimus intel/nvidia vga ,try config lightdm before reboot (for xfce/lightdm ).