Fedora 32 backgrounds

It’s not a world changer - but is there an simple (not rpm-ostree layered or extracted from an rpm file) way to get the current crop (version 32) of Fedora wallpapers/backgrounds and extra wallpapers into Silverblue ?

I also noticed that. The default wallpaper for f32 is present under /usr/share/backgrounds/f32/default/f32.png but it does not show in the background settings.

Only if i layer f32-backgrounds-animated on top of the system do i also see the default background for f32.

Edit: And to answer your question: I do not think there is any other way unless someone from the Silverblue team adds more of the f32-backgrounds-* packages to the base image. So layered packages or the simple png files extracted are your best options.


Backgrounds for Fedora can be found here if you change the branch you can find backgrounds for previous versions of Fedora. For other background packages you can find the spec files used to create the RPMs here which will show you where the source images are downloaded from.

You can place them in ~/.local/share/backgrounds for them to be automatically added to your choose background dialog. Note you can’t place them in /usr/share/backgrounds without layering them with a package.

Thanks @eskse as you pointed out - the work-around is to download the backgrounds and copy them to your users .local/share/backgrounds. Thanks for the info on this. There are fewer new backgrounds than I expected (including the extras) - so this is not a big deal.

I also just noticed on my regular Workstation - which is also upgraded to 32 - that the new backgrounds never showed up there as well. So this is not Silverblue specific and as @gierthi points out can only really be “fixed” if they are added as packages to the base.

The default background seems fixed! The packages got updated. I did remove f32-backgrounds-animated and the single default background is now there correctly in the settings.

Yes - they just got updated on Workstation as well and the F32 default background now shows up. (not my favorite - but it’s there)