Fedora 30 Workstation - Online Accounts freeze on fresh install


I am on a fresh install of Fedora 30 Workstation. I found out that during initial setup, when trying to set my Google account, it would freeze after accepting to give Gnome permissions.

This behavior continued after the setup. I am now able to use my OS normally except for the Online Accounts functionality.

  • It hangs for about 5 minutes, then it either gives me the option to force close the settings app, or it adds the Google account, but then synchronization does not work (even with all toggles turned on);
  • I saw the same behavior when trying to add a Microsoft account. It froze, then added the account. However, this time, the email sync worked (I could open it on Geary);
  • I have 2FA on Google;
  • This feature worked normally on Fedora 29 (which I didn’t upgrade from) and Ubuntu 19.04, on the same computer;

This is where the UI freezes: (the progress bar doesn’t move either)


I’m kind of a newbie so I don’t know exactly if there are any logs I can get, and where/how to get them. The only additional information I have on it is that trying to open Geary (from Flathub) with my Google account added shows me the following error after a while:

Geary version: 3.32.1
GTK version: 3.24.8
Desktop: GNOME
Account id: goa_account_1558091804_1
Service host: imap.gmail.com
Error type: GIOError 24
Message: O tempo limite foi alcançado
Back trace:
 - unknown
 - g_simple_proxy_resolver_set_uri_proxy
 - g_task_attach_source
 - unknown
 - g_simple_proxy_resolver_set_uri_proxy
 - g_simple_proxy_resolver_set_uri_proxy
 - g_main_context_dispatch
 - g_main_context_dispatch
 - g_main_context_iteration
 - g_application_run
 - unknown
 - __libc_start_main
 - unknown

I’d appreciate any help. Thanks in advance!

You should look at the logs and see if there is something interesting.
I think that you should look for something like “goa” or “goa-daemon”.

Viewing logs in Fedora: Viewing logs in Fedora :: Fedora Docs

Oh well. Apparently it was network related. I’m using my laptop on a different Wi-Fi now and it worked perfectly.

When I get home I’ll try to fetch the logs to see what was going on.