Fedora38: Cannot add online accounts

Hi there,
I got a problem adding a new online account by settings.
Here is what happens:

  1. I open settings → account and select google (even microsft has same problem)
  2. in the windows that appeas to select “something” is not visible anything (see picture one)
    Screenshot from 2023-10-20 11-33-25
  3. if I “select” with mouse the windows “content” and “drag” it (see the mouse hand cursor) i can see the text (see picture2)
  4. the journalctl show following messages (the first 2 once i open the google account window, the last appear when i close it) see picture

My system has the following Nvidia:
VGA compatible controller: NVIDIA Corporation GA102 [GeForce RTX 3080] (rev a1)
All fedora packages are updated.
I also already disabled all gnome shell extension but same problem.
In the following picture the settings->about details.

where the strange thing is that no gnome version is displayed.

I suspect my gnome (coming from some fedora update) because also meany other errors are in the log about gnome.

Can someone help me debug this issue?

Thanks a lot in advance

It works fine here (both the online accounts dialog and showing GNOME version). Try creating a new user account and use online accounts there. Do they display correctly?

You can check whether you’re not missing any Workstation packages by running:

sudo dnf group install workstation-product-environment

(that could fix the GNOME version display, but unlikely the rendering).

1 Like

Thanks @kparal,
The problem is i cannot see anything to possibly install online account as you can se in first picture.

Doing what you asked, istalled only following packages:

Trying again to add accounts after the installation, same behavior: blank windows not usable.

The gnome version in the “about” section was fixed: thanks:
Screenshot from 2023-10-20 12-27-01

You’re likely to have lots of issues with Nvidia on Linux. If it’s enough to drag/resize the window to display the content, I’d say that’s a good enough workaround.

Some seem to have issues, but in many years of using nvidia I have no issues.

Only the newest cards (3000 series and newer) have even had issues with installation for me, and that is because the nouveau drivers do not support them properly. Even with those cards the installation can be easily done by using the basic graphics mode then installing the nvidia drivers from rpmfusion.

Resizing doesn’t solve the issue at all.

I can see the text only selecting andf dragging with mouse, but once i live the mouse sx button, nothing is displayed.

I also had Nvidia (older) for ages and no problem.
Also I’m able to pèlay steam games without issue on linux.

change X11 to Wayland, can see account display.

1 Like

This actually resolved the issue on my end. A pretty weird bug nevertheless…

Thanks all, I’m away right now.
I’ll try to switch and let you know, even I’d prefer this bug beeing solved.

1 Like

After some “magic” update now it works with X11: