"Failed to mount API file systems" error on boot

I’m giving Fedora a second chance with F38 after an extremely disappointing experience with 37.

Several days ago, GNOME software stared crashing on startup. I tried doing a manual dnf update in terminal and rebooting, and while that went totally fine, GNOME software kept crashing

I’m sick to death of troubleshooting bug after bug after bug in Fedora, so I just tried restoring an earlier snapshot in timeshift from several days prior. Now, I’m getting “Failed to mount API file systems”, right after I enter my LUKS password.

So what’s broken THIS time and how to I fix it (short of just ditching Fedora completely and going back to Windows)?


I guess since this post seems to be in the complaint and negative attitude range most do not feel like adding to the noise.

If you were to post usable information and real questions like is suggested here we might be able to assist.


You want to talk about ‘negative attitude’ - how about we talk about the pointless passive-aggressiveness in talking down to a new user and blaming them for not posting ‘usable information’ , then not actually saying what information you need?

I put every bit of info and context into the OP that I could think was relevant - OS version, circumstances leading to fault and description of fault including specific error message. If I start writing essays about what i had for breakfast and whether its a “cubicle farm” (whatever tf that is…), then people moan it’s too long.

Frankly, the fact that the best you can do to elucidate on what “usable information” you expect, is copy paste a generic link (that reccomends what I did any) just says you have nothing to offer but judgement for your our satisfaction.

SO if you’re wondering where the “negative attitude” comes from? Well, physician - examine thyself.