"Failed to load /" U-Boot error

Recently, I have had to reinstall Fedora thrice, I believe due to this issue.

In the first two re-installations (Gnome first, then KDE) I booted in to the freshly-installed environments, installed packages and whatnot, etc. If I rebooted however, I would get stuck in U-Boot with the log ending with the following:

Failed to load ‘/’…
Booting: nvme 0:4

And then it would hang, and eventually boot loop a few times before it eventually landed me on recovery assistant. Yes, I followed the installation steps properly.

On the third reinstall though, it stopped doing that, and I do not know why. Someone else in the Matrix chat mentioned that they “installed Fedora Asahi yesterday and get the same error message every time [they] boot into it. [They] got a little scared but it has successfully every time despite the error.”

Does anyone know the cause of the error, or why it might have spontaneously stopped mattering? I still get the error, but it just doesn’t freeze anymore.

The Failed to load ‘/’ warning is a red herring, it happens on all systems and can be ignored. The boot loop isn’t normal though and looks like a genuine bug. Which model were you installing on?

The loop is just the watchdog kicking in, and recovery assistant means Linux wasn’t getting far enough to clear the panic counter. So that means something is getting wedged between U-Boot and the Linux kernel startup.

Best guess, something related to GRUB? Hard to say though, since that segment of the boot flow is pretty silent (especially the way Fedora hides GRUB and kernel output by default).

To debug this further: Press ESC after the u-boot “Press any key to stop autoboot: $N” timer has expired. This should result in in stopping in the grub menu.
In the grub menu edit the current entry and replace rgbh quiet with loglevel=7. This should result in the kernel log being displayed. If the kernel crashes during boot it can be helpful to film the boot process.

Macbook Air M2 2022

Oh this would’ve been great to know… To be clear, the third reinstall has not been having this issue, and I have no clue why. I thought it might’ve been an updated installer, but the GitHub repo hasn’t had a commit since last week, and all of the installs were within this last week.

Then again, maybe a package I installed (somehow) broke something? I may try to reproduce this error if possible by re-installing everything.

Just FYI I am seeing this same problem on my 2022 M2 Air.

I rebooted Fedora and its stuck at the same U-Boot screen.

Pressing Escape after the timer elapses does not bring up GRUB.

OK I have a feeling this is after dnf upgrade and it installs a bunch of grub updates

I have just reinstalled Asahi Fedora and running the upgrades again. Will report back if the same behavior

If it does I will hold the updates in RPM for now.

Do you remember if there were any changes which could affect booting? Installation of system packages like kernel, m1n1, u-boot, grub, shim, systemd*, …?
Did you remember if you change anything which could affect booting?

Please provide the output of ls nvme 0:4, ls nvme 0:4 EFI, ls nvme 0:4 EFI/BOOT, ls nvme 0:4 EFI/FEDORA from the u-boot prompt.

Yeh see above, grub got updated from dnf

rebooting now.

if it locks up again I will post output of the above as requested

EDIT: yes, same behavior. grub2-common, grub2-efi-aa64, grub2-efi-aa64-modules, grub2-tools and grub2-tools-minimal updated to 2.06-97.fc38


=> ls nvme 0:4

0 file(s), 7 dir(s)
=> ls nvme 0:4 EFI

0 file(s), 4 dir(s)
=> ls nvme 0:4 EFI/BOOT
966711 BOOTAA64.EFI
98192 fbaa64.efi
152 grub.cfg
3702256 grubaa64.efi
898936 mmaa64.efi

5 file(s), 2 dir(s)

=> ls nvme 0:4 EFI/FEDORA
143 grub.cfg
3702256 grubaa64.efi
898936 mma64.efi
966711 shim.efi
966711 shimaa64.efi
152 grub.cfg.rpmsave

7 file(s), 2 dir(s)

Update to grub2-*2.06-97.fc38 worked for mewithout issues. Judging by the file sizes your /EFI is identical to mine except for grub.cfg. What’s curious is that my /EFI/BOOT/grub.cfg and /EFI/fedora/grub.cfg are identical and yours are not. Please save both copies and compare them. If you can’t stop an obvious error in either of them try booting with each variant in both /EFI/BOOT/ and /EFI/fedora/. Use MacOS (recovery) for those manipulations.

And interestingly, the grub.cfg.rpmsave from EFI/FEDORA (presumably the original file before the upgrade) is the same file size as what is in EFI/BOOT

Use MacOS (recovery) for those manipulations.

Not really sure how to do this specifically

diskutil list to list your partitions and sudo diskutil mount disk0sX (where X is the partition index from the list) to mount the EFI partition, then you can inspect/modify the files. This works in a terminal in both macOS and recoveryOS.

1 Like

FWIW we have several users running into this (or something similar) here: Reddit - Dive into anything

1 Like

Duh of course, thanks! :slight_smile:

I will reproduce this again once more so I can do the diff on the grub configs pre and post grub upgrade for you guys! Stay tuned

It’s not necessary to reproduce it again. @marcan has reproduced the problem and the cause is that the update rewrote /boot/grub2/grub.cfg to a config which causes grub to reload itself indefinitely.


OK so work around for now post upgrade would be to simply restore the rpmsave from macos or macos recovery?

Do we know why this is happening yet?

Story here: Announcements - Fedora Discussion

Restoring the rpmsave file won’t fix it, you have to do what’s outlined in that post.

Perfect, working fine now! Thanks alot.