Error message when booting Fedora

I get an error message when I boot Fedora.
I’m on a Dell Inspiron Gaming 7567 and I have upgraded my ram to 32GB
I don’t know what it means and my installation gets stuck on “starting gnome desktop” and it doesn’t progress from there.

That’s a memory checksum error.

Have you tried reseating the RAM?
Check that there’s no dust, or obvious debris in the sockets. I also might try running memtest.

If reseating doesn’t clear it up, I’d hazard that you got some bad memory.

I took out the ram and put it back in. I even swapped the bays. I still get the error. I’m not too sure if it’s bad ram because the ram is brand new. I grounded myself well before installing it as well. I tried Linux Mint and I don’t get any such error with it. Just when I boot Fedora and Windows works fine too though I don’t have it on anymore.

Try running memtest86.

New RAM can still be bad, and not every system responds to a bad bank of memory the same way. It’s possible that only Fedora, out of the three is trying to address that specific bank on boot.
Memory issues can be finicky. Did the issue occur with the old memory? If not, I’d say that’s more than enough to cast the new sticks into suspension.
If it is the RAM, memtest86 will tell you for sure. It wont hurt, and the last thing you want is to wait to find a problem in your new hardware after the return period is up.

I ran memtest86 and there were no errors found.

what else could be wrong?


That is very strange.
Software doesn’t usually trip hardware errors such as this, though it’s possible the kernel, as compiled for Fedora, is doing something unexpected on this specific hardware.
There may be some information hiding in a nook somewhere that might help me.

You said that it hangs on “starting gnome desktop”, is that during init (like seen in the picture), or does the desktop start, then hang? And either way, can you change terminals with something like Ctrl+Alt+F3?

It doesn’t do anything when you press Ctrl + Alt + F3. It just hangs.

I took clear shots of the error.

I managed to get GNOME to work by following the instructions here

but I still get the mce hardware error when booting my pc… I’ve been googling it and most people think it’s the intel microcode. But I’m not sure how to install it or even update it on Fedora.

You could try to issue this command:
sudo fwupdmgr update

If the 7567 is the same model as LVFS: Inspiron 14 7000 Gaming/Inspiron 15 7000 Gaming (it should be), you should get the firmware (BIOS) update to the 1.8.1 version (even if on the Dell web site it is available a more recent 1.10.0 version, but it is distributed only as an exe file).

So am I supposed to downgrade the BIOS? My current version is version 1.10.0

Oh well, no!
1.10.0 is the latest one, so stay with that.

From what I’ve found, it’s not the uCode, it’s something to do with Dell’s custom BIOS firmware.

Seeing as Dell doesn’t want to fix it, or tell anyone how, there might not be anything we can do. I’ve see some people had varying degrees of luck recompiling the kernel with this or that option, but that seems like a lot of work to go through.

If you got GNOME working and there are no other issues, I’d say ignore it.
Unless something comes up that is obviously the result of it, then it’s likely a red-herring and not worth worrying about. Just a quirk of that machine when using Fedora’s specific kernel.