'oops' generated every boot: mce: Hardware event. This is not a software error

Hello everyone.

I’m having this log error every time my computer boots. I’ve looked for this particular message all over the internet but I found none like mine or even solved. Could someone help me resolve this bug? Bellow is the backtrace log file from the oops directory created by the error. It is the same message every time this crash occurs.

The kernel log indicates that hardware errors were detected.
System log may have more information.
The last 20 mcelog lines of system log are:
-- Logs begin at Mon 2019-05-13 22:06:06 -03, end at Wed 2019-05-29 09:48:55 -03. --
mai 29 09:39:55 dell-fedora mcelog[896]: mcelog: consider an update
mai 29 09:48:53 dell-fedora mcelog[896]: Hardware event. This is not a software error.
mai 29 09:48:53 dell-fedora mcelog[896]: MCE 0
mai 29 09:48:53 dell-fedora mcelog[896]: CPU 0 BANK 6
mai 29 09:48:53 dell-fedora mcelog[896]: MISC 78a0000086 ADDR ffb01e00
mai 29 09:48:53 dell-fedora mcelog[896]: TIME 1559134132 Wed May 29 09:48:52 2019
mai 29 09:48:53 dell-fedora mcelog[896]: MCG status:
mai 29 09:48:53 dell-fedora mcelog[896]: MCi status:
mai 29 09:48:53 dell-fedora mcelog[896]: Error overflow
mai 29 09:48:53 dell-fedora mcelog[896]: Uncorrected error
mai 29 09:48:53 dell-fedora mcelog[896]: MCi_MISC register valid
mai 29 09:48:53 dell-fedora mcelog[896]: MCi_ADDR register valid
mai 29 09:48:53 dell-fedora mcelog[896]: Processor context corrupt
mai 29 09:48:53 dell-fedora mcelog[896]: MCA: corrected filtering (some unreported errors in same region)
mai 29 09:48:53 dell-fedora mcelog[896]: Generic CACHE Level-2 Generic Error
mai 29 09:48:53 dell-fedora mcelog[896]: STATUS ee0000000040110a MCGSTATUS 0
mai 29 09:48:53 dell-fedora mcelog[896]: MCGCAP c07 APICID 0 SOCKETID 0
mai 29 09:48:53 dell-fedora mcelog[896]: CPUID Vendor Intel Family 6 Model 69
mai 29 09:48:53 dell-fedora mcelog[896]: mcelog: warning: 8 bytes ignored in each record
mai 29 09:48:53 dell-fedora mcelog[896]: mcelog: consider an update

I don’t know how to proceed since I’m new to Fedora and Linux OS, so if you guys need any other file/information please let me know. Thanks in advance.

Have a look at this post. Looks related:


Have you tried updating the firmware to the latest version followed by loading BIOS defaults, rebooting, setting your BIOS preferences, rebooting and then check if the error still is there?

Hello @RickBadKan,
Can you tell me a bit about your PC? I think it is a Dell, is it an AMD powered one? FWIW I have a similar error on my AMD powered GigaByte MoBo and it is of no consequence for me since my processor isn’t supported by MCE. Do a man mcelog to see some of the gory details about the log command and what MCE’s are.

1 Like

Thank you all for the replies! I’m a little short on time so I’ll take a look at every suggestion.

Thank you Francisco, I’ll have a look at this post to see if the issue is similar! (sorry, as a new user I cannot mention more than 2 users on a post :confounded:)

@patrickl No, I didn’t. Since I’m dual booting Fedora 30 with Windows, I actually don’t know if it will mess up in some way with it. I’m new on this Linux world, so I’ll have to do some research to see how to update my firmware and change de BIOS settings without collateral damage.

@jakfrost Yes, it’s a Dell but with a Intel Core i5-4200U CPU @ 1.60GHz and a AMD Graphics Card Radeon HD 8670M. I read the mcelog manual but I got confused; my Dell is a x64 bits, not a x86. So it doesn’t make much sense, since the manual says that is for x86 CPUs report errors detected by the CPU. Also - and I don’t know if it’s related - but my boot time is around 2 minutes from splash screen to the login one. Bellow is the systemd-analyze blame commands for more details.

rickkan@dell-fedora:~ $ systemd-analyze blame
         46.623s plymouth-quit-wait.service
         21.707s systemd-journal-flush.service
         21.232s firewalld.service
         20.037s udisks2.service
         15.341s lvm2-monitor.service
         14.425s dnf-makecache.service
         14.123s systemd-udev-settle.service
         10.181s systemd-fsck@dev-disk-by\x2duuid-2C91\x2d4C7D.service
          9.704s accounts-daemon.service
          9.206s polkit.service
          9.068s ModemManager.service
          9.002s sssd.service
          8.379s NetworkManager-wait-online.service
          6.697s initrd-switch-root.service
          6.467s var-lib-snapd-snap-core18-970.mount

Also, bellow are the CPU info file generated by the ‘oops’ in question:

Arquitetura:                x86_64
Modo(s) operacional da CPU: 32-bit, 64-bit
Ordem dos bytes:            Little Endian
Tamanhos de endereço:       39 bits physical, 48 bits virtual
CPU(s):                     4
Lista de CPU(s) on-line:    0-3
Thread(s) per núcleo:       2
Núcleo(s) por soquete:      2
Soquete(s):                 1
Nó(s) de NUMA:              1
ID de fornecedor:           GenuineIntel
Família da CPU:             6
Modelo:                     69
Nome do modelo:             Intel(R) Core(TM) i5-4200U CPU @ 1.60GHz
Step:                       1
CPU MHz:                    2582.104
CPU MHz máx.:               2600,0000
CPU MHz mín.:               800,0000
BogoMIPS:                   4589.36
Virtualização:              VT-x
cache de L1d:               32K
cache de L1i:               32K
cache de L2:                256K
cache de L3:                3072K
CPU(s) de nó0 NUMA:         0-3
Opções:                     fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm cpuid_fault epb invpcid_single pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts md_clear flush_l1d

Thank you all for the quick responses!

Welcome to the Linux world!

The reason I mentioned the firmware is that I have seen a BIOS upgrade solve (mce-related) issues on a Dell server. I usually take a pic of every BIOS settings screen before resetting to defaults. Here is a Dell link about upgrading the BIOS:

1 Like

x86 is the processor family (like ARM, PowerPC, etc…) and specifically Intel or Intel like (AMD, others). The 64 or 32 represent 64 or 32 bit processor data width. So if it states x86_64 or x86_32 the difference is only the data bit width.
So back to what I was saying earlier about the MCE Log, it is for processor errors reporting, and I am uncertain how much of it’s metric’s are actually used by Fedora. In any case, I have not run into it causing me issues, although my processor has due to AMD not totally following the standards WRT mapping IO. That shouldn’t be a problem with an Intel CPU since they were on the standards board when they were written (I say that with my tongue firmly planted in cheek). Definitely flash your BIOS up to the latest for the MoBo, since that often clears up these types of issues. Also, @FranciscoD noted above that there was a similar question from another user, that does seem related and could indicate your issue is in need of being brought to the mcelog developers attention by filing a bug → https://bugz.fedoraproject.org/meclog.
Sorry I can’t be of more help on this, I don’t have an Intel powered Dell to try it out on.

1 Like

Thank you guys for all the tips. I decided that since this bug report isn’t actually affecting the usage of the OS, I’ll just report it and leave it behind. If anything happens regarding the system itself, like malfunctioning, I’ll return here to try solving it.

Thank all you guys again!

1 Like

hi all I have the same problem mce error with a dell after installing fedora30 I even try to update the bios to version 1.2.7 but the error and always please someone would
he a solution

thank you