F40 regression? Internal audio output device not found

I just updated my existing Fedora 39 installation to Fedora 40 beta. Since the update, GNOME does not show any audio output devices. The internal microphone works fine however, gnome sound recorder shows realistic graphs when changing input volume.

I’ve already tried booting into the old kernel (6.7.9-200.fc39.x86_64 instead of 6.8.1-300.fc40.x86_64), but that did not help, i.e., the F39 kernel behaves the same as F40 kernel.

By accident, when trying to connect an external audio output device (a bluetooth classic headset), I noticed that the internal loudspeakers are listed and working now. When disconnecting the external audio output device, the internal device also gets removed again – but only if it has not been played to.

It seems like my device is using snd_hda_codec_realtek for the internal audio input/output.

I don’t know whether this is worth debugging, but if yes, where would I start?

Edit:
Probably related: Updated to wireplumber 0.4.90 No output devices (#25) · Issues · GNOME / libgnome-volume-control · GitLab

Hi Christian, same here (Notebook Acer Swift sf514 51) and kernel 6.8.2-300.fc40.x86_64

Hi, the same problem here. Not device sound after upgrade to fedora 40. Lenovo ThinkPad E1.

It seems there is a workaround…just connect an hdmi cable, choose from the gnome settings, audio item again, and you’ll find all TWO devices (internal audio & hdmi audio output). Select “internal audio”, disconnect the hdmi cable, and the setting resist on reboot. It works fine for me & my hardware.

Hi, I had a similar issue when upgrading to Fedora 40 Beta as well, and it turns out that my sound card profile was in “off”. I used pactl to see the avaiable cards (I omitted some of the stuff):

pactl list cards
Card #42
	Name: alsa_card.pci-0000_00_1b.0
	Driver: alsa
	Owner Module: n/a
	Properties:
                ( Properties ... )
	Profiles:
		off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
		( Profiles... )
		pro-audio: Pro Audio (sinks: 2, sources: 1, priority: 1, available: yes)
	Active Profile: output:analog-stereo+input:analog-stereo
	( etc. )

I don’t understand really well this prompt but I just tried to set the profile to something else and it worked for me:

pactl set-card-profile alsa_card.pci-0000_00_1b.0 pro-audio

And then some “pro-audio” devices appeared in settings as well as some other output devices. If anyone wants to try this you can type:

pactl set-card-profile <card-name> <profile>

I think it’s worth mentioning that I had a conflict with the alsa-sof-firmware package during the upgrade, so I downloaded the .rpm needed and installed it forcefully before the upgrade to F40 Beta. It seems to be related with audio devices, so maybe that caused problems in my installation.

1 Like