Audio devices not detected after fedora 39 update

Hi,

After upgrading my computer to fedora 39 yesterday, i encountered some problems regarding the sound on my machine.

Shortly after updating, there did not seem to be any problem, but after booting up the next morning, no sound would play through my headphones and gnome settings would only display “dummy output” for an output device. My microphone did not get detected either.

Running lspci -k shows that the audio card is connected, since the output is

01:00.1 Audio device: NVIDIA Corporation GA102 High Definition Audio Controller (rev a1)
34:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Rembrandt Radeon High Definition Audio Controller
34:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h/19h HD Audio Controller

but aplay -l returns

aplay: device_list:277: no soundcards found...

My alsa-info file can be found here, if you need any additional info just ask me!

Thanks for any help in advance!

I have never had the sound problems, but there are many threads ab out this subject on this forum with many solutions. Have you tried a search here and tried any of the already posted solutions?

If not then please do so.

so i looked for similar topics on this forum as well as on google and i cant find anything that quite describes my problem.
However, it seems that most guides suggesting to fix the “dummy output problem” rely on certain audio drivers to be installed (sudo lsmod | grep snd). This is not the case for me, and it seems that no audio drivers are installed?
Trying to run modprobe snd_hda_intel only returns

modprobe: FATAL: Module snd_hda_intel not found in directory /lib/modules/6.5.11-300.fc39.x86_64

which probably should not be the case from my understanding. Additionally, my alsa-info file also does not list anything under the “Loaded ALSA modules” section.
Is there any way to reinstall all kernel modules?

So i did some more research and i am more and more convinced that the problem is, in fact, the missing kernel modules.
I loaded fedora 39 onto a USB stick and ran the live OS, and sound was back to normal.
So how would i install these missing kernel modules?

@gamerik Have you found a solution yet? I have the exact same problem after upgrading to Fedora 39.

UPDATE:

I noticed that the kernel-modules-* package that contains the necessary drivers was not installed…

sudo dnf install kernel-modules and a reboot fixed the issue for me.

1 Like

You can use the Linux Hardware Database to see if other linux users with the same audio hardware are able to use it with recent kernels. Having used linux for many years, I’ve learned the importance of having USB alternatives to “built-in” sound and wifi devices that I can use while sorting out issues. With older hardware, developers may inadvertently break things with newer kernels, so it can take time (and good user bug reports) for fixes to appear. For non-free drivers, vendors have little incentive to support older hardware, so fixes may never appear, but linux users may eventually reverse engineer the hardware and provide drivers.

Using Fedora 38 with gnome multi-window interface I find that if my login shell is tcsh sound output does not work, but if it is bash it does work. I then have to run tcsh after logging in to get my old environment working. Can I make sound work from the start with tcsh as my shell?

Update from my side on the Issue: The last update cycle I did on my system seems to have fixed the issue. My front audio jack now works as expected and the volume control also was fixed.

Thanks to all the people that contributed, my guess would be that a recent update to pipewire-alsa package fixed it.

Thank you for posting this. I just upgraded to Fedora 40 and my kernel-modules package did not update from 38 to 40 and my audio broke completely. Your comment here fixed the issue for me. I updated kernel-modules, rebooted and my audio devices were back and fixed.

1 Like